Google Home live feed not working with Cam Pan v3

It does work sometimes but it is very intermittent. I know this probably isn’t a Wyze issue. It is probably a Google Home issue but their forums are completely unhelpful. This forum has been great. I did post this question in the Google Home forums but didn’t get any answers so I thought I’d try here. Once out of every 15 tries, the camera will actually show up but it takes forever to connect; 45 seconds or more. When it does not connect, all I get is what is in my attached screenshot. Is there anything I can do to make it work every time?

Does it work with the Wyze app? If not, check your wifi signal strength at the cam location with an app like Wifi Analyzer. I put a wifi repeater near my Cam Pan v3 and it works much better now.

@SmedleyBunker
It works perfectly with the Wyze app. There’s a Google Nest wifi access point in the same room and 10 feet from the camera. I have checked the wifi settings in Google Home and the camera is connected to that access point. I made sure of it because sometimes a device will hop from access point to access point if it’s right on the boundary between two APs. That isn’t the case here. Just to make double sure, I pulled up the AP on one phone and the camera live feed on another phone. The live feed failed to connect and the camera was connected to the correct AP the whole time. And, again, the live feed works perfectly in the Wyze app. This is why I started my original post with the fact that I think it’s a Google Home issue, not a Wyze issue.

I have also tried deleting and re-connecting my Wyze account to Google Home. I also re-synchronized the camera and the app with Google Home. Nothing seems to help.

If there is, I don’t know what it would be. Reading your posts, I get the impression that you’ve done all the right troubleshooting so far. The only other thing I would add would be ensuring that your Cam Pan v3 :cam_pan_v3: is up-to-date with its firmware, but I imagine you’ve already done that.

It seems like most of the users in another topic who are having this issue with Google Home are also iOS users, so at least you’re having some luck with Android. There are some suggestions in that topic about the things you’ve already done and also about playing with router settings or trying a different router entirely. I’ve never used Google Nest APs, so I don’t know if mucking about with that would do you any good or not.

I agree. Although Wyze does have its issues with Google Home/Assistant integrations…

…and that includes the way their own routines call their own services, apparently. :roll_eyes:

I also concur with your assessment of the Google Nest Community, unfortunately. My limited experience there has been much less helpful and significantly less engaging than the Wyze Forum.

I wish I had more advice at this point, because I’ve had a generally positive—though occasionally glitchy—experience with my Cam Pan v3s streaming to the Google Home app (Android) as well as a Google TV, and I want you to have that same or better experience.

@Crease

Thanks for the thorough response. I’ll chalk this one up to a Google Home flakey-ness issue. Google Home is apparently going through a whole revamp to integrate their AI into it and get rid of the old Google Assistant. They can’t even decide what to call it. Apparently, it was Duet early on. Then I got a notification to install/turn on Bard for the whole Pixel 8 Pro OS. So, I did that and it broke a bunch of voice actions in Google home. Now, I am getting notifications to turn off Bard and enable Gemini. I wish they’d make up their minds. Apparently, the different names are because they’re different AI models trained on different data sets…? Whatever. I just wish they’d settle on something that actually works. I have tried all of them and the only one that works consistently and doesn’t give any errors when I try voice commands is the old non-AI Google Assistant. But I did try the Wyze cam with all of them and they were all flaky as heck. So, I’ll just stick to the Wyze app and disconnect my Wyze account from Google Home entirely until Google can get their sh… stuff together. I noticed when the camera would load in Google Home that there is no way to pan or tilt the camera anyway. So, even when it does load, it’s missing features. lol. So, thanks again for the reply and I’ll mark this one solved.

You’re welcome! I often just think out loud in my responses, and I like sharing what knowledge I have when I can.

Apparently you’ve read a lot more into it than I have. I appreciate your sharing that.

Me, too. In addition to breaking routines, one of the things I’ve noticed recently is Assistant telling me that it doesn’t know which room to act on. For context, I’m in the Google Home Household both where I live and a family member’s home. Both homes have some common room names, like Kitchen or Living Room. If I want Google Home to turn off the lights in the Kitchen, I used to be able to say to a Home Mini, “Hey, Google, turn off the Kitchen lights.” Now if I say, “Hey, Google, turn off the Kitchen lights,” Assistant responds, “Sorry, I’m not sure which Kitchen you’d like to turn off.”

I’ve tried things like “turn off the Kitchen lights in this house” or even using the home names I’ve assigned in the Google Home app, but that doesn’t work for me, either. :man_shrugging:

I could work around this with routines, but then I’d have to remember what phrase I defined to trigger the event, and that doesn’t feel as natural. I shouldn’t have to do that, anyway.

Sometimes Google actually does (apparently) fix things that they break. When I had an issue with not being able to turn off a (Wyze, incidentally) smart plug after a predetermined time using a voice command, I found a relevant topic in Google Nest Community and contributed my own testing. I don’t know what good that actually did, but I like to think it shed some light on the wonky inconsistency of the problem.

Yeah, when it works, the stream in Google Home is convenient and easy to share with other family members, but it’s really going to be just a live view of whatever the camera looks at (and/or tracks, if it’s set up that way). The Wyze app definitely gives more of a full-featured experience, but Google Home works in a pinch (and it’s nice when it streams to a Hub or Chromecast or Google TV).

I don’t feel like I actually solved anything for you, but I genuinely appreciate the feedback and the vote! Thanks!

1 Like