Ghost rules?

Is anyone else having trouble with the ghost of deleted rules? I tried checking known issues but the link wasn’t working for me.

I had a rule for turning a light on with motion, then I got more blind, switches and sensors and made some more complicated rules to turn on lights with motion in the living-room. I deleted the old rule, and while watching a movie disabled the new rule.

With the rule disabled, that rule didn’t work but the old+delete rule kept triggering and it shows up in my event log as a triggered event with the deleted rules name. (It’s easy to tell since the old rule just turned on one light)

1 Like

I’m using android. I’m also having trouble with my Wyze Cam 2 and never got help. Here’s my reddit post 4 months ago. It’s annoying but I just create new rules to counter my old ghost rules. I have this invisible rule that it turns off my camera. I just made a rule to turn it back on a few minutes later. If anyone has a solution, please tell us. I tried everything. Disconnecting reconnecting. clear cache. unisntalling reinstalling.

I read in another thread the issue was resolved but, I’m having this issue now off V1 motion sensors. The rules I first disabled, then deleted are still impacting the white bulbs they were tied too. I created new rules to replace that workflow with what works now, and they get overridden. It really annoying and I’ve had to make workflows just to correct what the old ones do

I design and implement workflow for a living. Without knowing how they designed their app or network, I’d imagine the rules are copied somewhere on the back end where the disable and delete functions either don’t find or can’t change the rules (permissions?). However, another less likely scenario is they are able to be disabled and deleted but, something immediately replaced the new version with the previous.

Since the front end is responsive to changes, it’s likely nothing with the hardware or applications front end, I’d guess it to be between the database where rules storage happens and the backup/redundancy function.

That being said… Can’t you guy please reopen this issue and resolve it. It pus people in a position of have to buy new devices and trash perfectly good ones.



I’m also having a similar issue w cameras. We recently set rules to record an event and send a notification when motion is detected while we were away on vacation (normally we just use them to keep an eye on our pets when we’re out). We deleted all of these rules when we came home from vacation but days later we’re still constantly being recorded by Wyze. The rules don’t show up in the app at all—as far as we can tell there is no reason the cameras should still be recording.

Check your camera settings, if your camera is set to record events based on motion or sound or continuos your camera will keep following those settings.

Those settings are settings on the camera so they don’t follow or show up under the rules.

I’m not sure why you can set them up differently except that in the settings it uses image based movement settings not motion sensor movement. Rules allow you to set recordings based on the motion sensor, I’m not sure if you can link the camera’s image motion detection to record as a rule but even if you did the app pops up a warning because they don’t like (and can cause problems) if the initial unit and the action unit are the only (aka only one object is being effected) by a rule.

I hope that helps!

Nope—doesn’t help unfortunately. There is no default for these to record unless you set up a rule. They were no recording prior to the rule being set up. Now they are recording constantly.