Gaps in recording

Why do I get frequent gaps in the recording? (See attached picture.) This is a V1 camera. Does the memory card need reformatting?

Is the cards set to record continuously or only on motion? (Check in camera’s Advanced Settings.)

It’s continuous.

Are there actual gaps in this stream, or only in the shaded areas of the timeline? The timeline shading is known to not always be accurate. If there are actual gaps in the recording, I think I’d try changing from continuous to motion and back. Then power cycle the camera and reboot the app and see if that helps.

The gaps were really there. In fact, there was motion that should have been captured during one of those gaps, and there was not even a motion clip captured. My dog was chasing some kind of animal, and one camera caught it, but there was a gap in the recording when it got around to this camera.

I reformatted the memory card via the app, V1.3.125. I now have a couple of hours of fresh recordings with no gaps. But the Playback part of the app kept crashing when I tried to watch some recent playback. I can record clips off the recorded stream, but the playback crashed.

I submitted 3 Feedbacks through Google, I guess, when the app crashed. I don’t know if those get to Wyze, or just to Google. I just tried the playback again, and it isn’t crashing.

Another funny thing about that camera is that the thumbnail view is missing in the album. See the attached picture.

Another funny thing is that in one small part, there’s a glitch in the picture, such that there are two of me. Something happened with the compression and the keyframes perhaps…

Speaking of compression, I’ll be posting another topic about the image quality when there is a lot of detail in the picture. It’s really overcompressing, and lots of tree branches in the image causes a dramatic loss of image quality.

Just an update to keep this thread alive. Still getting gaps in the recording on two of my V1 cameras.

Could this be a memory card problem?

Wyze - what would you need to help diagnose the problem?


RE: Could this be a memory card problem?

The definitive test is to use h2testw. It writes a varying but reproducible semi random pattern on the card to fill it up, then reads it back and compares with what should have been there. If it finds a discrepancy, it tries to determine if it was “aliased” memory (a memory card location that has more than one address assigned to it) by looking at the contents to determine if it sees the expected format (that has offset addresses embedded in the data). It will report those as “aliased”.

If it passes the test, and can write at least 10MB/s then it should not be a card issue.

If you are interested and want to add some info to the knowledge base, can you backup the card contents that you want to save, init the card, download and run h2testw

to see if the card passes the test?

I can try that. Should I format the card in my computer first, let the camera format it, or does the test destroy everything anyway?

If I should format it myself, what format and parameters should I use? (Windows machine.)

I ran the test, and it was fine. Before I quick-formatted the card, I looked at the video files. There were some minutes that were missing entirely, which corresponded with the gaps, and others with a small file size.


Test finished without errors.
You can now delete the test files *.h2w or verify them again.
Writing speed: 16.5 MByte/s
Reading speed: 17.4 MByte/s
H2testw v1.4

Well, it does not appear to be the card. Although h2testw only reports the average speed, unlike HDTune which graphs it. But the speed on the SD looks good.

I don’t have any good explanation. RickO can you pass this to Wyze? If he is using continuous recording, it should be continuous.

You said “on two of my V1 cameras”. Does that imply you have some other v1 cameras that don’t have the issue? If so, what is different? Length of USB cable, different type of memory card, different firmware? Also you might want to swap power supplies with a camera that doesn’t have the issue. Also, do you know if there were any motion alerts around the times with the missing video files?

FWM reports in

that motion alerts affect his recording to SD, and it was a v1 camera (even though it was posted in a v2 topic). So perhaps it is related to motion alerts?


@sdorshan… what it the ticket# you got from your support case on this?

I have three V1’s and one V2. When I checked yesterday, only two of the V1’s had the problem with the gaps.

There are no alerts that happened during the gaps. On the other hand, from an older post above, there should have been an alert during one of the gaps, but I got neither the alert nor the regular recording. The alert recording should happen regardless of whether there is a memory card.

A network problem shouldn’t interfere with memory card recording, and a memory card problem shouldn’t interfere with alert recording.

Maybe something is interfering with the general operation of the camera, and just freezing it up for brief periods.

I just submitted the ticket, #50562.

Well aside from this forum’s incompetent UI, I have this problem and wyze has been unresponsive

OK, now on desktop so I can see what I type…

More details: ticket 223420 created 5/18/19. Several back & forth with Support. SD card out, back in, reformat. Nada. Sent screenshot showing that gaps correspond to a file that is shorter than most, that I can play manually, but causes the visible gap in Wyze playback (see screenshot).Corrupt%20Wyze%20mp4
THEN, instructed to install RouteThis Helps on my Android device, run it, and report back the code it generates. Did all that on 5/19/19, 2.5 weeks ago.
Total silence from Wyze since then. Seems to me this is a fundamental defect in a camera supposedly suitable for surveillance and monitoring…

Sorry to hear about your experience! I scooped up your ticket and appreciate you letting us know about this problem.

1 Like

Thank you Gwendolyn for fielding my issue. I was losing hope that
Wyze would respond. I even created a new ticket pointing to the
initials “gaps” ticket, to no avail.

And yes, the Event clips not playing should be closed, as that

problem came and then went without my doing anything.


You’re welcome. Thanks for letting me know about this problem. I don’t see a response from you in our system. Did you also send a reply email back?

Thank you for the confirmation that there were two different problems but one was resolved. It looks as if support thought that the two problems were related and they closed the ticket with the recording gaps as well (leading to your support dropping off). I’ll make sure this is clearly outlined when I pass your ticket over to a tech so that someone more experienced (and useful) can help you out. :slight_smile:

1 Like

I have attached my last message re: ticket?? 223420. I believe it
contains the entire thread between Wyze and me on this issue,
including steps Wyze asked me to take, and my results. Please ensure
this ticket is re-opened so that I may receive help.
Fred Ehrhardt

(Attachment [Wyze Ticket 223420] Re: Feedback: gaps in recording.eml is missing)

Well, your mail system rejected my attachment *.eml - here it is as
a PDF.

Re_ [Wyze Ticket 223420] Re_ Feedback_ gaps in recording.pdf (376 KB)

Since your previous tickets were closed, I responded to 241595 so we’ll be working through that one. I apologize for making you jump through hoops, but could you please try sending your response to that ticket without the attachment? Before I hand your ticket off, I want to make sure that you and your agent will be able to communicate.

1 Like