Floodlight Pro Not detecting Person, Vehicles or Pets. No notifications either when enrolled in Cam Plus

Just installed a new floodlight Pro today, was super excited about the “Hi you’re being recorded” message playing for my neighbor when he brings his dog to poop on my lawn, but it stayed at excitement lol.

For some reason when the camera is enrolled on Cam Plus I get 0 notifications of motion on my phone, nonetheless AI ones like person detected ect, Neither does the recording go off when theres a person.
I called support but they were completely clue less.

I unenrolled the camera from Cam Plus, and it behaved a but differently. Still no voice saying the message, however I do get notifications on my phone that there is Motion now.

Not sure if its a hardware issue since the Person detection is done on device, however found it very strange that unenrolling it from Cam Plus triggered notifications on my phone.

Its on the latest firmware 2.0.921
App is latest Android Beta Version 2.43.0.b301

Also all settings are correct to enable Notifications for Events, with Person, Pet and Vehicle checked.
Event Recording is set up correctly as well, Smart Detection Events, with same Person, Vehicle and Pet toggled.

Cut power to the floodlight for 30 seconds then restore power. In rare circumstances with AI issues (sometimes after a firmware update), this seems to reset the local AI code to start working properly. Then check and make sure you’re still on the newest firmware, etc.

Also, keep in mind that sometimes detection only works well with a high confidence interval up to 30 feet, especially when it is not the middle of the day with bright light everywhere.

Another thing you can try is resetting the camera to factory settings and going through setup one more time. Here are the steps for that:

I’m telling you this because I had a similar issue on one of mine and I fixed it by doing the above, so maybe it will help you too. Mine has worked great since I did that. It seems the local AI just needed a little nudge and reset and then it was perfect after that.

Also, after you do any of those, try testing it yourself and walk a little closer and see if it gives the message closer, just not so far away. Then we can talk about some things to try to see if you can optimize it to detect a person a little farther away. :+1:

hi carverofchoice,

Thanks for your reply, I had actually already tried this. Right after the firmware update when I noticed It was not working I restarted it by cutting the power for a few minutes then restoring it. Still Nothing. Performed a factory reset as well, but that didn’t help either. Just tried restarting it again for the sake of trying again, but still it does not work. Very strange… Someone from support also suggested playing with the positioning of the camera to change the angle, this did not work either. It does not detect Persons 5, 10, 20 or 30 ft away day or night (lights or no lights)

1 Like

I’m glad you were in contact with support. Maybe they just need to do a warranty replacement because it sounds like that unit is not functioning normally. The 2 I’ve setup so far are working as you would expect (I still have some more to setup), but it sounds like yours isn’t functioning as we’d all expect.
Are they sending you a replacement?
Let us know if that helps, or if you get it figured out.

Support had me submit a log, which I did, we’ll see if they do contact me back, but yea starting to think its a hardware issue :frowning: I appreciate all your help!

Sounds good. Let me know what they tell you so we can make sure you get taken care of somehow. :+1:
I really love these things.

1 Like

Ended up doing an exchange through Amazon. Wyze support never reached out back :frowning: But it was definitely hardware related, new floodlight works perfectly!


Oh yeah, if you ordered through Amazon, then that’s a great way to handle it.

I’m glad that a replacement solved the issue like we were both expecting. Hopefully you enjoy it as much as I do. I liked them so much I kept ordering more. I just had my 4th delivered a couple of days ago and will be setting it up soon. :heart_eyes: