Floodlight Pro cannot manually record past video

Hey all, those with the new Floodlight Pro cameras. I wanted to know if anyone else uses continuous recording, and is having issues with going back to manually record a section of video. When I watch playback, the “Loading SD Card Stream…” pops up, never goes away… and the Take Photo and Record buttons gray out and become unusable.

I’ve already submitted a support ticket with them, but just wondering if anyone else is having this issue.


Good find @No_Smoking!

Replicated and confirmed.

Selecting a prior date and scrolling the timeline back results in the same condition. I can see the video playing, however the loading bubbles never resolve and the buttons are inaccessible.

Additional possible issue: my 256GB SD Card is slightly less than half way full, yet I only have 3 ½ days of SD Footage that I can scroll back thru (with the loading overlay). I installed the cam well over a week ago. That is an issue. I am going to monitor to see if the Hx gets longer and the card continues to fill.


yup, installed these on wednesday and i’ve noticed the same problem. didnt know if it was weak wifi (so upgraded to a mesh router and two satellites; strog signal everywhere now; it wasn’t the wifi.)

sd card playback is just plain bad; like really bad on the flood pro. in contrast, the sd playback on my v3s is flawless and intuitive, i don’t get it. anyway, other issues:

when i do rollback to a recorded event or time, the video that is displayed is a bit zoomed in. sometimes it appears in full but as a small frame in the top-left corner, giving a picture-in-picture look. i realized i have to unpinch for it to show the full frame.

when i put my phone in landscape, i completely loose any capability to scroll through stored video, i.e., there’s no timeline. all i can do is jump forward/backward 30 sec. and though i have the timestamp displayed to get some kind of feedback of where the playhead is, the stupid “go live” button almost covers the timestamp so it’s hard to know where you are in time.

there are many other bugs or bizzare/unexpected behavior with the sd playback; too numerous to describe in detail.

hopefully this’ll all get ironed out in the next couple weeks.


From wyze support.
"We’ve reached out to the team and our developers are aware of this issue. Thanks to user reports like yours, our team is working towards a fix for this. We appreciate your patience and apologize for any inconvenience while we work to get this resolved. "

Glad to know it’s a known issue and being worked on.


Annoying, but I did find a workaround.

If, when you do get to the time in the scroll bar you want to watch, and the “Loading SD Card Stream” appears… Minimize the app (not close but go back to the phone home screen), then reopen the app from the background. It will be at that time without the loading overlay.

Here is a new one… When you choose a date from the date selector calendar, does it go to that date or to 12PM the day before like mine does?

Also… New bugs found. Can you replicate?

Floodlight Pro App Crash - Setting Floodlight Schedule

i open the camera, touch “sd card”. it shows a list of events. you’d think you could touch an event and that it would jump to it, play, and that the playhead would scroll (with the timestamp). instead, when you touch an event, it jumps to before the first event and plays from there. the playhead doesn’t move so you have to rely on the hard-to-read timestamp.

i have a 32gb card and it first claimed i had no video before 2hrs ago. but after some scolling of the timeline and waiting, it now shows i have video back almost 6hrs. the card shows almost full so that’s legit. time to get much larger sd cards. 32gb was fine in the v3 but not gonna be adequate in this camera.

1 Like

Im having the same issue, the going to the phone home screen and reopening the app helped but not a fix. Also am I missing a slider when you turn your phone sideways in landscape?

1 Like

I have been having issues with doing this on my floodlights too. Sometimes it will tell me there is no recorded video in the spot I am trying to navigate to (like it will blank out entire hours worth on the timeline), but I know it is there, and sometimes if I navigate there a different way, I can get it to pull up, proving that it was always there. (note this doesn’t always happen for all hours, just sometimes)

For example, just the other day, I wanted to record something at 7:04pm on one of my Floodlight Pros, but all of 7pm was showing as blank when I navigated there or tried to go there from the Cam Plus Event to the SD card. However, if I went to an even an hour before or after that time and then jumped back, sometimes I could get it to show there were events during that time period, and it would sometimes start playing the event even though there was a message saying it was still loading the event. There is definitely a glitch with the playback and it happens on a few of my Floodlight Pros.

For those of you experiencing this, what size SD cards are you using? I am using 256GB High Endurance Samsung cards (so fairly top of the line). I have asked other people with smaller cards and most of them say they never see this issue, so I am wondering if it only happens to those of us with large SD cards, and not anyone with smaller cards.
(Edit: Just saw some like klivingston reported this was happening with 32GB cards too)
klivingston showed screenshots very similar to what I routinely see too.


another bug, i think. when i used 32gb cards, it looked like i got about 6 hours before the card filled up. i now have 256gb cards. so you’d think this would be 48hrs. but it’s been a week and the card is showing half full. makes no sense. it doesnt help, of course, that we can’t playback all contents of the card so i can figure it out myself. i’ll pull the cards tomorrow and check it manually.


I have been recording continuous to a 256GB SD card for weeks.

The card is currently at 96.5% capacity.

While the SD Card Playback UI is still as broke as it has been since confirming the SD Viewer bug and the “Loading SD Card Stream” persistence issue,
I was able, using the minimize App workaround mentioned above to work my way day by day back thru video footage to the oldest point on the SD Card. There is no way to pinpoint an exact time since the scollbar and FWD\REV buttons are useless, however I do have active footage that will play from Noon on 6\6\23. A bit more than 16 days ago. Note the timestamp.

But, until such time as I can pull the SD Card and fully examine the video files, I have no way of knowing yet how large the 2.5K QHD MP4 files are that may account for the reduced history. The closest comparison I have currently is my V3Pro recording in 2K continuous at 28 days history.

A new development in the long list of Floodlight Pro App UI issues: during the process of minimizing and maximizing the app to clear the “Loading SD Card Stream” overlay, so that the 30s FWD\REV buttons were accessible, I was greeted with this view:


following up. i pulled my card. the good news is that the flood pro has recorded continuously since i reformatted the card on june 13th. there are one-minute files grouped by hour and day folders. each file is about 10mb. so you’ll get ~2.2 days on a 32gb card; ~17.7 days on a 256gb. this jibes with @SlabSlayer above. so now we wait for the software (app) to catch up with the hardware.

1 Like

Anyone who was experiencing this, if any of you are using the latest Beta App Release candidate, will you check and see if it is working better for you with this latest Beta app version:

I expect it will be launched to the public soon, so if you aren’t in beta, just wait, it should show up soon enough, but if you are in beta, can you comment on how this latest app version performs related to this?

I have tested this in the current Android Beta App Release Candidate 2.43.0.b309 and it appears that the issue has been resolved.

The “Loading SD Card Stream” overlay does not remain persistent any longer and the timeline can now be manipulated to recorded points on the timeline. There are still some issues I have experienced with the UI that aren’t acting normal. The loading of the timeline and video when scrolling lags horribly. When pulling to a point that appears there is no video, it just stalls at “No Video”. The green timeline may catch up, but the video doesn’t. The timeline has to be moved in order to see video.

Nonetheless, this is progress. Let’s hope the Beta App passes QA soon.