Firmware update page locks up

When I go to the firmware update option on the latest iOS app it hangs the app (see screenshot). iOS is latest and so is the wyze app. I assumed it was a bug and it would be reported by others but I don’t see anyone else reporting it. Is it just me?

This was an iOS issue that was reported, and is being worked.

See this post and read down. I believe this is still being debugged. Suggest you reply to one of the Mavens in that thread or Jason from Wyze who knows about it.

1 Like

as @SlabSlayer indicated, this has been reported and in being worked on. Recently, I have tested both Android and iOS to replicate the issue. Later, I was asked to see if it was working, so I tested on Android’s latest Prod version and it appeared to be working. Once my iOS has completed updating my V3 Camera, I will check to see if it is working on the current prod version and report back.


I just tested the prod version and the issue you indicated still exists. I also just tested the Beta Version of the app and the Firmware Updates Page comes up without issues.

As @Antonius indicated, you can manually flash your devices or see if you can update firmware by going to the device you are trying to update, go to settings, device Info, then Firmware. If it determines you need an update, you may be prompted to update along the way.

1 Like

Are you trying to update your V3 to or a Beta version? You can add .32 to the V3 with the manual method.

1 Like