Firmware connection issues

Let’s use this thread for all connection issues related to firmware. We will closely monitor this thread. In the future, we plan to create a new post for each beta or official release of firmware. This will be easier to track issues.

So, we are ready for the issues. Bring it on :slight_smile:

Was excited to see new firmware…hopeful for a resolution to constant 3/3 issues…installed and a perfect connection! <yesterday>

Today, nothing but 3/3. Power cycled three times, same result. And there is something I am trying to time lapse right there. I’ve updated Test Flight and firmware.

Gotta say, I love what you’re doing, but these connection issues are pushing me to run these little bricks over with my car. It’s just maddening. Please help!

What info can I send to help you troubleshoot? Right now, both of my cams are hooked up to Wemo switches (that cost more than the camera) to remotely power cycle them because of how often I need to do that.

A sincere thanks for your help!

So that it easier to read what the error messages are, how about using black text. As it is now, the text is so small and with the text being white on a mostly white background, it is almost impossible to read.

Connection issues are the top issues for us to resolve. We totally understand the frustration there. We will need your help to nail down the issues one by one. Thanks in advance!


A few questions:

  1. Once it is stuck at 3/3, will you be able to connect again later? What if you re-enter the live view page or reopen the app?
  2. How often does it happen? 100% or random?
  3. What is your network situation? I assume you have good internet connection for the device. Was your phone on the same network, another WiFi or LTE?
  4. What is your router model?

We will take the feedback and try to improve the experience. Thanks!

Thanks for getting in touch and understanding my venting… Sorry for the long post.

If it helps troubleshooting, I installed the new firmware two nights ago and everything worked great. Yesterday morning, I used the Test Flight app on my phone to access and everything worked. Then a few minutes later, I tried the GA app on my iPad: 3/3. Figuring it was an app issue, I then used my phone: 3/3. Rebooted camera multiple times: 3/3. Later in the day: started working. The time lapse I setup when it worked in the AM actually recorded, surviving reboots somehow - which was impressive!

To your questions:

  1. Sometimes I am able to connect later. Usually later is MUCH later. In this case, I rebooted the device three or four times, it didn’t change anything. Then much later in the day, it started working again. Getting in and out of the app has no effect. Force quitting and restarting the app has no effect.

  2. It happens daily. And it is random.

  3. Network and internet connection are solid. Phone was on the same network and SSID. Sometimes they are on different SSIDs (2G v 5G), but still same network. I don’t recall a case where being on LTE made the situation better.

  4. All wireless devices in my house connect through two Ubiquiti Unifi UAP-AC-PRO access points. The camera I was having issues with yesterday is twice as close to the AP as the camera that was working. Those APs are connected to a Netgate SG-3100 network device running pfSense router/firewall/VPN/etc software that controls the entire home network. Then onto the uVerse box. I’m pretty confident in my network, but open to hearing otherwise.

Thanks again for the assist!


We fixed a few ‘stuck at 1/3’ issues in but didn’t chance too much with stage 3/3 code. We definitely want to work with you to get it fixed. Can you please help us with following?

when ‘stuck at 3/3’ happens again, please take both app log and firmware log right after the issue (no power cycle or killing the app). You can submit the app log and change the email recipient to me ( Please tell me the time and time zone when you failed your connection. For firmware log, please insert or reinsert an SD card into it. Take the card out 10-15s after you hear two ‘chime’ sound. There will be a log_XXX.txt file on your root file. That is the firmware log. Please send it to my email as well.

Two more questions:

When it failed at 3/3, would you have the issue fixed right after you power cycle your camera? Or, does it fail for a while and then magically starts to work again?

Do you have another camera? If you do, I would like to have you try to connect to another camera when you have 3/3 stuck issue happened. If needed, we can send you another camera to test it :slight_smile:


Did you disable the WiFi on your Uverse box & configure for IP passrhru to your router?

Do you have any WiFi printers that are broadcasting their own WiFi network for a WiFi Direct connections?

I have seen a printer with bad WiFi transmitter cause issues with WiFi connectivity.

Hello, please see below feedback.

Q: Once it is stuck at 3/3, will you be able to connect again later? What if you re-enter the live view page or reopen the app?
A: Once stuck at 3/3, I am unable to connect afterwards. The LiveStream view does not come up for the specific camera and reopening the app does not resolve the issue.

Q: How often does it happen? 100% or random?
A: Randomly.

Q: What is your network situation? I assume you have good internet connection for the device. Was your phone on the same network, another WiFi or LTE?
A: Yes, issues occur when phone is on the same ssid/wifi and on LTE as well.

Q: What is your router model?
A: Linksys.

Q: When it failed at 3/3, would you have the issue fixed right after you power cycle your camera? Or, does it fail for a while and then magically starts to work again?
A: Issue is fixed right after a power cycle.

Next time it happens, I will grab those logs and send them along. Thanks for digging in to assist!!

  1. When it was hanging at 3/3, no amount of power cycling would fix it. I tried three or four power cycles the other day and nothing got it to reconnect - then later in the day I tried again and it magically started working. Voodoo ;)
  2. I have two cameras (and a v2 on order), but will happily take another one ;) Sometimes it stalls on connection as well, sometimes one works and the other one doesn't. They are on opposite sides of the house, but connecting to the same AP. The one that was failing the other day is quite a bit closer to the AP.
One of piece of note is that even when having these issues, when I check my AP controller software, it shows that both cameras are connected and have plenty of bandwidth (even on the non-AC connection).


Hey there, thanks for trying to help!

Yes, the wifi is disabled on uVerse. My pfSense router lives in the DMZ as configured on the router. No issues there.

I have one wifi printer, but it does not broadcast its own network. It only uses wifi to connect as a client to my existing network.

Thanks again!

In your case, it is very likely your router has lots of WyzeCam traffic. It keeps retrying X times which makes your network ‘stuck’. In the end, all network traffic died down so you can connect again. That is our best guess for your case.

Do you know if the cameras are connecting to your AP or router? If you are willing to try it (totally optional), please power off your AP/router for 15-30 seconds and restart it when you are stuck at 3/3 next time. We are very curious if that can make your connection back. Obviously this is not the solution we are suggesting :slight_smile:

Our devs are working on making a special version of firmware for your case with more log information. Once they are done, we will let you know how to install it.

Thanks for the help!

Thanks for the reply!

My network has two (and only two) access points (Ubiquity Unifi AC-PRO). Those APs are hardwired into my router/firewall/VPN/DHCP server/etc (Netgate SG-3100 running pfSense). This setup is not a consumer-grade Netgear or Belkin running standard firmware, it can handle more traffic than ten cameras could produce (1.8M active connections). I mention this only to put the network in perspective, not to be arrogant - please forgive if it comes across that way. I am open to there being a configuration issue that I need to track down, but I do not have these problems with my Nest cam (or Thermostats or Protects), SkyBell, Apple TV, Roku, FireTV, Echos, etc - all that stream consistently. So, respectfully, I will not reboot my router next time this occurs.

By checking the controller software for my APs and pfSense, I am positive that the cameras have a solid wireless connection (controller tells me the available bandwidth to each client - and how much its using by session) and connection to the router (by virtue of the fact that they have IP addresses, which are assigned by pfSense). I can trace the traffic with ntopng if that will be helpful.

I am happy to try different firmware on your device to give better logging information. I haven’t had a chance to play with it much the last few days, but as soon as I catch a snag, I will forward the logs that the current firmware will produce.

Thank you very much for your help troubleshooting the problem!


No worries about the network setup. I didn’t have any negative sense on it. I also don’t think it is a network setup issue for your home, especially you can connect to your cameras intermittently. Our goal is to find out why our cameras don’t work well in your home and fix the issue.

Our diagnostic firmware should come out later this week. Once they are done, I will ping you again. At the mean time, I will take a look at the log you sent to me. Thanks!