Faster Notifications - Turning Off Android Battery Optimizations

I’ve seen this mentioned but this is the first time I’ve done it so I took screenshots to help out others. It’s a surprising number of levels down. Based on a discussion at

Please bear in mind that I have older Android and Wyze app so as with all things Android your mileage may vary.

Change it to “Don’t optimize”. Good luck. I just set this myself… so I have no idea if it will actually help me. :slight_smile:

1 Like

I did this a while ago for Android 11. It helps. Before, sometimes my phone would wait a while and deliver a bunch of delayed notifications all at once. This reduced the problem.

I wish I could say I never get delayed notifications anymore, but unfortunately it still happens sometimes. It’s definitely less frequently though.

Sometimes delays are Wyze’s fault (takes the AI a while to process video and return the results), but I think most of the delays are my phone’s fault since it still happens to other apps even when optimization is fully disabled for everything. I think Android has some kind of bug in the notification feature or doesn’t really turn off battery optimization completely or something (hence why Wyze added a persistent notification option to help with that… But since it doesn’t minimize, it’s hard to tell when there’s a new one).

Still, I’d definitely highly recommend turning off optimization for Wyze app and you made an awesome walkthrough here! I think Wyze should update the app to prompt people to disable optimization for the app, with a warning that the phone might otherwise delay important push notifications.

1 Like


Well for me the good news so far is that the app hasn’t used ANY battery at all since I disabled its battery optimization setting. So there’s no downside in that regard. On the other hand I haven’t received any new notifications yet.

1 Like