Failed to update device list (error code -1)


I’m having a problem with my Wyze app on my Android phone. I noticed a few days ago that there were no Rule shortcuts appearing at the top of my home screen. Also I noticed the following error briefly appearing at the bottom of the home screen when the Wyze app was opened: “Failed to update device list (error code -1).”

I just decided to log out of the app and then to log back in, and now all of my devices have disappeared! I don’t want to have to set up my 15+ cameras, bulbs, plugs and sense devices. What is going on?

There might be a bug with your app. I’d suggest forcing close of the app and opening it again. If that doesn’t solve the issue, try deleting and reinstalling the app. You will not have to reset or set any of your Wyze products up again because they are connected to your Wyze account, not the mobile device with the app. As long as you have your login information(email and password) you’ll be able to access your Wyze devices.


I force closed the app, no difference. I then uninstalled the app, then installed it again, Still the same. This is the Beta app.

Stupid question…do you have an internet connectivity problem either with your phone or the devices connected to your WiFi? I had a connection error through our ISP last night and was seeing that error until the connectivity was restored.


I don’t think there is a problem with the WiFi. BTW, when I look on the Wyze app on my iPad, it is working fine.

Well, as of this morning, All is well. When I looked at my phone this morning, I noticed some Wyze notifications, and saw that my Wyze app home screen had all of my devices showing, the Rules shortcuts were at the top, and there was no error message when I opened it. I don’t know what changed, but as of last night, my Wyze app home screen was blank and I was still getting that error code -1 message.
Maybe WildBill was right? Maybe there was some issue with the WiFi that corrected itself overnight? (But all my other android apps were working fine, and the Wyze app worked fine on an iPad connected to the same network.)

From the information you provided it looks as if there may have been an issue with the phone connecting to the wifi, not the wifi per se. You were only receiving the error on the one device so I would suspect a problem with that network connection.

I get the failed to update device list on the regular. As a matter of fact, I just got it after trying to view a motion detection on my doorbell. When I go to it it says error code 6 and then when I back out of the doorbell it gives me failed to update device list error and then when I went back view doorbell there were no longer any videos showing. So I have to kill the app and then go back in to see events. There is another “person” video that works but this earlier “motion” video doesn’t. This is on IOS.

so you got 15 plus all these little bulb thingy puppies hanging around somewhere do you?
perhaps you could reply with a report of how well they work or don’t work for you? I just went several rounds for several weeks with a singlet hub and 20 singlet bulbs then I tried the smart thing hub and I tried the hubitat hub, and I couldn’t get these bulbs to be recognized. 90 million people buy these things and don’t seem to have a problem setting them up when I watch the videos but this was a nightmare.

I was hoping to get the 20 bulbs in one space that I wanted to light that’s roughly 30x30 ft. I needed to have the color bulbs all dimmable and all that stuff and I was trying to figure out whether the Wi-Fi connection will be better than the Bluetooth connection etc, so I had ordered both Bluetooth and Wi-Fi I couldn’t get either technology to work with that brand.

what was your experience using the wise bolts which I didn’t consider cuz I didn’t come up very high on the ratings list that people were offering on the internet. however a lot of that is opinion and people who don’t know how to use this stuff anyway. apparently you figured it out. could you please tell us your story with setting these bulbs up how it all unfolded and work out for you…

I think there are issues with the Wyze server from time to time. Outages, etc.

1 Like

Happened to my husband(android), just went to the play store and updated the app and that fixed it.

1 Like

Welcome to the forums and thanks for your experience! I am sure the recent security changes effected the updating of your husbands device list and the updating of the app brought it into the current versions which satisfies the requirement.

Upgrading to version 2.27.33 solved the issue

Looks like it did for me as well. Thanks for the head’s up.

App (ios) is up to date. Just tried to add a v3 cam and got the ‘devices list (1000)’ error.
I deleted and re-add ed the app but still not working.
Yet I’m getting notifications from all my wyze devices.
What’s going on here?

1 Like

I got the same error this morning. Deleted app and reloaded, I even update my IOS and still same error.

I just restarted my phone. That seems to have fixed the problem for me.

Same issue here, i have removed the permission to the app, enable it again, re-start the cellphone several times, force close the app, uninstall the app and install it again and the same issue, i shared this cameras with other family member and we do not have any issues, just one of the family members is the one having the issues.

Can you tell me the app version number for the family member with the issue, it can be found under account (lower right of app) than about (very bottom)

1 Like

I just had this happen to me today with a new app version loaded to my phone and what I am expecting to be a high server usage due to Black Friday/Cyber Monday load. My Wifi/Network is fine since I have near gigabyte bandwidth and work from home with no issues. The devices are slowly coming back along with events, etc. Just taking a little time and patience… The latter being something I always have to work on - LOL.

1 Like