Entry Sensor V2 could not trigger Alexa App on phone to run a routine once phone enters idle

Note that I did

  1. delete Alexa App & re-install;
  2. delete the routine, removed the Wyze Entry Sensor V2 from Wyze App (& even delete Wyze App and re-install). Then, re-install the Sensor & recreate the routine
  3. Goto iPhone Setting->General->Background App Refresh-> Turn it ON & include Alexa and Wyze … (this action is from Amazon’s forum ->the same problem persists.

My procedures are as follows:

A. Wyze App-> Select the Entry Sensor-> Setting (Gear Icon) Notification → Turn it ON (Only select “when sensor is open!”

B. Alexa App, Routine, + … Only one action (Alexa says "Sensor Opened)
C. Alexa is still on the Routine page. Pull the entry sensor apart to open & closed it in 2 seconds
D. Alexa on phone pops up an notification (with time stamp) on screen top & then says “Sensor Opened” (as expected)
E. Phone Screen moves to Wyze Home, Pulled the sensor apart to open
F. The same notification pops up (but time is different), but Alexa has no response!
The notification pop-up shows that Wyze did sends out an notification, but it may only goes to the phone, but not reach Alexa. Of course, Alexa could be accused of closing its door that receives message once idled (or phone switched to use other apps)!

I will see whether other people have the same problem or anyone using routines on phone should try to see whether now the routine can fire on the phone when it is idled or sleeping!
I did try Alexa on an Android phone, basically it behaves the same!

I did create a routine for an Echo, but it has the opposite behavior…
Since for a SHOW device like Echo, Alexa is always listening… So when the sensor’s notification is on, it does get the notification!
The problem is that when I set the sensor notification to OFF, the routine does fire on the ECHO. It could show Wyze sends out notification even the setting is ON, and this may at least points finger to Wyze’ sensor notification system!

The sensor events happen on the back end or server side. Your device notification settings in the Wyze app for the sensor has no effect on weather an event is sent to Alexa or not. If your notifications are disabled for the sensor and the sensors open, an event will still be sent to Alexa.

What was your Alexa routine supposed to do?

The thinking is to make a routine asking Alexa to produce alarm sound on phone & on Echo when the sensor is open . There is quite some forum discussion using the notification (ON/Off) to do that! By common sense & English, ‘Notification OFF’ means Wyze will not send out notification about sensor state to any party (including Alexa)

Notification ON means it would do that according to what you choose (open, close, leave on and leave close)

This is totally a matter of Wyze’s design. If it decides not to send anything, Alexa could not receive anything unless Alexa could monitor Wyze’s components directly and I believe it should not be implemented that way … as it will take a lot of resources.
No mattr Google home, Alexa, IFTTT should only be implemented as a listener & when the trigger condition satisfy the criterion, it runs its actions…
I do not know whether this is what is implemented, but according to my programming knowledge, it should be done that way!

Sorry, I just would like to express my disappointment if it is implemented that way… it will make using notification on and off to arm and disarm sensor completely impossible… Events and notification are not that clearly explained in Wyze support web site! On Alexa, it does say when an event happens … and leading to misunderstanding that it learns the event from the notification
Do you have any other idea how to disarm or arm a sensor without using the keypad?
If we use the keypad, can we do that disarm and arm?

The sound or alarm on the echo device is pretty simple, just make a routine like this:

Why do you want it to alarm on your phone? Is the Wyze notifications not suitable?

That may be using a program like Macrodroid on your phone, which takes events on your phone (lots of triggers, geo fence, notification, network connection, button press, etc) as triggers then does whatever you then program the action to do

Notifications off means that push notifications won’t be sent to your phone, but the event still happens, is recorded in the cloud, and is sent to any third party service you have linked.

This is the way it was designed, if you want to help and support a possible change, I’d suggest commenting your use case and voting on this Wishlist which requests the ability to turn on and off the sensor itself (it’s events), not just toggle the notification settings.

The keypad is for controlling the home monitoring service.

I would say that the only way to disable the entry sensor or stop it’s events is to take another magnet and put it by the sensor body so that it thinks its always closed. You could also just use rules in the Wyze app to control the notification settings based on time of day. And if you make an Alexa routine. Add a time frame where the sound to the echo will and won’t happen.

The most important problem now is
when the mobile phone, no matter iPhone or Android, enters idle, or even the screen leaves Alexa to use other Apps (such as Wyze), the routine (triggered by an entry sensor ON) will not run! Despite a notification is shown on screen top!
I do not consider an notification like that can get attention from the phone owner!
Any comment for that? I already checked the Setting-General-Background App Refresh to ON and included Alexa.