"Dustbin removed" in the middle of vacuuming

I am constantly having to resume vacuuming with the robot vacuum manually. The robot vacuum will stop during its vacuuming and claim that the dustbin was removed. Then, a moment later, “dustbin installed.” Afterward, I am manually resuming the cleaning cycle. How sensitive is the dustbin sensor? Can this be fixed with a piece of paper or something? I have removed and installed the dustbin and tried to find a sweet spot with no luck. Let me know what you know out there!

I have never had this happen with my Wyze Robot Vacuum. That is not normal. It may be possible to do something to reduce the frequency of this occurring or fix it altogether…I am guessing the sensors aren’t hitting the contacts right or something, however, in this case I would first suggest contacting support about it before any of us look at possible options that could possibly void your warranty. Best to go through support first, assuming your warranty is still valid and that a fix to this may potentially require using it. Best to have support make that determination first IMO.

Also, let us know how that goes. If support can’t help you, I know several of us would be willing to check things out and give some suggestions. I just want to make sure you get the best possible outcome here.


Check the contact surfaces on both the bin and the vac. The contacts in the vac might be bent just a bit so when the vac bounces it could be the contacts not connecting completely.

1 Like

The HEPA filter contains a magnet, the black dot in the corner. That is what it is sensing.

I’ve not had an issue either. Maybe it has something to do with how you are installing it? I just push the container straight down until it clicks after dropping it in. You could try a different HEPA filter.

If there is no damage to the dustbin, maybe the sensor inside the vacuum is out of alignment…

[Mod Edit]


Wow! I was trying to figure out how these 2 contacts worked this whole time! There is a peice of metal in the HEPA filter! I swapped out the filter because the previous one looked recessed! It’ll take a few days for me to be pleased but I am hoping the issue is gone! Thank you