Drops connection to Wifi every 2 days

The Air Purifier has worked perfectly until the most recent firmware update. Now it won’t stay connected for more than 2 days. After that I need to power cycle it, it’ll then connect for another 2 days before disconnecting again. What gives !?!!

Interesting, the latest firmware should have fixed that very issue. (Or was it latest beta?)

Try restarting your router, and also make sure you don’t have too many devices for the router.

1 Like

I absolutely agree with @IEatBeans, that sounds like a “limit on device” issue with your router. If you are looking for some ideas. You can download the app called “fing” to help you count all the devices on your network. Then Google your router model for its specs. Look how many devices it can support. Too many? Delete some or replace your router. But before you just get another router, check the limit on the new ones. Sometimes its not more, but same as you have.

1 Like

I’m using an Eero Mesh network that can handle well over a 100 devices per node. I’m way below that and none of my other WiFi devices have any problems including Wyze v3 cams.

Good. I am glad you have ruled that out has a possibly. I wish I could give you something else to look at. But pleased for you that its not that. Best of luck to you sir.

Try deleting the device from the app and adding it again

Will try that. Thanks

1 Like

Was your issue ever resolved? I was having this problem on 1.0.8, then 1.0.9 solved it. Unfortunately, this exact problem has returned on 1.0.10. I too am using eero. What’s odd to me is that the air purifier still shows as connected to my network, according to the Eero, but the device itself is saying it has lost its connection. If I unplug the device, it reconnects for a day or two. Same problem on two different purifiers.

Yea by Wyze themselves. They sent me a replacement unit which has had zero problems. Interestingly my previous unit got worse, after rebooting would fix it for 2 days I did a reset to factory and after that I couldn’t connect it at all.

Oh huh. That’s unfortunate but glad they got you squared away. Out of curiosity, were you an early adopter? I bought both of ours the day the launch email was sent.

Yeah. Same. I bought as soon as it was announced. Perhaps a bad early batch ?