Wyze Air Purifier won’t connect to WiFi

I have bought 3 purifiers, all three were able to connect to Wi-Fi initially and update the firmware. 20 minutes later, one of them showed as connected on the front panel but not reachable via the app. Turning on and off, unplugging for 15 minutes, and deleted and attempted to re add, via the app, but the app cannot find the purifier, even when the Wi-Fi is blinking from pressing the Auto and Fan buttons at the same time. Is there a way to force a reset of the device?

Welcome to the forum @68K20.

Can you try a factory reset of the Air Purifier and see if that helps resolve?


I can’t get it to factory reset. It beeps but doesn’t turn off as described in the Wyze article.

1 Like

Sorry to hear this is still an issue @68K20

Out of curiosity, any chance you have run out of IP’s on your home network?

I experienced something similar, after the button push and hold the Air Purifier beeped but did not power off and back on but it did reset. The reset took a little bit of time after the manual button push.

Could you try the following?

  1. Press and hold the Auto Mode and Fan Speed button until the air purifier beeps.
  2. Wait 10 Minutes
  3. Remove power from the purifier
  4. IF the Air Purifier is still on the Wyze App, Delete the Air Purifier from the App
  5. Clear the App Cache in the Wyze App
  6. Plug the purifier back in
  7. Set up the air purifier as a new device in the Wyze app.

If this does not work I would contact Wyze support

1 Like

Hi @68K20 one way to reset the device is to press and hold the Power button for 8s. It shall factory reset the device, and get into the pairing mode.

1 Like

Thank You!

One or two factory resets and then, logging out and back in THEN R.Good’s 7 step and the air purifier paired and setup I believe properly. It is currently going through the software update.

So Thank you!

Perhaps a mod can make this topic easier to find, the in app help is useless and there’s no easy way to request help if the device isn’t listed on your device.

1 Like

Out of the blue now my Air Purifier says it’s offline on the app. I tried holding down the Auto and Fan speed buttons, the WiFi icon has been blinking for 5 minutes and still not connecting.

The unit does not turn off when doing this.

This did not put it in pairing mode.

Has there been a fix to the air purifiers not connecting to Wifi? I have 2. They both paired initially and life was good. Then they lost connection and will no longer connect to wifi. I have an Orbi mesh wifi system, great coverage, these are the only wifi items that are not and will not connect. I’ve tried factory reset multiple times. I’ve reset my wifi. I’ve tried uninstalling and reinstalling the product.

It (Wyze app) recognizes the purifier and adds it to my list of products when I try to reinstall. It then connects to Alexa and then it goes to the third and final step. It spins for a moment then comes back and say install failed. It says offline and asks me to check my wifi password. The password is correct.

I just got a new modem and router. Got all of my other Wyze devices (cameras, light bulbs, sensors, home monitoring system and scale) connected but they air purifier will not reconnect. Tried power cycling and resetting. Can see the wifi symbol flashing but my app says ensure the power is on.

Will someone from Wyze acknowledge and reply please? I have 2 air purifiers that will not connect to wifi. I have done everything suggested and have spent way too much time on this, so I would like to hear from Wyze that they have heard those of us that are having this issue and that they are working to address the issue.

I had the same problem when I got a new router and modem. Contacted Wyze through chat and they are sending me a new one. Contact Wyze directly.

I am sorry you are having issues with them, have you contacted support about it yet.

I like turning on the air purifier about an hour before getting into my home office where it is kept.

Have the similar experiences with the WiFi connectivity of my air purifier. Getting pretty tired of factory resetting it in order for it to find the WiFi again. Works great for a week or so but end up resetting it when the WiFi icon starts blinking again and I can’t connect to it.
All my other Wyze and non-Wyze devices don’t have any issues maintaining connection with our 3 node eero mesh.

Anyone find a fix for this? Had to do a firmware update on my router today for the first time since getting the air purifier. After the update everything reconnected flawlessly except for the air purifier. I figured I could just delete it out of the app, factory reset it, then add it back, but no such luck. Can’t get it to connect at all now. What’s the deal, Wyze? Seems like this is a pretty consistent problem. How can I get it to connect?

Same thing happened to my dad when we changed out his router. We could never get it to connect and Wyze sent him a replacement. Contact Wyze directly.

try leaving it unplugged for a long period of time. Then try to connect to it.

BTW: talking for a few hours.

I had a similar issue in the past, doing this allowed it to be connected. Since then, I have updated the FW and have not seen the issue since

I am on FW: