Doorbell voip phone call bug

I have now enabled the beta voice for the doorbell. I have to select between my Sim and wyze when I make a call.!

1 Like

BTW I went in and checked that the phone is the default app in system settings .

Hi, could you please let us know if you see this with Android or IOS?

Sorry my mistake samsung note 10 running android 11

That is really really odd. Send in logs as much as you can on that. I haven’t heard of this happening with anyone else in the VoIP beta. I wonder if one of my fellow @Mavens team might have an idea on this. I wonder what would cause it to do that. Apparently I need to familiarize myself a little more with the VoIP protocols and how they work on the back end.

Thanks for the Callout @Bam I had not yet activated the VOIP before now, so I did so to help test this.

This gets REALLY weird. First, let me say that I was able to replicate this on my old and deactivated (not on any carrier) Samsung Note 8, but not on my Newer and activated (to a carrier) Google Pixel 5 despite both using the same Wyze App, and the Same Google Phone App. This leads me to believe it is a bug with the Samsung One UI somehow. Let me call out to @R.Good who I know has a spare Samsung phone too and see if he can also replicate this with his Samsung phone.

Samsung Galaxy Note 8 - Android 9 (Security Patch Dec 1, 2020) - One UI 1.0 - Using “Phone” App by Google - Phone not currently activated through any carrier:

Right after I selected to choose the “wyze” Sim Card instead of the deactivated Sprint sim card, it asked me if I wanted to place the call through either Google Voice or my carrier - This is the normal thing that comes up on this phone when I try to place a call because for the “Default call redirecting app” setting I have it set to “NONE” set instead of my carrier or Google voice (this helps prevent accidental dialing).

Again, that is normal when I make a call, so most people won’t see this request of how I want to place the call (Google Voice or carrier)

After I selected “Google voice” (because it’s not active through the carrier), it popped up this screen AGAIN asking me select between Sprint or wyze a second time:

I selected wyze again, and it attempted to call.

The following I believe to be a Google voice issue and unrelated to the wyze Sim Card thing…in other words this entire section can probably be safely skipped/ignored for the purposes of this testing

Click here to read the weird Google Voice issue/story about what happened when I tried to call out with Google voice and the "Wyze Sim" card

Now here is why I say it gets weird. Also, if a Wyze employee wants me to make a private video of all this I am willing to do that, I just won’t be doing or posting it in a public forum like this since a video would who my friends/family members’ contact info…besides that would violate the forum community guidelines against personal information (or maybe I can create a guest account later and try it that way).

ANYWAY, I told the phone to call my Wife’s personal cell phone number that she’s had for almost 2 decades now. It starts with a 435 area code as you can see in screenshot #2 where it says it’s going to call the 435 number…but if you look in screenshot #3 after I told it to call through Google Voice and use the Wyze sim card the second time, it ACTUALLY called a totally different number with area code 816. I thought it would be calling a number Wyze contracts through for their VOIP services (like a customer service number or something). Boy was I wrong…it actually CALLED MY WIFE! My wife picked up. I went and showed her what I number I actually dialed according to the phone, and she didn’t recognize that number. It is a MISSOURI number. We have never lived in Missouri and it is a good thousand miles away from us. I checked My wife’s contact information to see if somehow it dialed some old Google Voice contact number for my wife or something. Nope, my wife’s Google voice number is totally different (385). I can’t figure out what on earth that 816 number is. Also, my account is the main Wyze account, and the Wyze VOIP is only activated and used on my Wyze account which only has my phone number, so I am completely lost how on earth an 816 phone number is linked to my Wife’s phone number. I should mention that I also called this 816 number directly through my carrier number on my Pixel phone (not Google Voice nor the “wyze” sim card) and it still calls my wife’s carrier phone number somehow. I don’t know how Google Voice/wyze Sim figured out that number was linked to my Wife when it’s never even been in my contact card for my wife, but now I’m wondering if someone spiked my drink or my food because I am out of explanations on this one. I do have some theories on this, but almost all of them boil down to being caused by Google Voice in some way. Hence why I said I believe this really weird part is unrelated to the Wyze Sim Card part of all this…maybe I’ll get into some of those rationales later…but either way, it’s still weird that my phone said it was calling my wife’s 435 number then google voice called a different 816 number that ultimately forwarded to the 435 number I told it to call. So that’s still weird no matter the explanation!

(Sorry if I raised more questions than I answered within that Google Voice issue)

I think for Wyze, the main testing should be checking if the Wyze Sim Card issue can be duplicated on any Samsung phones using the Samsung One UI. Maybe @R.Good can try with his. I could also try switching a different UI on my same Samsung phone and see if that makes a difference…I just have to get some work done tonight or I’d do more tests right now (can probably just assign the carrier (T-Mobile in this case) in the “Default Call redirecting app” setting to solve the issue. It would just be nice to figure out why Samsung is asking this and thinking Wyze has a Sim Card or a way to call, but normal Android phones are not.


The same thing happened on my S10, Android 11.

To fix it I just made “Fido” aka my carrier here in Canada the default calling account instead of “wyze”.

I’m using the Google phone app but this works for the default Samsung one too.

Settings > Calls > Other call settings > Calling accounts


Thanks for checking that. I was pretty sure that should resolve the issue so that it doesn’t show up anymore.

It would still be good for Wyze to try to figure out why Samsung is prompting people for this in the first place and see if there is some way to make phones ignore it by default.


Wow @carverofchoice this is precisely the type of reason why you were invited to be a maven, it is a badge well earned! I could not get this to replicate it all and I’ve never run into this issue before with VoIP. Your breakdown of it and explanation are perfect!!! I’m glad something was able to be figured out because I was a little frustrated I could not get it to do anything on my end. Now we just need to get the issue brought to light for the company in some way. Off to find that post and see if we can figure out who the PM is for VOIP


Thank you this worked!



1 Like

Yes agreed maybe someone higher up can get Wyzes attention on this issue.

1 Like

Not someone Higher up, but I assume the reason why it may ask is, some Samsung devices offer a E-Sim option, by default its set to ask you which phone should you use if you call abroad, so it may assume Wyze Voip acts as an extra sim card since you do receive this call on your Dialer app. I’m glad someone pointed this solution out because I was wondering how would I do if I was traveling abroad and how to set my second Sim card. IPhone is safe to say knows how to integrate calls on its Dialer while Android uses the app to make the call and not its own Dialer, that basically tells you how broken and separate android is to Brands.


Interestingly though, this issue happens to me on my Samsung Note 8 which is NOT capable of an eSim card, only a physical sim card. And then on my Pixel 5, which IS capable of an eSim (I had it using the eSim when I was on Sprint, then switched to T-Mobile and now it’s back to using a physical Sim card), I don’t have this issue.

So while this train of thought is very logical, it is strange that the issue is only occurring on the phone that doesn’t technically support an eSim, but isn’t happening on the phone that is developed for an eSim.

I suspect Samsung might’ve built their “One UI” to always check or allow eSim even on their phones that don’t technically support it for carriers though…

I gave up on the Wyze doorbell. Inconsistent with the Alexa integration to echo show. Removed it and installed the ring doorbell which integrates exceptionally well with the show. Seems like Wyze outputs products that don’t quite cross the goal line. The doorbell is an example, the door locks inconsistently Auto unlock, the security system lacks basic devices like smoke detectors (listening via cams don’t count) nor glass break sensors.
Really wanted to go full out with Wyze but finding their inability to cross the goal line very disappointing

1 Like

Thanks, This solved my issue.

Can you use this in the production version?

Had the same problem with my Samsung S20+ forcing me to choose every time I made a call. This all started when I installed the Doorbell Pro and the app asked me if I wanted VOIP calls when the doorbell is pressed. I was missing rings so I thought I would try it. However it doesn’t go away even if you turn it off. The app is making system level changes to the device. Even in the caller setup I can’t get rid of the “wyze” caller setting, it is permanently stuck in there now. Wyze developers need to give users a way to undo the changes that are made to their phones by this setting if they choose to disable it. I still want to know how I can get rid of the “wyze” caller showing up in my settings.

I have a OnePlus 8, my wife the OnePlus 6. We still have this issue and the given workaround doesn’t work as TMobile does not show up as an option, and default sim is greyed out. This is Killin me! No idea how to fix, but close to going back to ring.