Doorbell not getting power

I tried last night to hook up my Wyze doorbell. Followed instructions as they said, when I powered the doorbell back up it was stuck in a power cycle where it kept clicking and flashing yellow. Would not say ready to connect. I cut power, re checked my wiring and all was the way it was supposed to be and tried the reset button, nothing. Now it won’t power up at all when hooked up to my doorbell wires. Any ideas? I put in a ticket with support as well.

You can try powering via microSD on the back just to verify it boots.

I did try that and it does power up that way.

did u check the breaker that feeds the transformer? Also, you could try to wire the doorbell directly to the transformer bypassing the existing wiring as a test.

I had the same issue when following the Wyze directions (and video). I fixed it by removing the diode that was in parallel with the doorbell circuit. In fact, I disconnected the chime circuit completely and wired the transformer directly to the Wyze Doorbell and it powered up with no issues.

Then I had an issue with the chime not connecting to the doorbell. I resolved this by updating the doorbell firmware to the latest version and restarted the device using the app. The chime then connected and everything appears to be working.

Can you throw a pic of the wiring out here for us to see? I have the same issue. Nest doorbell powers up fine. Wyze works with the usb. Nest needs 10v and Wyze 16v. I’m pulling a little over 18v at the transformer. Ordered a new doorbell kit with a new chime, transformer, and buttons and would rather get a refund and use the money on more Wyze products :grin:

Just an FYI, I had the same issue with the doorbell constantly power cycling and finally fixed it. My transformer was actually no where near my chime box. After I finally found the transformer, I saw it was wired for 8v instead of 16v. I changed the wiring to 16v and my doorbell is now working properly. I hope this helps others.

Just wanted to throw this out there. The issue ended up being a defective unit. The replacement arrived and it works great.

1 Like

After repeated attempts, I learned about the back port on the device. Set up worked fine including the connection with the chime. So it is a wiring issue.

My doorbell will allow for the first parts of the set up until it reads the QR code, then it presents with error codes.

I tired setting it up then connecting it to the wires and that’s a no go.

More information of how to work out the wiring situation would be great. It is getting power but I suspect with not enough or too much?

Can you post those codes?

What happens when this is done??? Error codes, etc…

Welll… IF IF you are familiar with using some basic test tools you can…

You NEED a DIGITAL MULTIMETER a local “home” and tool stores can provide this inexpensively.

Need to measure the voltage of the wires coming out that you connect to the doorbell. you should get from 19-24VAC


Measure this WITHOUT the camera, post the voltage

Connect the camera/doorbell in a manner which allows you to REMEASURE the voltage with the doorbell connected, post the voltage. And any actions it takes, boots, error codes… IF YOU CAN REPEAT THIS doing a CURRENT MEASUREMENT.

You will need to try to find the “doorbell transformer” and well honestly these things can be ANY PLACE! Mine is located mounted on the breaker panel… Its LONG been disconnected. They could be there, could be in the attic above or any where in between.

You want to find it to get its markings… something like 19VAC 2A or 38VA or something. Post the makrings. Post a photo on as many angles as you can… Measure its OUTPUT to see what it is at the transformer… It could be a bad as in LOW VOLTAGE transformer, or it could be a under current transformer… hence the markings and/or the current measurement would be helpful… BUT a GOOD HINT that current is the issue is that it won’t work when setup from the USB and then powered via the AC doorbell circuit.

BE CAREFUL with handling these! These have AC VOLTAGES from 19 to 120VAC! Do NOT JUST GRAB ON TO THEM OR THEIR TERMINALS!

A lot of bargain bin doorbell transformers are not rated for continuous duty. They are only designed to be loaded when the doorbell button is pressed which completes the circuit. When the doorbell button is not pressed, no current is flowing, unless the button is illuminated which only draws a few milliamperes.

Now bring in a video doorbell that draws current continuously. The poor transformer is not designed for that. In addition to making sure you have the correct voltage, you need to make sure the amps are there also.

Example of a bargain bin transformer

Years ago I installed a Ring doorbell and its remote chime. Worked great. Came home a few months later and got that burning insulation wire smell.

Traced it to an overheating doorbell transformer. It was mounted to an octagonal metal box, and that was attached to a floor joist. The transformer was way too hot to touch. The OTHER side of the floor joist was warm.

I replaced it with this

Amazon says I bought it in November 2019 so it has been working 4 years.

What I like about it is that it is fused and plugs right into an electrical

Neighbor across the street installed a Ring doorbell last year. She told me the doorbell transformer buzzes and keeps her awake at night so she unplugs it when she goes to bed. I told her the transformer is failing and she should replace it. Not easy because it is behind stuff that is behind stuff. It has an electrical cord supplying voltage from a wall outlet. They are snowbirds so the transformer has been connected since October. They will be back in May. Fortunately the house is across the street rather than next door so if it catches on fire there is more space between us.