Device sharing not working

I have 12 pending device sharing requests. Go to Account, Sharing select the email address I want, next screen shows all the pending devices and an icon that looks like a pencil in the upper right corner. I select the pencil. Boxes at the end of each device say Update with a check mark. The update key at the bottom does nothing. App is uptodate.

Are you trying to share a device, or cancel something you shared, or cancel something shared with you?

What OS and app version number are you using?
What device are you trying to share or unshare?

Also, is the shared device actually active and connected?
I just tried doing this with some of my devices on my daughters’ account and it worked, except for when I tried to remove an old lock that is currently offline.


iOS 16.3.1. Wyze 2.40(15)
Share devices
6 cameras, doorbell, outdoor plug (2), 2 lamp switches, robot vacuum
Doesn’t work

So these people have not logged on to their Wyze account using the Wyze app and accepted your share. Tell them to do so.

This portion lets you change what devices you shared. You have not made any changes, so the update button stays gray.

Tell these people to log on to their Wyze account using the Wyze app and accept your shares.


They have logged in. When they get to the place to accept the share nothing happens.

Problem fixed. We were both signed into my account instead of each signed into our own accounts.

[MOD EDIT] Violation: Personal Information Removed

1 Like