Sharing pending but no emails received

I set up my camera and app yesterday. Everything worked well until I tried to share the camera to multiple users. One who had already registered with Wyze, one who is not in the system. The app lists them both as pending yet neither have received an email or invitation.

Welcome to the community @sajafisher . I am a community member as well and try to help out when I can.

First, the wyze app is required to be installed by the individuals you wish to share with. I see that one of them do, as you reported. The email you used to share with must also be the email used with their Wyze Account. If all of this lines up, when they start the app they should be prompted about your Share. If they do not see it, have them go into the Account Menu, ckick on the bubble icon at the top right. Wen the screen opens, tap on Sharing and see if the items you shared is located their.


I tested this with another account (alternate account) I shared the device to the alt ID… after 15 minutes no email with the share offer. I will continue to monitor.

However, when I logged into the Wyze App with the account I have setup with the alternate email, it DID inform me on the app upon login that the device was share with that account.

Could be an outbound email issue… But I know some emails are getting out for Wyze cause I forgot my Alt ID password and had to reset it. I got that email :wink:

My wife and I have new iPhones. Everything worked fine on the old phones. But now I’m having trouble sharing the devices with her. When she opens the Wyze app she gets several messages to Accept the sharing or cancel. She clicks Accept but it makes the message disappear and another appears for the next device. This continues for 6 devices. When she exits the app and then comes back to the app the same thing happens again and again. Any ideas how to fix this.