Daylight savings time rules

Rules are messed up again due to daylight saving time. Everything is coming on an hour early on the clock. (Rule set for 4pm but history shows 3pm etc) How do I fix this?

You should sync the timestamp on your camera(s)/device(s) by opening the device settings → advanced settings → sync time → “Sync”. Let me know how it goes.

1 Like

My timestap IS synced…That’s what’s frustrating.

Same issue here

Same issue here. Although I don’t seem to have a sync option for our outdoor cam or smart bulbs. Checked the firmware versions and everything is up to date.

I have the same issue. My cameras are synced, showing the correct time, but my scheduled rules turning on and off my light bulbs are an hour early. Can we at least have a daylight savings time button or toggle switch to shift the time forward or back one hour if the app can’t automatically do it? I don’t (more like unwilling and will find a different brand) want to edit my schedules twice a year. I love Wyze but this seems like an easy fix.

I have the same issue. Time is right when recording. One hour off on playback.

Having the exact same issue but with a turn off rule for a plug. Strange that the turn on time is working correctly however. I made a 1 minute adjustment to the turnoff time to see if that corrects the issue. They should add a Sync time for the plugs in a future firmware update if this is in fact the issue.

I am also having an issue with time sync. I don’t understand how it makes sense to sync time to my phone. I am currently traveling and in a different time zone than my house. Is there a way to sync time to the network or manually set the time? All of my schedules are incorrect.

1 year later and this is still an issue. I am using the sunset option so my lights are supposed to turn on at sunset. Ever since daylight savings last weekend, they all turn on an hour late. So we sit in the dark waiting for the lights to turn on.

I am just looking for this now, and cannot believe this was brought up a year ago and has not been fixed.

1 Like

Legacy user here…Try since the beginning…

1 Like

Hi @duhbrain99 we’ve solved this issue. Could you send me a message with your email address and the name of your problematic schedule so that we can look into it?

It’s 2022 and it seems that this is just too big of an issue for Wyze to successfully update. My cameras are synced and display the correct time and the rules have not been edited. Yet everything is happening an hour off of the scheduled rule.

My outside cameras are set to notify outside of business hours upon motion detection. We’ve been open for nearly an hour now and we get notifications every time someone pulls into the parking lot.

It’s silly that such a simple thing as daylight savings can not be implemented into the software.

2 Likes

Sync is in Advance Setting on the Wyze Cam Outdoor at the bottom of the list.

This happens twice a year since becoming a Wyze user 4 years ago. They usually take a week to fix this.

1 Like

I have a different story but equally as frustrating. My WYZE plugs have specific schedules to turn on lamps based on my work schedule. Well, today my lamps did not turn on as scheduled. When I checked the app, all of my schedules had been pushed back an hour for both the start and end times. Just because our clocks are set an hour forward dresment mean I want my schedules to be an hour later - I don’t go to work an hour later. I can’t even understand why it would be acceptable to change all of my schedules by an hour - seems like daylight savings time is an obvious thing to manage.

Then I put in a log to report the issue and after doing that, I was instructed to contact customer service so someone could look at my log? Really - why did I do the log.

I love WYZE products, but this one has me puzzled.

@joremson @Joey_RC Sorry for the inconvenience, Could you give more information about your issues. We’ll dive deep into it.

1 your rule name
2 submit a log and send me the log id.

v2 Cams clock/time adjusted correctly.

Rules adjusted correctly (as logged in History.)

Cam Event Recording > Schedule did not.
11:03p - 5:55a changed to 12:03a - 6:55a.

Vacation Mode on original Bulbs and Plugs did not.
6p - 9a now operates from 7p - 10a.

@peepeep I’m a bit confused.

You said “Rules adjusted correctly (as logged in History.)” first, then you said" Cam Event Recording > Schedule did not. 11:03p - 5:55a changed to 12:03a - 6:55a."
Do you mean that the rule history was displayed correctly, while the Cam schedule wasn’t executed correctly? And the same issue to bulbs and plugs?

The issue I had is that with daylight savings time, all of my Wyze Plugs schedules that I had created were automatically advanced one hour. For example, I had the start time for 2 plugs set to 6 am on Saturday and Sunday and these were now showing 7 am. My weekday schedule was set for 5:30 am and that was changed to 6:30 am. The end times advance an hour also, so if I had the plug to turn off at 8 am, it was now showing 9 am. I did submit a log and the id is 499742. This just isn’t right - I had to redo all of my schedules back to their original times and I really don’t understand why they just didn’t stay the same.

Thank you.