Incorrect timestamp on camera feed

Hi community,

I’m hoping someone will be able to help me with this timestamp issue I am having.
The timestamp on the camera feed is always 30 minutes different to the actual time.
I have gone to advanced settings and clicked sync but it doesn’t change.
My router is set to my current timezone.
I have 6 camera and all are 30 minutes out, it’s been like that since day 1, they are all on the latest firmware.

As you will see from the screenshot the camera feed shows that it is 16:54 but my phone time is 17:24 (the correct time).

It’s highly annoying that the time is wrong.

Anyone have any ideas how to fix the issue?

Thanks in advance


What time zone do you live in?

As to what @rbruceporter asked… if you’re outside the United States and located in a timezone with a 30-minute or 45-minute offset, there currently is no solution. Syncing from your viewing device will round to the nearest one-hour time zone. I don’t think Wyze has any plans to fix this.

If you’re in a one-hour offset time zone, check your viewing device’s time settings and ensure that the Automatic date and time setting is toggled on.


Thank you for your responses.

Yes I would be one of those people in the 30 minute time zone offset.

I’ve lived with it this long, I guess I will continue to do so!