Wyze Cam has wrong time on all camera's

I have 7 camera’s. I’m run the Android app and it’s on 2.26.22.
The 7 camera’s are at V3, V2, and V2 Pan at
Both App and cameras are up to the most current versions.
All camera’s have SD cards in them.
The App shows the correct time for events but ALL of the Camera’s are 3 hours fast.
I can not find any setting in the App or the camera’s for time zone (I’m in PST)
I have cleared the cache in the App with no change.
It’s useless to have security camera’s logging events with the wrong time.
What am I missing??

I don’t have an Android phone…did you check the phone’s time? Maybe a timezone setting wrong on the phone?

The phones time is perfect. Also, if you sync the time on the camera’s, they sync just fine. They are just 3 hours fast. Thanks for the suggestion.

Have you tried unplugging them for 10 to 20 seconds? I wonder if I power cycle wouldn’t help them establish a new connection and Link with your phone, the app and the servers correctly and get rid of that ahead time issue.

1 Like

Have you gone into the Camera’s settings area, selected Advance and then Sync Time to ensure the time matches with your Phone?

Haven’t tried that, so I just did. No change.
Good guess though thanks

1 Like

Camera’s have been synced numerous times to with no change. Tried again for grin, no joy. :frowning:

My next best guess would be to re-add the devices. I don’t know what would be causing this issue. I wish I could be of more help

Try to sign out of your app and back in and then sync it

Well, I just tried that and still the same.

All I can tell you the time sinks with your device, I just went in on my phone and change my time zone and zap 1 camera and it showed East. Coast time,I went back to my phone and put it on carrier update on time and zapped it again and now back on pacific time

I did the exact same test as you, I changed the time to Eastern and the Wyze did not change, it stayed on Eastern (which is expected). Changed it back to Pacific, the camera’s stayed on Eastern (which is what the problem is). I did change the time on my phone from carrier set to manual, no change.

I should say my wife’s phone and my phone show the wrong time on the camera’s. Both phone are S20’s.

I went back as far as I can go on the SD card’s which is about 3 days, and it has always been wrong. When they were first installed a number of years ago they were correct so I have to assume an F/W update messed them up but I don’t know which one.

This is just one in a number of issues I’ve had with Wyze. But, like I said a long time ago, what do you expect for $20.

Did you check the time on BOTH phones?

I hope you hit sink time on the advanced tab

No, but I did hit SYNC on the Advanced tab. :wink:

I also completely uninstalled the app, removed any left over orphan files and reinstalled the App. No Joy. :frowning:

It appears that Wyze can’t fix this. I sent them everything they requested.

Well, after trying everything else, I went ahead and deleted ALL the camera’s and Reinstalled ALL the camera’s and that fixed the time issue. I’m not really sure when this all started but I’m glad it’s resolved. Most of my camera’s are in inaccessible locations and require me climbing on a latter to get to them. I’m sure others have the same issue. Add to that, that when you do reinstall them all your personalized setting are off and must be recalibrated (detection is the most time consuming). Thanks for everyone’s help, I hope no one else has to delete and reinstall.