Couldn’t update the setting, check your connection

Android s7 edge

I just got the google display hub thing and wanted to try “Show my camera on the display” but would get the “sorry the camera stream is currently unavailable” message.

So I un-linked it and now I can’t re-link it. Every time I sign in and press accept, I get “Couldn’t update the setting, check your connection.” It’s been a few days now.

Things I’ve tried so far

  1. Switched default browser to chrome
  2. Dleted the camera and re-added it on wyze app
  3. Turned on locations for wyze app
  4. Re-installed wyze
  5. Unplugged internet router
  6. Phone restart

Well… I’ve unlinked all my other devices and apps… Re-linked all of them EXCEPT wyze home app.

Deleted the Home on google… Still nothing.

Any solution I find online it’s “Welp it fixed itself”. Lol my problem isn’t fixing itself after a few days now.

Oh and BEFORE you unlink your wyze cam which is the common method/solution that you’ll find, try telling google “Hey google, sync all devices.”. MIGHT be the easiest solution before unlinking your app and going through this whole sh!t storm

Alright for any poor souls out there who comes across this thread after trying the first 20 links from google…

This is what I did, no idea the exact problem since I just did multiple solutions at the same time.

Turn off/on your wifi on your phone
Reset power on your router

Clear cache inside the app AND in your phone settings
Wyze: Account (bottom right, blame wyze if they changed the layout again. ) Scroll to the bottom App Settings > Press Clear Cache File Size.
Phone: Settings > apps > Wyze > Storage > Clear data/Clear Cache (at this point you’re desperate and don’t care about your settings if they get deleted)

You can do this with your other smart apps, I didn’t… Just wyze cause that was the only app giving me issues.

Then uninstalled all the other apps that were able to connect with google home ie Philips Hue, wemo, etc etc. (yay…)

Restart phone

Install wyze, create new name etc etc

Go to your Google Home app, try linking it. If it still doesn’t work, you’re SOL.

Good luck