Constantly turning cameras on and off

I have triggers to run once a day to turn off and on all 11 of my Wyze cameras. Most v3 and a couple v2. But it’s really annoying when it’s only been 2 hours since they last got turned on and off that I have to use my manual trigger to turn them off and then on. This has been going on for months. I had a to-link ac1200 m4 for 3 years and just upgraded to an asus zen WiFi et8 yesterday and it’s still doing the same thing. Here’s my specs if anyone can help

Xfinity XB7 modem (WiFi transmissions both turned off)
800Mbps (don’t think this matters)
8 Wyze Cam v3 all up to date on firmware
3 Wyze cam v2 all up to date
Asus ZenWiFi ET8 router (2 pods)

Confused what the actual issue is to go on. Why are you manually turning it off after 2 hours?.. did you turn it on 2 hours before it was scheduled to go off but it didn’t so you did?

Side point: ASUS routers tend to have all kinds of errors after a firmware update and need to be factory reset after every firmware update. Also, if its on the original firmware update then ones after that have fixed stability issues. ASUS routers tend to have stability issues (even their latest firmware likely may) that can affect cams not just from Wyze. I don’t think that’s what’s going on here though as you had a TP-Link previously.

I do wonder if the Xfinity modem could be causing the issue. These are internet based cams that are heavily affected by the internet and thus it as well.

I don’t use rules but they will very likely be internet based in some way (looking it up it seems true of Wyze doing it this way as wel). That kind of thing tends to be so any internet or local network based stability issue can ruin it.

But, at the same time, if its internet or network based, that’s a whole other world and its not really something anyone can ultimately fully help you with. It would be similar to telling you how to be a master mechanic on your car. That doesn’t work. So, its a broken record around here.

Here is a more detailed issue. So after a while I will go to the Wyze app to view some of my cameras and after clicking on one it says connection 1/3 but it never gets past that part. The app seems to know that the camera is online and working but it can never completely connect to it. Then I will back out of the selected camera and then turn off the camera and then back on and now I can connect to the camera and view the live feed. This happens constantly throughout the day. I hardly believe it’s an issue with the modem but I am going later to get it exchanged at Xfinity since I am renting it. Hopefully this post clarifies my issue a little more and if later I find out that the issue was the Xfinity modem I will report it.

1 Like

I’m having the same issue, I have ring cameras too and don’t have an issue with them connecting so it’s not my modem. Mine does the exact same thing. Are you paying for the monthly service or using a SD card? I’m using the as card

I’m using endurance sd cards in some and others none. So it’s definitely not my modem/router combo I get from Xfinity. It’s still having the same issue even after exchanging. I also tried connecting two of my Wyze cam v3 to the xb7 router/modem combo from Xfinity and they are still having the same issues. So can someone from Wyze please elaborate what is causing this issue? Seems like it’s not just me with this problem.

1 Like

From what I’ve been reading, several people say it has something to do with the cam plus subscription. I haven’t cut my cameras loose to check it yet but thought I’d mention it. My cameras turn off everyday, several times, and turns on ‘privacy mode’ on 2 cameras, (I think they’re the v2’s), around 7am every day, though I’ve deleted all rules. I created a new rule to turn all cameras on because it happens so much but the 2 I have to go in and turn privacy mode off. Trying to fig out how to run the rule to turn them on automatically every hour or two. If I could get this licked, I’d be in pretty good shape though I do have some connectivity issues from time to time.

I made a restart all cameras shortcut myself. this issue started for me in January.
cameras are online. iOS app never loads camera completely, unless i power cycle the cameras. That only lasts for a couple hours. then the process repeats.

Are your cameras lights blinking blue? mine were.
Ended up taking a camera, deleted it from my account. installed it at a different home, different iPhone, new account, different Wi-Fi. new SD Card. Problem still followed. I have downgraded back to firmware prior to the updates. no change.
Wyze Support wanted screenshots of device info for all my cameras affected and a speed test result. I sent them in. they said they are aware of the issue and there’s nothing they can do.
this response was sent twice under 2 different support numbers.

I have upgraded my inside cameras to a different brand. my outside cameras are still Wyze floodlight V2s until, they fix their issue, or I find a better floodlight/camera.

That’s just great. Do you mean a ‘rule’ or is it something else. I’d like to automate it if I can.

How this isn’t a top priority for Wyze, I don’t understand. I’m wondering if the Roku cameras suffer from the same thing.

What brand did you switch to?


Yep, made a rule.
I switched 2 cameras to eufy E220 cameras.
No issues with them yet.
I do feel the zoom isn’t as close as the Wyze V2, and Pan V2 cameras were, but it’s worth the change for a dependable camera ready when i want to access it.

I tried reading about problems with Wyze before I bought them but missed any of what I’m experiencing.


Thanks for the tip!

Having same problem here. Xfinity Xb7 gateway. My 3 Wyze cameras drop connections randomly throughout the day. They work flawlessly on my WAN but don’t livestream outside my network most of the time unless I restart cameras using app. How can I command a restart outside my LAN but not livestream? Makes no sense. Wyze tech support was supposed to get back to me a month ago but haven’t heard from them yet. Had these cameras for three years and never has a problem until about 3 months ago. Very frustrating.

Hmm I also have and Xfinity XB7 modem/router. Had the same router/modem for 2 yrs now.
Unless Comcast did a firmware upgrade to them recently.
I work in a place with a Spectrum Internet connection. I’m planning on taking a camera to work and seeing if i get the flashing blue light & remote connectivity issues there.

I’d be interested in what you come up with.

Might not be able to test until next week. but i will post my results.

Well, I took one of my pan V2 cameras to work.
Had to delete it from my Wyze iOS app, add the device again, with the new WiFi credentials. The blue light remained solid for the 5 hours I was at work, on a charter spectrum WiFi network.

Then I took the camera home.
Had to delete and add the camera once again.
After 40 minutes on my Xfinity XB7 WiFi, the blue light started to blink.
I did not try remote viewing while at work.
I might try the process again next week….