Connection issue - with a twist

Hi. I have two Wyze V3 cameras on Cam Plus Ultimate.

On the iPhone app both cameras, Cam1 and Cam2, connect and stream live.
On my PCs (two PCs) however, only Cam1 connects and streams live.

I have tried resetting the camera itself, the WiFi router, and the PCs. No success.

Has anyone come across this? Anyone have an idea as to how I can go about fixing this issue?

Thank you.


Welcome @forexblue

Hpw are you streaming on a PC? There is no Wyze App for the PC, unless you are talking about on a browser.

Just looking for additional information here.

1 Like

When you set up the cameras, did you take the extra step to register both of them to the Cam Plus account ? It almost sounds like you missed that step during the registration process. One way to check would be on the Wyze Web Portal, Click on teh Account tab at the top of the screen and then look at your services. It should tell you how many cameras are on the plan.

1 Like

If I remember correctly, some one reported that clearing their browser cache fixed the problem with Wyze Web Live

There’s a possibility Cam2 isn’t on Cam Plus or there’s a problem with Wyze’s backend server verifying you have Cam Plus. You can try going into Settings > Reset Services.

If that still doesn’t work you can try deleting the device and setting it up again, but that will require you to have physical access to the camera.

1 Like

Yes, they’re both registered to my Cam Plus account.

Thank you.
Yes, on

Apologies for the mess I made in here with deleted posts. I wanted to make sure I actually used the ‘reply’ function to you kind people helping me here, rather than posting my responses to your feedback randomly.

I need to get used to this forum layout.

Clearing browser cache didn’t do it unfortunately. The thing is Cam2 is connected and live on the app (iPhone) so it must be on cam plus. I also manually checked to see if it’s registered and it is. That’s the twist :slight_smile: If it works on the app why not in the portal?


I just found that is recording events on Cam2.
It’s just not live streaming.

I’m looking at both cams right now, side by side. Cam1 is live - Cam2 says ‘reconnect’ (which I’ve tried many times)

That is very strange. You can try using other browsers to see if you can replicate the issue, but I doubt it would solve your problem considering Cam1 is able stream on Web Live.

Web Live has always been buggy for me. I occasionally get “Web Connection Failed” and it’s completely random when I get it. I even tried to tweak my browser adblock settings in hoping that will fix it. Sometimes it would connect very quickly and other times it takes a while for me to get connected.

If you can’t resolve it then I think your better off installing Bluestack on PC and Wyze app to livestream your cameras (limited to 4 cameras if you add it in a group).

There’s multiple points of failures / differences even for the same devices that can affect one or the other…

  • Cam firmware version or differences from things happening during updates (one or more could become different).

  • Wifi AP connected to.

  • Wyze servers connected to can be different.

  • Router has to treat both the exact same (and routers are complex so you never know).

  • Etc etc.

You can obviously try looking at the router interface to see what’s going on.

Wireshark on the computer might help or not.

But similar to @grapefruityoda suggestion, I’d just try from something else and see if it works. This is not any less complicated though for most people. For Bluestack to even not be a pain your computer needs the right hardware and BIOS/UEFI setting enabled. That just goes over the heads of most people.

Thanks. Yes I tried Chrome and Opera - same issue.
I’ve been holding off on your previous suggestion of removing and restarting Cam2.
Now’s the time to do it.
I’ll let you know how I get on :+1:

I know the firmware is up to date on both, but yes something might have happened during install.

Would Wyze use different servers for the cams on a single account?

I’ve been into the Router interface - settings are identical, so nothing I can work with in there.

My bios is UEFI virtualisation ready so I tried Bluestack when I setup Cam1 - couldn’t stand it. Didn’t see any advantages, and Google was giving me issues about creating an identity for the camera, so I ditched it.

Thanks for your feedback. I’ll get hold of Wireshark - you never know :slight_smile:

I’m still trying to resolve this problem.

I’ve reinstalled. That didn’t fix it.

I’ve tried everything that people have suggested now and I still can’t stream live to one of my V3 Cams on PC.

If anyone has any further ideas I’d appreciate it.

It is May 27 and I have the same issue with one of my V3’s. It will record events on Cam Plus but not live stream. I did submit a log and have worked with support. They say to wait as the engineers will work on it. Unfortunately I now see that I have another V3 that records everything on events despite selecting Smart Detections :frowning:

1 Like

I’m sorry to hear you have exactly the same issue, but I must admit it feels good that I’m not alone on this.

I really hope the engineers give you a fix, dvaiciunas. Please remember me when they do :slight_smile:

1 Like

I wonder if your router’s firewall is somehow only blocking “Cam2” connection to Wyze’s Web Live. May I know what router are you using?

I don’t know what else can you do. You can try the beta firmware as a last resort if you like. Here are the instructions to become a beta tester. You can always manually flash back to with instructions here. Please note this beta firmware introduce a new behavior which I detailed below.

It’s an EE Smart Hub (identical to a BT Home Hub) Which may not mean a lot if you’re outside the UK. The firewall is set to ‘Allow all outgoing connections and block all unsolicited incoming traffic. Games and application sharing is allowed.’

There are no device-specific settings in the firewall so unlikely to be blocking Cam2.

Thanks for the Beta details. I’ll try absolutely anything :+1:

In my case - the V3 is updated with the same software as the other V3’s and all purchased in the last 6 months. I use a Wyze Router and as noted - the one that will not live stream is now only 15 feet from the router and the modem. I have moved it around with the same results. Note: the other V3’s work just fine. I have a small house (1200 sq ft) I am thinking it is a defective unit.

Same here. The one that’s not live streaming on PC is closer to the router than the one that works. Both have the latest firmware update.

I would have suspected a faulty device if it didn’t live stream on the app, but it does. Works perfectly. It’s just in the portal that it doesn’t show live. It records without a problem.

I’ve tried it on two different PCs and on a linux machine, all without success.

I also spent many hours learning about all the settings in my router. Tried many things in there. But it remains a mystery.