Connecting failures after new router

After installing a new router with same name and password, my cameras and doorbell connected and needed no action by me. The problem is the light bulbs and plugs did not connect. I deleted them from the app and went through the setup process (blinking bulb and fast blinking blue light on plug). The bulbs and plugs wont connect following the app instructions. I unplugged/plugged the bulbs and plugs and tried to again. Still no luck. Keep getting the message “connection failed”.

This is an issue for a lot of the older devices. They are using a chip that is very picky (same with a lot of other older IOT devices with other companies).

There are common issues:

  1. If you are trying to use an OpenWRT-based router firmware (including Gargoyle. etc). The chip in the old plugs and bulbs commonly have issues with OpenWRT.
    • Related to this is the WMM mode (Wi-Fi Multimedia), which when turned on often causes problems with the chipset used in the V1 plugs and bulbs and many other companies’ devices. If you are able to turn off the WMM on a fairly permanent basis, this has often resolved many people’s IOT connection issues. I was able to do this on one of my OpenWRT firmware routers (Gargoyle) and after disabling the WMM (using putty or WinSCP to access and manually edit the firmware directly) I was able to get my devices to connect to the router…the only problem is that sometimes it would reset the WMM to turn back on (I think everytime I rebooted the router) and this became too much of a hassle, so I finally gave up and just switched routers to resolve this issue one of the times I had this struggle.
  2. If your 5gHz and 2.4gHz SSID name are the same name, sometimes this older chip in the V1 plugs and V1 bulbs have a lot of problems with that.
    • If that is the case, you can try temporarily disabling the 5gHz SSID, and then set everything up again and it should be fine. Then when you re-enable the 5gHz, the older IOT devices (plugs/bulbs) should be linked to the actual MAC or other identification of the 2.4gHz chip, and ignore the 5gHz. They seem to hate switching over to a new router because they appear to link to something other than the SSID name (probably the MAC)), but newer devices switch easier now that they use a different chipset. When I switch routers I can usually get the older devices to switch to the new router by rebooting them (maybe a couple of times) and sometimes waiting as long as a day or so, and they’ll usually switch eventually. That’s been my experience.

If you continue to have problems, consider changing the name of the 5gHz SSID to be different from the 2.4gHz SSID. That sucks, but I had to do it once. Also, you can always use your previous router or another router to be dedicated to the IOT devices, and have all your other devices use the new router.

I hope one of those things can resolve your issue. I’ve gone through this multiple times, wasting countless hours trying to figure out what’s wrong, so I know how frustrating it can be. I am glad Wyze has switched to a new chipset on all the newer devices, but the older ones are still a big pain.
V2 cameras also sometimes struggle with switching to a new router a little bit (though usually will switch after a while or after a couple of times rebooting it, or maybe setting it up again), but the V3’s are pretty good at easily switching. If they have any problems, usually a reboot resolves it right away.

Best of luck. Hopefully I saved you some of the dozens and dozens of hours of research and testing I had to go through trying to figure out the same thing.


that is a very very good explanation. definitely one that will be referenced!


Thanks buddy. I would’ve been so desperately grateful for the above information last year when I was frustrated to wits end trying to figure out why my devices just wouldn’t connect. I tried EVERYTHING in the other troubleshooting threads and finally found stuff in the OpenWRT threads explaining the issue was with a commonly used IOT chipset, and some options for trying to resolve it. I can’t tell you how glad I am the newer devices are improved in all those ways. :slight_smile:


If I turn off mobile data then they connect OK and quickly. Guess I missed that memo.

Ah, yes, that is a common issue to help resolve setup for those setting up devices for the first time . Since this wasn’t the first time and you previously had them set up (apparently without having to do that last time), I didn’t include that option as it seemed that wasn’t a problem for your phone since they previously set up okay without doing that. But yeah, some people do have that issue with the older devices too. Interesting it didn’t make you do it the first time, but is making you do it now. You must’ve switched phones since the first time and your new phone is pickier with that?

I keep a $19.95 burner phone without service - WiFi only around the house just for adding problematic 2.4 GHz devices to my network. Wyze is not the only product that sometimes is difficult. Found the Trafone burner on Amazon.

And I know this is not part of the conversation, but let me add. With the WiFi only old burner phone, you can install the Google Voice app, log in to your gmail account at Voice and select a Voice VoIP telephone number. So for FREE (who does not like FREE?) So for free you can have a WiFi phone/phone number that not only works at home but take it with you.

Ya never know when a WiFi only extra phone with WiFi service might be useful. You could be caught in a bank robbery where they make everyone put their cell phone in an old dirty white bag. And you have your spare burner/WiFi phone to call for help or a pizza. And if you are a quick thinker, you might just give them the burner and keep your good one for that Grub Hub call. Don’t forget to turn off the phone though. Last thing you need is a call from mom after they think you already gave them your phone. Think, bubba, think.

1 Like