Color Bulb Mandatory Firmware Update not working (resolved)

It’s strange that even with the base firmware you are not able to set the state of the bulb. Are able to see what firmware the bulb has currently? And what OS are you using?

Have you tried a factory reset by turn the power to the bulb off and back on 3 times fast? If that does not set the bulb back to setup mode then I would lean towards a diagnoses of a bad bulb. If it does reset, remove the bulb from the Wyze app and add it again and then see if you can set the bulb state to off back in the device listing. It may take some fiddling and possibly let it fail on update try before you can get back the device listing.

I am running the latest iOS that came out this week on Apple. I have hard reset the ball by turning it off and on three times. And yeah I’m running 1.2.359 on the bulb.

Wyze did send me two replacement bulbs and even with the replacements it’s still failing.

And when I try to turn the bulb off with the app, as soon as I come back to the main screen from the bulk update page the bulb automatically switches back to on in the app. Same goes for when I click on the actual bulb and turn it off on the bulbs menu

Oh well I inherently have bad luck with technology but this one is definitely taking the cake lol

@mike47336 sounds like you have everything there that you need: your OS is the same as mine, your current bulb firmware is what mine was when I started.

The one thing that is different is my bulbs stayed off when I set them to off in the Wyze app. Having turn back on on their own is very strange. How much time elapses between them turning back on and when you set them off in app? Do you have a setting of “return to previous state” turned on? Might you be double tapping the button in the app? I know their can be some circuits that are not designed to led bulbs might where you have this bulb plugged into be one of those? I’m kinda grasping here, your situation is a head-scratcher.

Nope not double tapping at all.

I definitely checked the return to normal state setting. Made sure everything is set to factory defaults. We just redid all the electrical in the house, brand new everything down to the breaker box. All lights in the house are already led. Tried using multiple different light sockets, from lamps to ceiling sockets, to outdoor light sockets. No dice

Solved it, I had to literally factory reset my Wi-Fi router and reset it up from scratch. After doing that the bulbs updated and I was able to control them before updating and turn them off first.

So final troubleshooting Hail Mary step is factory reset internet router

Thank you, thank you, thank you, thank you!!!

Had the same issue with a slightly different circumstance and thought I’d share in case someone else is having the same problem. So when I added 4 new BR30 bulbs it prompted me to create a group which I did. When attempting to use the group I would get the same firmware message and not be able to do anything.

The way to resolve it, is to delete the group, then proceed with what others stated (turn off lights via app not switch) and then proceed to hit the update now when prompted for firmware update.

Couple of times of notes for engineering team working on app … when selecting Update all at once, either with or without a group, the bulbs do NOT appear in the list of hardware items to update. You MUST choose the update now option in each individual bulb when prompted.

This seems like a lot of work for this kind of product.

Yeap - Just bought three from Amazon. Setup the first bulb, was prompted for the update, tried while the lightbulb was “on” in the app and it failed and the bulb went offline. After some quick searching - turning off the power off and then back on let the bulb reconnect. Tried the update again with the bulb on and the same outcome.

Another quick search and it turns out the you really do need to turn the lightbulb off “in the app” then apply the update and “bingo”!!

WYZE - You guys should update the firmware prompt with these instructions. Would save your customers a little bit of the headache.

Cheers!!

1 Like

I was just dealing with this as well when two of the lights were offline and the other two were updated – you have to make sure that the power recovery settings are set to ‘turn on’ so that when you turn the power off to the bulbs and back on, you can turn them off with the app. Once they’re off from the app the bulk update worked for me. Mine was set to ‘custom per lights’ for some reason