Color Bulb Mandatory Firmware Update not working (resolved)

Try this. Turn the bulbs off within the app first. Then go to settings, firmware update and run it the update from there. Thats what worked for me.


@ytsejam777 Thanks for the reply. This worked for me, though I did need to disconnect power to the bulbs first, plug back in, then turn them off in the app, then attempt the update. They are updated now!

1 Like

I’m having the same problem. My light won’t complete the mandatory update and keeps failing. This is also my first experience with this light and I’m pretty frustrated.

Thanks for the replies folks.
I tried the suggestion of turning off the lights via the app and updating the firmware and it seems to have worked - thanks for that suggestion!

This worked perfect. I have been fighting with this for two days. Finally decided to check the forums. Thank you!

1 Like

I just bought 3 Wyze color bulbs during amazon prime days, The initial setup was the easiest of any smart device I own, and I have a ton. No idea how long these sat on the the shelf, but they all required a firmware update, else they are shipping with old firmware, if the latter then shame on you Wyze. On the first bulb I spent 45 mins trying the update firmware. try after try I constantly got the “Oops Something went wrong” after waiting what seemed like forever for the update to apply. I went online looking for help and did not find much but I found this reddit thread: which unfortunately did not help. I then contacted Wyze support via their web based chat. Unfortunately their tech support is script based and the people running them either cannot, or will not deviate from the script and try actual tech support. The script they are handed by their in house technicians has a lot of mumbo jumbo about rebooting routers (which we called a punt in my tech support days), and when that doesn’t work they then blame your wi-fi being interfered with by too many neighboring wi-fi signals. They might as well have used the BOFH’s excuse calendar.

So there i was with one, possibly 3 dead to me color bulbs. I could not use them with the lower firmware as the app instantly puts up a “firmware update required” overlay on the controls. I was about to send them back but gave the interwebs one more try. I then read into the comments (something that rarely if ever should be done :wink: ) of the reddit thread and found this gem:

OMG got it to work for both bulbs! Turn off the light first within the app before updating firmware!

Exact steps:

  1. Via app; Tap on the color bulb.
  2. Tap the off button which is just to the left of the “brightness” slider.
  3. Tap “Settings” > “Device Info” > “Firmware Version” and run the update.

Voila! Worked!

Figured this out by accident; that is, not from help from support. I suspect this works because the firmware update is trying to access some subsystem that is locked while the bulb is on.

So I gave it try, I was not able to click the power button in the control area of the bulb due to the firmware overlay, but conveniently there is an on/off button on the list of devices. Once the bulb was off, I then went into the control area and ran the firmware update as normal. The firmware update went through without a hitch. I hope this post not only entertained, but may also be informative for the next unsuspecting purchaser of the Wyze Color Bulb.

[Mod Note]: Post moved to this more current topic for better visibility and consistency in grouping similar posts related to production (vs beta) firmware.


Thank you!! This was driving me crazy!

Hey I’ve tried this, among every other trouble shooting step. Gone as far as clearing cache, resetting home router, re installing the app. Resetting bulbs and re pairing them.

Still no dice for me. Any other ideas?

1 Like

I am sorry none of this has solved your issue. Those are all the ones I know of, at this point I would have to recommend calling support.

Wyze Support

(206) 339-9646
Mon - Fri 4am - 8pm PT
Sat - Sun 8am - 4pm PT

Turning off the bulb and then updating through the bulk update page worked. So weird, because most Wyze products need to be on to update.

Thank you for saving my sanity!

Called support, all they did was run a robotic script and send me two new bulbs that also are not updating.

Tried using three different phones, made sure my phones OS are updated to latest version, deleted Wyze and reinstalled, cleared cache, reset router, did all the turn the bulb off and on steps that everyone else said worked. Nothing worked. Still stuck with not being able to update.

Any leads when Wyze will actually address this issue and fix the bug? Super frustrated here

1 Like

Mike, have you tried updating the bulbs when they are off?


Yes if you read above, I have turned them off in the app before updating. It doesn’t actually turn them off though because the firmware being out of date makes it so one can’t even control the bulbs at all

Just to mention this incase there is some confusion: by “turn the bulb off” it is not meant turn off power to the bulb by either flipping the switch to the socket it is plugged into or unplugging the power cord. “Turn off the bulb” means to set the bulb to an “off” state in the app. The bulb will still have power running to it (which it needs to run its Wi-Fi and get and process the update, but it will not be emitting any light. This is counter-intuitive portion of Wyze’s workflow as they have the bulb start emitting light during setup and then jump right into the firmware update.

Also there are 2 places where you can set the bulb to its off state: one is in the bulb’s control screen (where you can set color and intensity, etc.). But when a firmware is required you cannot use the power button on the screen because the update firmware overlay prevents it. So you’ll need to the “off” button on the main page of the Wyze app that lists all your Wyze devices

then tap the bulb to open it’s control without hitting the “on” button where you should then see the firmware update screen. Do the update, and that has been what is working for most.

If this setting the bulb to an “off” state before firmware update and you still get the “oops” message then perhaps it is a bad bulb, but to get multi bad bulbs in a row is highly unlikely. So other more out-there things to try is put the bulb in a different socket (maybe you have a janky wire or grounding issue with one you are trying). Try a different location … again highly unlikely but it is possible to have interference from neighboring Wi-Fi that could prevent an error free download of the firmware (although you would see other slowness in all other Wi-Fi communication) but still worth giving it a shot if you can.

That’s my $0.02 worth.

1 Like

Yes no confusion here. Exactly what your explaining I’ve done

It’s strange that even with the base firmware you are not able to set the state of the bulb. Are able to see what firmware the bulb has currently? And what OS are you using?

Have you tried a factory reset by turn the power to the bulb off and back on 3 times fast? If that does not set the bulb back to setup mode then I would lean towards a diagnoses of a bad bulb. If it does reset, remove the bulb from the Wyze app and add it again and then see if you can set the bulb state to off back in the device listing. It may take some fiddling and possibly let it fail on update try before you can get back the device listing.

I am running the latest iOS that came out this week on Apple. I have hard reset the ball by turning it off and on three times. And yeah I’m running 1.2.359 on the bulb.

Wyze did send me two replacement bulbs and even with the replacements it’s still failing.

And when I try to turn the bulb off with the app, as soon as I come back to the main screen from the bulk update page the bulb automatically switches back to on in the app. Same goes for when I click on the actual bulb and turn it off on the bulbs menu

Oh well I inherently have bad luck with technology but this one is definitely taking the cake lol

@mike47336 sounds like you have everything there that you need: your OS is the same as mine, your current bulb firmware is what mine was when I started.

The one thing that is different is my bulbs stayed off when I set them to off in the Wyze app. Having turn back on on their own is very strange. How much time elapses between them turning back on and when you set them off in app? Do you have a setting of “return to previous state” turned on? Might you be double tapping the button in the app? I know their can be some circuits that are not designed to led bulbs might where you have this bulb plugged into be one of those? I’m kinda grasping here, your situation is a head-scratcher.

Nope not double tapping at all.

I definitely checked the return to normal state setting. Made sure everything is set to factory defaults. We just redid all the electrical in the house, brand new everything down to the breaker box. All lights in the house are already led. Tried using multiple different light sockets, from lamps to ceiling sockets, to outdoor light sockets. No dice

Solved it, I had to literally factory reset my Wi-Fi router and reset it up from scratch. After doing that the bulbs updated and I was able to control them before updating and turn them off first.

So final troubleshooting Hail Mary step is factory reset internet router