Classic plug setup nightmare needs to be addressed!

Wyze needs to create a plug setup selection for the classic or new bluetooth plugs, forcing us to wait 1 to 2 minutes for the app to detect if we are using a old or new plug is unacceptable.
In my case I now have to go through this nightmare for 20 plugs.

I have been a customer from day one and recommended them to many friends, this needs to be fixed.


Although I have not had to reset my plugs, most are the older version. I probably have about the same number as you but only 3 or 4 are the bluetooth models. This is just another blunder in the ongoing saga of the Wyze application and other issues.


Wow- I feel your pain! I found it’s impossible to erase and reset my older plugs, and they’re just not working right anymore. It started taking slightly less time trying to reset when I switched to using an iPad instead of the phone, but same results with the plugs just not following the schedules. The Scheduling and Rules operations seem to be totally messed up and the old schedule is impossible to erase.

I am frustrated beyond belief and now unable to contact any support help.

Are they not resetting or is it that you haven’t waited long enough for the setup process to time out so you can switch to the old plugs?

All I have are old plugs. They seemed to quit working correctly recently- maybe when I downloaded the new Wyze plug app update.

It was taking forever to wait for the bluetooth that never connected from my phone, but when I switched to the iPad and turned off the Bluetooth then it would eventually allow me to set it up via wifi. Each time I got that far, I would put in a schedule, then test it out, and each time it would follow the schedule up until when the item turned off, as per the schedule, but it somehow would turn back on immediately. I repeatedly erased the old schedules, then tried making a new schedule with the same results. So frustrating and time consuming.

Did you use one rule with start and stop time or two rules, one to start and one to stop? I’ve read elsewhere that the latter sometimes works better.

Ohhhhh. That’s interesting! I used one rule to start and one to stop; they’re two separate actions but on the same device and rule page. It worked fine when it was set up like that for months. So, you’re saying it might work better to make a whole other action using the same device name but a whole different action on a different page? In my never-ending repetition of retrying the same thing that fails over and over again (definition of insanity, right?), I’m waiting for it to finally work correctly again tonight, but if it fails once again, I’ll try to make 2 different rules! Thanks so much! Fingers crossed!

I have the same issue. About two weeks ago my original Wyze Plugs went offline (?) and since they cam back online the on/off schedules have been wonky. Really frustrating. I have been trying to resolve the issue for weeks to no avail.

I know that frustration. I finally got one of my old plugs back on a schedule after hours and hours of trying to get it to pair. Nothing will work with Plug #2. It just won’t connect. I’m not even sure if the old plugs have bluetooth, but it keeps insisting I pair it, then it won’t work. Over and over again.

it is a pain but if you wait a minute or 2 during this bluetooth process you get a screen where you can select the old familiar way of setting up your plug. just make sure you delete the old rules and setup new ones. This worked for me… ( took hours after having to replace my router, I have many of these first generation plugs).
I hope wyze fixes this ASAP, but we will see

I have to thank the Wyze Team for resolving this issue. Thank you, for listening, you made it easy again.:hugs::heart:

Can you tell me exactly what issue did the Wyze team solve for you?

They added a nice link to they old style plug
Setup, at the bottom off the screenshot.

1 Like