Can't delete wyze scale from app

My scale just started having problems with just showing the weight and not sharing details like BMR or water ect… So Wyze couldn’t trouble shoot so I was sent a new scale. When I went to take off the info for the old scale it wouldn’t let me past the cog wheel and when I clicked on it, I was returned to the main page with all my wyze products. Also my personal data is gone so basically it’s just a scale without the smart! Please advise.

Welcome back to the forum @shannon01

I remember a scale reading issue I had in the past as well and it was caused by missing data in the health data page. Not sure how or why the data was missing but it was a single field.

By chance do you have all of your data entered in the Health Data page in the Wyze app?

This is found under the Account icon of the Wyze app, then Account again, and Health Data.

Yes, I see my specs but my problem is trying to get the app to connect with the scale again so I can see not only my weight but my BMR, water consumption, so on and so forth. The app won’t let me delete the scale so that I can start over. When I try to it takes me back to the main menu where all my wyze products are. So frustrating. :unamused:

Sorry for the frustration. I’ll try to be of some assistance if I can. I see you said they were unable to troubleshoot. And I apologize if you have tried some of these things, not sure what you have done to this point.

What version of the Wyze app are you on? If on an older version an update may help?

If on the latest version have you tried clearing your cache, force stopping the app, reopen then trying to delete the existing scale?

Not sure if you have to be connected to Bluetooth to delete as well. Have you tried removing the device when it connected to the scale?

Just thinking of some things I would go through if in your place.

Cleared the cache, then closed the app, ( hope that’s what you meant by a force stop) went to delete it with Bluetooth and the same problem persist. It looks like it’s connecting on the scale and states that it is but the info doesn’t update on the app side. This has been going on since before I got the new scale and it worked for a little while when I got it but I decided to compare the old scale and the new scale to see if there was a difference in weight and that’s when things went awry. I took the batteries out of the old one and set it far within Bluetooth range and still can’t figure it out. :person_shrugging:

That’s the current app.


Anybody from technical support willing to help!!?

Awesome… you are excited no worries about the caps :wink:

Wyze support doesn’t show to often in the general forum channels unless the is a widespread issue happening. You can try the below. I prefer calling as it has been my best experience.

Support can be reached at; Online Ticket WYZE Support Live support is available: +1-206-339-9646 Monday - Friday 4 am -8 pm PT
Saturday 8 am - 4 pm PT

I had a similar problem in that the scale wasn’t sending data other than weight and bmi. I opened ticket they were unable to troubleshoot it but said the engineers were on it. Then the ticket was closed. I reopened the ticket and asked for a status. They told me they just didn’t know what the problem was. They sent me a new scale,. Same issues.

Same here!! So much for investing in Wyze products!!