Cannot record to SD card, No event detection

I recently purchased a Wyze Cam V2 to test it out. I purchased a Wyze SD card as well. The setup was simple and everything seems to work ok (firmware was updated to The camera is operating as anticipated based on my settings. I am also receiving notifications as expected on my iPhone 6s.

Given the ease of setup, I decided to purchase two additional cameras. The only difference is that I purchased Sandisk 32GB SD cards to save a few bucks. The setup went as expected (firmware was updated to Unfortunately, these two cameras will not report events or record data even though I have Event Recording and Continuous Recording turned on. Based on some of the posts in this forum, I formatted both cards to FAT32 but this didn’t resolve my issue. I tried formatting using the app as well as on my Windows 10 PC. Both cameras are acting the same way. Naturally, the SD cards are the common denominator.

I am not using cloud for storage. My preference is to use the SD cards.

  • No issues connecting to any of the three cameras
  • No notifications are being sent on the second and third cameras even though I have them enabled to send notifications for motion and sound. I know my notifications work because I receive them for the first camera.
  • No events being reported even though motion and sound detection
  • No recording to card.
  • No playback available - Message is “No video at the selected time”

Hi, @jdn132. Welcome to the Wyze forums!

Sorry to hear about the issues you are having with the cams. If you haven’t already given this a try, I recommend doing a uninstall/reinstall on one of the misbehaving cameras. Also, if you have a different brand SD card handy, you can try that and see if it makes a difference.

You can also report this to the Wyze Support Team and get a support ticket started on this issue here.

I am having a similar problem. I purchased my first two new V2 cameras last week. Neither camera will record or send me notifications. I have troubleshooted all the settings with the Wyze staff. It appears like it is a problem with the firmware. They are still working on my support ticket. But I am very frustrated with the lack of solutions and the lack of a phone support line.

Hi, @chadarmitage. Have you tried contacting Wyze support with “Live Chat”? Click on support and you can speak to a Wyze Wizard about your case.


Wyze support team is available Monday-Saturday, 8am-4pm PT

@jdn132 - Did you try swapping the Wyze card into the new cameras? And like @StopICU33 wrote - start a support request.

@gemnii - this will be one of my next steps when I get home tonight. If that doesn’t work, I’m going to reflash the firmware.

@StopICU33 - Thanks for the response. I’ll try those tonight.

1 Like

Yup. 3X. They still have 3 of my tickets open, They are trying to figure out what the problem is. I am supposed to try a “flash the firmware” tonight.

1 Like

Problem solved. Here are the steps I took to troubleshoot and resolve.

  • I confirmed that the issue was not with the Sandisk SD card by putting the Sandisk into the one functional camera. All seemed to work well and was recording video and events.

  • I deleted the two problem cameras and added them again. No change.

  • I re-flashed the firmware on the two problem cameras and this did the trick. See YouTube video link below for instructions to re-flash.

Instruction Overview:

  • Download the latest firmware from WyzeCam website.
  • For V2 cams, change the firmware filename to demo.bin and place this file into the SD card root directory.
  • Hold the setup button and continue holding it while you plug the camera into a power source. Continue holding the button for ~6 seconds prior to release.
  • The camera will go through the initialization process and after a few minutes will connect.
  • If for some reason it doesn’t reconnect, simply add the camera and perform the setup process.
1 Like

I had the same issue and flashing the firmware worked for me also.

I just cleared the app’s cache under account / app settings / clear app cache and that fixed it for me