Cameras Not Recording Events and Not Recording to SD Card

My three cameras all worked great until about 1-11-19. As of that date, they stopped recording event videos (and obviously stopped uploading and notifying me of said videos). They also stopped making continuous recordings to microSD card.

I can record time lapse videos, and I can do manually-started and -stopped videos, both of which will record to the SD card.

I’ve tried the recommended factory reset, which fixed nothing.

Wyze tech says: “It would seem as though you are encountering a bug that has recently appeared. We are currently working on a fix for this and it will be released in an update in the soon future.”

I’m surprised that I’m not seeing more reports of this problem here. I noticed that Amazon isn’t accepting reviews for Wyze cams today.

Anyone else having a similar problem? Anyone find a solution?


Can you still reliably connect to the live stream?

I have seen some reports of installed microSD card interfering with normal camera function. I would try this… unplug the camera, then remove the SD card. Plug the camera back in and verify you can connect to the live stream, double check that motion detection event video recording is enabled (camera settings > event recording > detects motion). Then see if you can get events sent to the cloud.

If this works, I’d format the SD card on a computer using the tool below, then test cloud events and continuous mSD recording again.

Official SD card formatter from the SD Card Association:

1 Like

First, I just wanna say thanks for your quick reply.

I’ll add that I had three cameras in operation, all with microSD cards, and all sending event notifications to my phone. I used that feature, along with continuous recording, for at least two months, including all of November and December 2018. When it stopped working, all three cameras stopped working. I have spent a lot of time trying everything I can think of to fix this problem. I’d rather not have to learn some new camera’s software if I can make these work.

I’ll will try your suggestion. I’m skeptical, because I’ve tried replacing the microSD cards with brand new ones, and it made no difference. I’ve also tried to send event videos to the cloud with no microSD card at all. Correct me if I’m wrong, but I don’t believe the cameras even need microSD cards to send the 12-second videos to the cloud.

EDIT: I can reliably connect to the live stream. I noticed that I hadn’t answered that question.

Thanks again for your suggestion.



Correct, no mSD card needed for cloud events. That’s essentially what I was asking you to test, after a power cycle with card removed.

To rule out general connectivity issues, it would be good to know if you are able to live stream reliably from the cameras to your phone with your phone not connected to the home network (eg. over cellular data)?

Also, have there been any changes at all to your home network, router, or ISP setup?

1 Like

It also might be worth temporarily moving the cameras closer to the router, but if he’s getting reliable connections, that may not help. In “Device Info”, what signal strength is displaying?

Replacing the SD cards didn’t seem to help, but was there any examination of the original cards? Such as were they readable in a pc? What was the last file saved? Did they all stop exactly at the same time or was it after a firmware upgrade or something?


Yes, I’m able to live stream reliably from the cameras to my phone using my cellular data, with the phone’s wifi turned off.

I didn’t change anything. I’m using all the same hardware and the same ISP, and I haven’t changed any network or router settings.

I have one of the cameras beside me right now, and I’ve verified that the last date of recording to mSD card was 1-13-19 (and not 1-11-19 as I said earlier).

I’ve formatted a brand-new mSD card using the suggested software, and I’m still unable to record video to the card. I’ve tried recording manually by touching the record button while live streaming, and I’ve set it to record when camera detects motion. No recordings show up in the cloud or on the mSD card.

I appreciate all your help so far. I’m having to work on this in between other jobs, but I have more time today than I probably will during the next week. I’d really like to get this figured out.



When I checked the cameras in their “permanent” locations, I never saw any signal strength lower than 80%. And

The cards are readable in a PC. The last file-modified date on two of them is 1/13/19. The third one’s still in the camera, but I think I turned event recording off on that one before 1/13.

I seem to recall that my app was updated (and I didn’t knowingly give permission for the update, which I thought was odd) to the 2.xx version at about the time all of my cameras stopped recording and sending event notifications. I suspect that upgrade was what killed them, but I don’t trust my memory that well to know for sure, and I can’t think of what records I might have to back that up. Usually, when my Wyze cameras don’t work the way I expect them to work, I just wait and try later. They’d been really reliable up to the point where they quit sending alerts, so I thought maybe the alerts would come back. It was until some time later, when I pulled a mSD card out and stuck it in a PC card reader, that I realized that continuous recording wasn’t working either. Those two failures are associated in my memory, but they might be unrelated to each, and they might be unrelated to the app version update.

1 Like

Let’s clarify something. There are three kinds of recording available in the app:

  1. Cloud motion/sound event: These are enabled in the camera settings (gear icon) > Event Recording. Also make sure that the Detection Zone under Detection Settings is not missing the area of motion. These are played back in the Events tab.

  2. microSD card recording: This is enabled in Advanced Settings > Local Storage and can be set to continuous or event only recording. This is played back by pressing the View Playback button on the live stream. This is completely independent from #1.

  3. Record button on live stream or playback: This saves to your phone’s camera roll or gallery, in real time, whatever is being played in the live stream or view playback. Note that it isn’t available when playing cloud events. It is viewed by tapping More and then the Album button, or by leaving the Wyze app and viewing the Wyze album in your phone’s photos or gallery app.

If none of these is working for you for multiple cameras, then it would seem the common point of failure would be the app itself. I’d suggest trying to completely delete the Wyze app from your phone and reinstalling it.


What he said. :point_up:

1 Like

I appreciate these clarifications. I have had cloud recording enabled for a long time, and it worked perfectly for about two months, in November and December. I have never used any schedule other than All Day, and I have always used the full area for the detection zone. I have checked just now to make sure I still have my cameras set up this way.

I have used continuous recording most of the time I’ve owned my Wyze cameras. It worked fine for some time, until one day in January. My camera settings are still on continuous recording.

I think I misspoke earlier, saying that this wasn’t working. It is working. I was thinking that it recorded to the mSD card, and when I saw that nothing was being recorded to the card, I mistakenly concluded that the record button wasn’t working. I’m sorry for any confusion I created there.

That’s a good suggestion. I’ve tried it more than once, including once this afternoon, when one of my cameras became unresponsive after a factory reset. And now that camera still won’t connect.

I suspect, as I think you do, that the problem is in the app, I searched this forum and the internet for someone with the same problem and didn’t find anyone. I created a new Wyze account and added one of the cameras to that account to see if that camera would work on another account, but it behaved just the same as it did on my original account.

I want to thank you again for continuing to help me troubleshoot this issue. It’s important to me that this feature works. It did work, and I loved it when it did. I hope someone can help me figure out why it’s not working now. I appreciate your efforts.


1 Like


I read pretty much every post on this forum and like you, I don’t remember seeing a situation quite like yours.

Here’s the connectivity troubleshooting guide:

You can try that, but I’m thinking you probably tried most of that already. If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get any additional help here from the community, file a support request including log files. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

I have submitted a log, either yesterday or today. I’ve had conversations with tech support that really aren’t very helpful, since it takes 5 to 8 days to get a reply. That’s why I’m here, about a month after noticing the problem. I didn’t expect to get this much help here, and I really appreciate it.

I don’t what I expected to find or what it proves, but I just now connected my tablet to the internet through my phone’s hotspot and started the Wyze app. I was able to livestream from the two cameras that still work, but that doesn’t troubleshoot the motion-detection uploads or the lack of continuous recording.

I may be repeating myself, but I’m still able to record time-lapse videos to the mSD card with both of the cameras that are still functional. I suspect that rules out any problem with the mSD card.

Thanks for all your time!

Do you have a support ticket number?

Also, if you pull the card from the camera and look at the contents on a computer, do you find any videos there?

Wyze Ticket 174939

I can see the time lapse video I made today, a .h264 file in the time_lapse folder,

I don’t see any recordings like I used to get, with one folder for each day, and each day’s folder containing 24 folders, one for each hour of the day. Each hour’s folder contained one .mp4 file for each minute. That’s what I used to get when recording continuously. I’m not getting that now.

Thanks again!

1 Like

I’m going to suggest you try flashing the firmware to the previous version on one camera just to see what happens. Here are the instructions:

I’ll also try to get Wyze to look further into your ticket and contact you again.

Thanks for this, Loki. I flashed my Pan with the firmware.

I put a clean 8GB card in the camera, formatted it in the app, gave the camera 15 minutes to record and detect motion, and then checked the mSD card in my PC. Awesome! The camera is recording continuously. Still not recording events, though, but this is progress.

Interestingly, the instructions say “no need to re-setup your camera”, but the camera was renamed to its MAC address and the settings reverted to default. I guess the instructions must only mean that the camera will still be connected to the account. That makes sense. I made sure that event recording and continuous recording were both turned on.

At one point yesterday, I wondered if my ISP had done something to cause the problem, since my annual contract expired on 1/23, and I had paid for a renewal on 1/11. But I think I ruled that out yesterday when I launched the app on a tablet using cell data and saw no event recordings.

Again, I very much appreciate all your help and patience, Loki.

So to bring us up to date, on that camera, everything is working except events being sent to the cloud?

When you look at the Events tab, are there thumbnails there that won’t load the video, or just the complete absence of thumbnails?

I reverted a v2 cam to V4.9.2.42 firmware, and it’s again recording continuously, but not doing event recording. I will probably be away from the cameras most of the day, but I’ll leave them plugged in with opportunities to do what they’re supposed to do.


I have similar problem but with a twist. I have 5 cameras 2 of them work like charm from day one but 3 are not recording events or uploading to cloud. All of them are on the latest firmware. But here is the twist I put the first 2 in The US and 3 in India and all the three in India are not working but live stream works fine. I am frusrated as wyze team was unable to respond back to my issue. Any suggestions ?

Thank you for your post.

Yes, I am having recording integrity issues with all three of my Wyse cameras (2 Wyze Cam 1080s & 1 Wyze Cam Pan). All three cams are equipped with high quality 32GB SD cards.


Wyze Cam’s failure to accurately records events and movement cause substantial embarrassment to me.

I was scheduled for weed abatement treatment on February 8, 2019, between 12:15 pm and 1:00 pm. I was gone for the day, and upon return, I reviewed the Wyze cam footage of the TWO front yard cameras to see if the weed tech showed up as promised. BOTH Wyze cameras showed NO ACTIVITY in my front yard from 7:00 a.m. to 5:00 p.m.

I called the weed abatement company and lodged a complaint for not receiving service as promised. The dispatcher said their records indicated the weed technician arrived at my property at 12:33 p.m. and completed his service visit for both the front and backyards.

I told the dispatcher, my security cameras CLEARLY SHOWED no one set foot on my property from 7:00 a.m. to 5:00 p.m. The dispatcher said: “Sir, we will send a technician out tomorrow to spray AGAIN.” I responded: “Spray again? How can you guys say ‘spray again’ when you never showed up as promised?”

Later that evening, I rechecked BOTH front yard cameras – and nothing. However, I did NOT originally check the BACKYARD Wyze camera, because no one can get into my backyard with crossing over my front yard, so it would be a moot point to check the backyard cam. You guessed it – the backyard camera showed the weed tech spraying in my backyard at 12:39 pm. However, the most of the frames of the weed tech walking in the backyard were dropped by the Wyze cam. The tech was on camera less than 5 seconds.

Well, of course, I called the weed service company and apologized profusely. I asked them to have the weed tech drop by for an in-person apology and to pick up a In-N-Out Burger gift card.

By the way, after removing egg from my face, I checked the archive of my RING doorbell camera. Yup, it clearly showed the weed tech arriving and spraying for weeds in the front yard.

Maybe WYZE CAMS are not such a “bargain” afterall. Because, if they don’t work reliably when you need them – what value are they?

I will be replacing the Wyze cams with RING SECURITY CAMERAS, which are designed to go with my RING security system. (I should have done this in the first place instead of cheaping-out with Wyze Cams.)

1 Like