Can Wyze take accountability for extremely delayed notifications?

Thanks, I’ll give those a try.

Let me know if you experience anything different. I also start the Wyze App and let it run in the background – Figured it couldn’t hurt… :slight_smile:

If you don’t get the same results, then maybe it is the Beta App. Curious if you experience the same thing.

I will keep you updated as I test things. IFTTT didn’t work for me as it requires the IFTTT app in order for the SMS to work. so maybe it is having the same issues - or maybe I did something wrong. I will work on it more tomorrow. like sending an email to the SMS Queue. I use Verizon Wireless so to send am Email to Text is PhoneNumber@vtext.com

Will let you know how that goes.

Heh Jeddkey - I am still trying to find something which would allow the Pixels notifications to work as expected. I have decided to try the ADB command, and will today. I will let you know how it goes.

However, I remember you mentioning that you don’t use a Windows computer. I found this link which allows the ADB process to be installed on Windows, Mac, and Linux. In case you wanted to try. https://www.xda-developers.com/install-adb-windows-macos-linux/

Not sure what the battery drain will be or if it will work. I am hoping this will get corrected sooner than later.

Thanks for the tip. I probably won’t go that route. Too much trouble. I’ve tried everything else but no luck. I contacted Wyze support. After some discussion the response was, "I understand this is a known issue for the current app version but this is an isolated issue, meaning not all android users are getting the same issue. Rest assured that this will be resolved in the coming updates. We recognize that this experience fell short of your expectations…”

I had porch motion (motion sensor) around 5:00 this morning. Got the Wyze notification 45 minutes later. Yeah, that’s useful.

I give up, at least for now.

Yea, I know what you are saying. Since I have 2 phones and it is only set until a reboot, I figured why not. :).

I am testing the beta version which has some nice features.

But the notification is still an issue. I have gotten it down to less than 10 minutes. Only 1 occurrence yesterday where I got notified 36 minutes later.

Good luck.

So I tested the ADB Shell Command process. As indicated, I am getting all alerts / notifications - quickly and no delays. so this appears to be a fix for delayed notifications for now. I am going to see how the battery life is now that I ran the ADB command

Hopefully Android will fix this soon, or maybe Wyze can change how the lert is processed to be similar to Arlo.

That’s good news! I’ll let you keep experimenting and see if your good fortune continues. If so, then I’ll try ADB. Please keep me posted.

I changed my mind. Downloaded ADB for the Mac, set developer mode and USB debugging on the phone, and ran the "adb shell dumpsys deviceidle disable”. Let’s see if it works.

You should be good. I have been getting alerts since and have not touched it. Battery drain is not bad. I really don’t see a difference.

About a month ago, I turned off motion sense, but left the tap and lift to wake. Just an FYI.

Also note: I did leave my notifications set to run in background and the other settings.

And I did go to battery optimization and turn off optimization on the Wyze app.

Reminder - I am still using the beta app.

The following is what I did before testing the ADB command:

I have done the following:

  • Display over other apps - Allowed
  • Modify System Settings - Allowed
  • Background Date - On
  • Unrestricted data growth - On
  • Permissions - Storage
  • Notification Sound - Default
  • Vibrate - On
  • Lock Screen - Show all Notification Content
  • Show Notification Dot - On
  • Override Do Not Disturb - On
  • Wifi Control - Allowed
  • Battery Optimization - None

Wanted to make sure you knew what I did as you have a Pixel as well.

Let me know how your testing goes as well.

1 Like

It seems to be working now. Oddly, it didn’t work the morning after I installed and ran ADB. So I turned on “Display over other apps” and also got the beta version of the Wyze app. Then it worked. It’s possible that it was a coincidence.

I’m summarizing here what I’ve done based on your suggestions, just to have it all in one place. I’m sure that not everything below is necessary. I might start restoring settings to their defaults and possibly reboot to wipe out the ADB idle setting, one by one, to see which is actually solving the problem. Or maybe I’ll just wait until I hear that Wyze fixed it.

Wyze app settings
Turn off battery optimization
Allow background data use
Unrestricted data usage when Data Saver is on
Lock Screen - Show all Notification Content
Override Do Not Disturb - On (under Notifications in app information)
Display over other apps - Allowed (under Advanced in app information)
Modify system settings - (under Apps & Notifications → Advanced → Special app access) Doesn’t seem to matter. Mine is set to Not Allowed.

I’m using the beta Wyze app. To get it, sign into your Wyze account and scroll down to the bottom where you’ll find “Beta Tester”.

Doze and ADB

Turn turn off “doze” (deep and light idle) on an Android phone, you need to set developer mode and USB debugging on the phone, download ADB, and run a few commands.

Link which allows the ADB process to be installed on Windows, Mac, and Linux: https://www.xda-developers.com/install-adb-windows-macos-linux/.

Video of how to use ADB, including turning on developer option: https://www.youtube.com/watch?v=SB3-k-3Cem4&feature=youtu.be.

Then type this in command prompt: adb shell dumpsys deviceidle disable. This needs to be done every time you reboot the phone.

2 Likes

Mine has been working like a champ since doing the ADB command as indicated above. Like you I will start backing things off to see where it breaks. I am still testing Battery Life and Since 7am this morning, I am down to 90% - But I have been fiddling with it more than normal. But 10% in 2.5 hours - so if I get 20 hours of us I am ok… :slight_smile:

Yesterday, I decided to try the Whitelist of the Wyze App, it looks like the app name is com.hualai. But when I entered the command: adb shell dumpsys deviceidle it will show everything pertaining to deviceidle. I found that the app is already in the whitelist, which adds more to this mystery.

Also - Don’t get confused by the get deep or get light options to display status, it will show active. If you use the command above, you will see the deviceidle is disabled - you just need to look for it, it is located below the whitelist items.

I am glad it is working for you. Maybe Wyze can do more to alleviate this issue, even though it appears to be more Android related.

Well I’m glad to hear the alert delay problem is able to be fixed for some and is working for some. I never could get to it to fix. I even switched phones from a pixel 2 xl to a Samsung Galaxy 10 plus. Same problem, nothing I tried would fix it, neither turning off sleep or battery optimation or anything else suggested here fixed it. However, thank you all for the good suggestions to try.

I’m done with waiting. Not sure why Wyze can not fix the alert delay after so long? I’m leaving unfortunately. Over the past few months I purchased 3 different similarly priced cameras. For all 3 of them, the alert notifications are almost instantly. Sigh… What good is a security camera that waits from 2 to sometimes 10 minutes to send an alert? Very little to me.

Sorry
Brian

I found an app that’s no longer in the Play Store (probably too effective?)

:biohazard: I do not endorse it in any way, shape or form.

But I was curious enough to search extensively and find this source:

https://www.allfreeapk.com/disable-doze,12166247/

And this site for background reference:

https://www.appbrain.com/app/disable-doze/de.geroo.disabledoze

:biohazard: I do not endorse them in any way, shape or form.

:stop_sign: In fact, I suggest you delete any hint of this comment from your harddrive immediately UNLESS you are a SAVVY risk taker who can reduce that risk to acceptable levels by dint of their ample experience and critical tech skills.

:biohazard: AGAIN, don’t try this unless you know what you’re doing and still accept that your entire rig could be vaporized in an instant.

Ok. Disclaiming done. Hard work.

If I were an informed programmer type I might try to contact the author to increase my confidence. Info is on the second site linked above.

Peace out.

2 Likes

I’m always leary about sideloading apps I’m not familiar with…I think I’ll just keep sticking w/ good ole ADB to disable doze

2 Likes

Yeah, I haven’t tried it. I’ve been lowering my expectations on all fronts for years now so instant reliable nofications was just another item to follow suit. :wink:

Can’t be too careful. There are plenty of kids like this at home now anxious to try anything:

https://www.youtube.com/watch?v=cpi2fc5vfNs

Put on your helmets you crazy kids this is no joke! :angry:

1 Like

I’ll take this opportunity to provide an update to what I posted 4 days ago. By using ADB to disable deviceidle (aka “doze”), notifications continue to be within 30 seconds or so. To verify that it is the ADB trick that works, I rebooted my phone, which resets deviceidle to “enabled”. Letting my phone sit overnight, and shorter tests after letting it sit for an hour or two, notifications were delayed. In fact, I wouldn’t even get them until I picked up the phone to wake it up. (Granted, I didn’t wait more than 10 minutes because I’m impatient.)

Then I used ADB to disable deviceidle. Since then I’ve been receiving Wyze notifications virtually immediately (30 seconds, more or less). Conclusion: the ADB trick works, and I’m not sure that any of the phone settings matter.

Thanks for the Disable Doze app link. Since it’s not on the Play Store, I’ll pass.

Jeff

1 Like

Lastly, at least for now, do Wyze techs read these messages? I mean, are they aware of people’s failures and successes?

1 Like

Hard to say, there are at least three threads like this on the forum and to my recollection no staff member has chimed in.

Seems reasonable to tag @WyzeGwendolyn , though. Maybe they could get a definitive response from the devs?

(They are, from my experience, a very good and capable person and I have high hopes they will come through for us on this. :wink: )

1 Like

Glad to hear your experience is the same that I have seen. I have been testing the battery usage to see if there is a difference, compared to my iPhone (which has a bigger battery). I have noticed minimal impact to the Pixel 4’s battery usage. After about 9 hours, the Pixek 4 had approx. 60% remaining. where the iphone had upper 70’s, approx. 78%.

Last night, I turned Adaptive Battery on again to see if that would impact anything. There has been no change to the notifications, still receiving them as expected - quickly. My battery use after 9 Hours is as follows: Pixel 4 82% remaining, iPhone 72% remaining. Cannot explain why there is a such a difference, but will monitor for a few more days to see if this is consistent.

Maybe the adaptive Battery does work as advertised.