Notifications are 100% broken on Android

“Do not disturb” on my Samsung Galaxy only mutes the sound. The notifications are there when I open the screen.

I’m just pulling my hair out at this point. I’ve disabled battery saver, made sure Wyze is exempt from DOZE, made sure its never put to sleep, followed every guide I can find on wyze and Samsung notifications. Nothing works!
Very best case scenario, I can get it down to about 5 minutes delay. But I still get 20 minute - 1 hour delays.

Is there anyway to tell where the bottleneck is? I’ll get a notification at 4:30 that an alarm was triggered at 3:45. So it seems like the alarm is registered in the Wyze, but the app just doesn’t get the memo to send the notification. Would this be from the camera itself? Problems with my network? Wyze servers? Something else?

I also use “Do not disturb” in the night time, but I have wyze exempted from this to still get alarms… just an hour late.

Did you try using the adb command to disable doze, just turning off battery optimization is not enough. I know how frustrating it is to have the notification delay, but if you seriously want to get timely notifications, you’ll have to use the adb command.

How do you implement an adb command on android ??


1 Like

This may be a solution, but a bit extreme to fix a problem that none of my other smart device apps have?
I get instant notifications from nest, eufy, meross, gosund. All of them work all the time… Except Wyze.
I have everything disabled for power management, got background data / processing turned on… Followed every guide available, but the problem persists.
While the phone is active, instant notifications, but if its been idle for about 10 minutes, the problem returns. I’ve even modified the heartbeat down to 1 minute with Push Notification Fixer… Nothing…

Just some observations:

  1. This may be an Android 10 problem on Samsung devices, I noticed that some folks with older devices are not having this problem.

  2. The App naming change between stock and beta is causing a problem.
    No matter if you’re running the beta version “Wyzebeta” or “Wyze” Android 10 is using the same group of system settings for both, for example, you’re running Wyzebeta, wyze then releases the new app version and prompts you to update, after you update to the latest app, now called “Wyze”, the settings you created for “Wyzebeta” are now “associated” with “Wyze”.
    No matter which version you are using, Android 10 ignores any system management settings you make for the app, it’s like the App uses one set and the system another.
    Today I unintalled “Wysebeta” and whenever I went back to the Google play store and picked Wysebeta to leave the beta program (I wanted to install the stock version) Google play store crashed.
    I rebooted, deleted cache partion, still it crashed.
    After messing with it for a while, I managed to get to it via my apps / library and leave the beta program.
    I turned off “auto restore” in backup and restore to ensure a clean install and installed the latest public version… Guess what, all the system changes, I’d made for “Wyzebeta” were still there, now associated with the new “Wyze” app.
    This is not right, Android 10 should have treat it like a new app, with all its default power and battery settings, but it didn’t, somehow it still has everything disabled etc.
    This is where the problem is, when you uninstall either one, it’s never clearing out the system settings since they are not associated with that app only …I think?

Hi Everyone,

While I am still unable to fix this, I just wanted to thank everyone for their helpful suggestions, its much appreciated!

Still had a 45 minute delay this morning… :confused:

I just setup a new Pixel 4a last night, and hadn’t disabled doze yet, I get several wyze events when leaving for work. Once I got to work & unlocked the device, the notifications flooded in…I promptly disabled doze :slight_smile:

have u tried it yet? if not, need help?

Thanks for the update :+1:
I found that I need to re-disable idle every time after I restart the phone, but it seems to work.
I wonder why some apps notifications are not affected by this?

yes, unfortunately using the adb command does not survive a reboot. There must be something that Wyze is missing, I’m not sure, hopefully they’ll figure it out. I do know the issue does affect other apps besides wyze.

I hadn’t realised about needing to re-disable after every reboot, that may have been the issue. However, whatever it was seems to be gone now. I’m not sure if wyze fixed it in an update, but I am now getting notifications from wyze BEFORE ifft!

interesting, I’ll have to reboot & test!

I tested at lunch after rebooting, notifications are still very slow on my Pixel 4a, the odd thing is the Wyze lock notifications were much quicker, 1st time was 1-2 min, the 2nd test was under 30 sec.

I’ve just disabled doze again, where the notifications are nearly instant.

I’ve given up on Wyze. The notifications are still delayed unless you disable doze by adb, but then you have to remember to disable it again if you update or reboot your phone. Eufy and Ring are instant even when asleep for several hours and without touching the battery optimization settings. So it’s not an android thing, it’s Wyze’s issues that they can’t solve. Switch to Eufy or Reolink

Darn, I was optimistic there for a bit. Thanks for the update :+1:

All android 10 and above users are still having this problem, you said that Wyze is aware of the problem and are working on it, however I’ve spent the last hour searching the Wyze known issues and find no mention of this issue.
How sure are we that they even acknowledge this problem?
It pretty much renders the cameras usless… Unless you have ADB handy.

Are you using the beta app? The latest beta app has a option to keep the app running in the background. I just rebooted & have not disabled doze to see if notifications are better. Once I get home, I’ll be able to test it out.

Thanks for the heads-up Ken.
I’m beta testing another pre-production wyze product, they have us using a other version of the app. We’re almost done. So I haven’t used the new beta yet.
I have bought a “test” phone that I’m setting up right now, I’ll install the new beta on there and check it out also. I’ll post findings here.