Can Wyze take accountability for extremely delayed notifications?

You should be good. I have been getting alerts since and have not touched it. Battery drain is not bad. I really don’t see a difference.

About a month ago, I turned off motion sense, but left the tap and lift to wake. Just an FYI.

Also note: I did leave my notifications set to run in background and the other settings.

And I did go to battery optimization and turn off optimization on the Wyze app.

Reminder - I am still using the beta app.

The following is what I did before testing the ADB command:

I have done the following:

  • Display over other apps - Allowed
  • Modify System Settings - Allowed
  • Background Date - On
  • Unrestricted data growth - On
  • Permissions - Storage
  • Notification Sound - Default
  • Vibrate - On
  • Lock Screen - Show all Notification Content
  • Show Notification Dot - On
  • Override Do Not Disturb - On
  • Wifi Control - Allowed
  • Battery Optimization - None

Wanted to make sure you knew what I did as you have a Pixel as well.

Let me know how your testing goes as well.

1 Like

It seems to be working now. Oddly, it didn’t work the morning after I installed and ran ADB. So I turned on “Display over other apps” and also got the beta version of the Wyze app. Then it worked. It’s possible that it was a coincidence.

I’m summarizing here what I’ve done based on your suggestions, just to have it all in one place. I’m sure that not everything below is necessary. I might start restoring settings to their defaults and possibly reboot to wipe out the ADB idle setting, one by one, to see which is actually solving the problem. Or maybe I’ll just wait until I hear that Wyze fixed it.

Wyze app settings
Turn off battery optimization
Allow background data use
Unrestricted data usage when Data Saver is on
Lock Screen - Show all Notification Content
Override Do Not Disturb - On (under Notifications in app information)
Display over other apps - Allowed (under Advanced in app information)
Modify system settings - (under Apps & Notifications → Advanced → Special app access) Doesn’t seem to matter. Mine is set to Not Allowed.

I’m using the beta Wyze app. To get it, sign into your Wyze account and scroll down to the bottom where you’ll find “Beta Tester”.

Doze and ADB

Turn turn off “doze” (deep and light idle) on an Android phone, you need to set developer mode and USB debugging on the phone, download ADB, and run a few commands.

Link which allows the ADB process to be installed on Windows, Mac, and Linux:

Video of how to use ADB, including turning on developer option:

Then type this in command prompt: adb shell dumpsys deviceidle disable. This needs to be done every time you reboot the phone.


Mine has been working like a champ since doing the ADB command as indicated above. Like you I will start backing things off to see where it breaks. I am still testing Battery Life and Since 7am this morning, I am down to 90% - But I have been fiddling with it more than normal. But 10% in 2.5 hours - so if I get 20 hours of us I am ok… :slight_smile:

Yesterday, I decided to try the Whitelist of the Wyze App, it looks like the app name is com.hualai. But when I entered the command: adb shell dumpsys deviceidle it will show everything pertaining to deviceidle. I found that the app is already in the whitelist, which adds more to this mystery.

Also - Don’t get confused by the get deep or get light options to display status, it will show active. If you use the command above, you will see the deviceidle is disabled - you just need to look for it, it is located below the whitelist items.

I am glad it is working for you. Maybe Wyze can do more to alleviate this issue, even though it appears to be more Android related.

Well I’m glad to hear the alert delay problem is able to be fixed for some and is working for some. I never could get to it to fix. I even switched phones from a pixel 2 xl to a Samsung Galaxy 10 plus. Same problem, nothing I tried would fix it, neither turning off sleep or battery optimation or anything else suggested here fixed it. However, thank you all for the good suggestions to try.

I’m done with waiting. Not sure why Wyze can not fix the alert delay after so long? I’m leaving unfortunately. Over the past few months I purchased 3 different similarly priced cameras. For all 3 of them, the alert notifications are almost instantly. Sigh… What good is a security camera that waits from 2 to sometimes 10 minutes to send an alert? Very little to me.


I found an app that’s no longer in the Play Store (probably too effective?)

:biohazard: I do not endorse it in any way, shape or form.

But I was curious enough to search extensively and find this source:,12166247/

And this site for background reference:

:biohazard: I do not endorse them in any way, shape or form.

:stop_sign: In fact, I suggest you delete any hint of this comment from your harddrive immediately UNLESS you are a SAVVY risk taker who can reduce that risk to acceptable levels by dint of their ample experience and critical tech skills.

:biohazard: AGAIN, don’t try this unless you know what you’re doing and still accept that your entire rig could be vaporized in an instant.

Ok. Disclaiming done. Hard work.

If I were an informed programmer type I might try to contact the author to increase my confidence. Info is on the second site linked above.

Peace out.


I’m always leary about sideloading apps I’m not familiar with…I think I’ll just keep sticking w/ good ole ADB to disable doze


Yeah, I haven’t tried it. I’ve been lowering my expectations on all fronts for years now so instant reliable nofications was just another item to follow suit. :wink:

Can’t be too careful. There are plenty of kids like this at home now anxious to try anything:

Put on your helmets you crazy kids this is no joke! :angry:

1 Like

I’ll take this opportunity to provide an update to what I posted 4 days ago. By using ADB to disable deviceidle (aka “doze”), notifications continue to be within 30 seconds or so. To verify that it is the ADB trick that works, I rebooted my phone, which resets deviceidle to “enabled”. Letting my phone sit overnight, and shorter tests after letting it sit for an hour or two, notifications were delayed. In fact, I wouldn’t even get them until I picked up the phone to wake it up. (Granted, I didn’t wait more than 10 minutes because I’m impatient.)

Then I used ADB to disable deviceidle. Since then I’ve been receiving Wyze notifications virtually immediately (30 seconds, more or less). Conclusion: the ADB trick works, and I’m not sure that any of the phone settings matter.

Thanks for the Disable Doze app link. Since it’s not on the Play Store, I’ll pass.


1 Like

Lastly, at least for now, do Wyze techs read these messages? I mean, are they aware of people’s failures and successes?

1 Like

Hard to say, there are at least three threads like this on the forum and to my recollection no staff member has chimed in.

Seems reasonable to tag @WyzeGwendolyn , though. Maybe they could get a definitive response from the devs?

(They are, from my experience, a very good and capable person and I have high hopes they will come through for us on this. :wink: )

1 Like

Glad to hear your experience is the same that I have seen. I have been testing the battery usage to see if there is a difference, compared to my iPhone (which has a bigger battery). I have noticed minimal impact to the Pixel 4’s battery usage. After about 9 hours, the Pixek 4 had approx. 60% remaining. where the iphone had upper 70’s, approx. 78%.

Last night, I turned Adaptive Battery on again to see if that would impact anything. There has been no change to the notifications, still receiving them as expected - quickly. My battery use after 9 Hours is as follows: Pixel 4 82% remaining, iPhone 72% remaining. Cannot explain why there is a such a difference, but will monitor for a few more days to see if this is consistent.

Maybe the adaptive Battery does work as advertised.

I have been in contact with Wyze on this issue in the recent past. I get a good felling that they are working on a solution to the notification issue, but need to ensure it is corrected for the masses and not just a few Android Phones.

I have enrolled in the Beta test program to test the app to see if the problem is resolved or not. If not, I can simply run the ADB command as well. I have also let Wyze know that I would be glad to do some Alpha testing to see if the issue is resolved.

One item to keep in mind, this issue is not solely a Wyze issue, it does also happen with Google and other apps as well. I believe that the issue is more related to Android, but there are a few items Wyze could potentially look at to reduce the issues.

In addition, Android 11 is coming, which could either fix this issue or introduce other issues.

Wyze responded to one of my emails as follows:

We appreciate you sharing this feedback with us. We actually tried this not a long time ago as a workaround for not receiving notification issues. What we found out is that this does not apply to most Android users. Regarding the whitelist that is something new to me and I’ll have our engineering check this ticket.

If I hear anything else, I will let you know

1 Like

Thanks for the update. I’ve had Adaptive Battery turned ON with no ill effects. I have Battery Optimization for the Wyze Beta app turned OFF, though it says in the settings that it isn’t using battery in the background anyway. My testing after a reboot, which re-enables doze (deviceidle) implied that the Wyze Beta app does not fix the problem. The only thing that works for me is disabling deviceidle with ADB.

My battery life is essentially the same as before I disabled deviceidle.

Unrelated: Using ADB also allowed me to install Clip Stack for a multi-clipboard. Android 10 killed that option for all the clipboard managers, but ADB allows one to set permissions so Clip Stack works. Same thing for Join by joaoapps, which allows clipboard sharing between Android and a PC/Mac if, and only if, you set certain permissions via ADB.

Yea - My Battery Optimization is off as well. My experience is the exact same as yours. Good to hear… :slight_smile:

I will need to take a look at Clip Stack, Have not used that before.

thanks for the heads up.

For the impatient, “Doze Buster” is currently in the PlayStore with Kanji interface

For the patient, a teaser in another thread…

This app disables the Android battery saving feature Doze, which increases battery power consumption.

Use this if you really want to avoid Doze.

The Doze feature added from Android 6 is a great feature that saves battery power. However, it is a very troublesome function if there is a process that you want to keep running in the background.

This app avoids the Doze (slumber) by waking the terminal periodically.

You can also check if the Doze function is working by recording a log.

If you want to disable Doze function, tap “Doze Buster Start”.

If you want to know if the Doze function is working, turn on “Record Doze Log”.

  • In Android10, the log that entered Doze is output, but it actually behaves as if it is running continuously.

Soooooooooooooooddddd, you da man, brakin’ on thru to the other side. I may start to rethink my agnosticism if you do this two or three more times… :slight_smile:

I personally stay away from apps which have minimal or no review and in a language outside of the US or one I cannot read or understand. I may be overly cautious here. :slight_smile:

I have seen other apps, which I have not loaded and will not say it is something you should load. But it is called AntiDozed and is also on the app store and cost 99 cents. If you opt to try it, please note: I do not sanction or recommend this, just providing an alternative to what is stated above.

I personally will continue to use the ADB command as stated above. It has worked for me and continue to work with minimal to no battery impact.


Methinks you are sensibly sane! :+1:

I just couldn’t resist when I saw it - no reviews, in a language I can’t understand, even using characters I can’t read - yeah, it’s gotta be safe - I wonder what the TOS looks like? :rofl: The only thing normal was that it was actually in the PlayStore. :slightly_smiling_face:

Using ADB to work around this Wyze notification issue is the only sure way to go.

1 Like

This is why I’m always odd-boy-out in tech boy snuggle cuddle. I get sloppy if not fully engaged.