Can only connect to camera when on local network, events are hit or miss

Sigh… From reading through this forum, it seems Wyze is pretty buggy. Should have expected this given the low price-tag. Bought in a little less than 2 weeks ago and it has worked fine until today. Now I only seem to be able to connect to the livestream (on iPhone) when on the same local network. Event recordings are hit or miss. They almost never work when on a different network and often return error code 07 when on the same network. Weirdly, notifications seem to work fine.

Tried restarting and power cycling the camera. Anyone else have similar issues? This is the Wyze Cam v2.

When was the last time you rebooted your WiFi and router?

Not for a while. Definitely before I got the camera. I can try that later today, but my network is working fine for all my other devices.

Reboot router did nothing. Now I find the following message sometimes appears when on the local network. (Failed to update device list (error code -1003)). Thinking of switching to nest.