Can I totally delete my monitoring system and reinstall it? Hub, keypad, sensors? Have you done it?

Sense hub is not communicating with anything. Have tried the reboot and restart. Still no luck. Lights are lit and it will say ready to connect but never says it connects to anything. Neither Iphone nor keypad will arm the system. “Support” has been no help. But indicated they don’t reco a full install. Thoughts? Phone says all firmware is up to date. But phone also says batteries are normal in keypad when I have them out. Not sure what else to do other than trash the system.

If you restarted the hub and it’s saying ready to connect, and you already talked to support and their standard troubleshooting didn’t resolve it, then yes, that is what I would do next.

Yes, I have redone a full install again in the past.

What I would personally do if my hub was doing this:

I would restart my phone to force all the Bluetooth sensors, etc to be working from a fresh boot. Then I’d hold the reset button in for 30-60 seconds and hope that forces it to a factory reset. Then I’d try setup again.

Make sure it’s plugged into your router with an ethernet cord to do initial setup.

Don’t do it. I did that and had to buy a new hub. For some reason, the reset button on the hub only works 1 time. It does not reset after first setup.