Cameras Not Recording Events and Not Recording to SD Card

I just installed 4 cameras none will record continuously or event record. All will only record manually. I have powered down many many times. Installed new firmware, reformatted cards. Installed new 32 gig cards. downloaded your format SD card app and tried that. My coworker has a wyze camera that records so we checked all my settings, still no record, my SD cards are empty. HELP

I own (4) Wyze Cams V2. One Cam wouldn’t record movement or sound.
This Demo.Bin instructions WORKED!

1 Like

Thanks for the reply I will give it a try after work tonight

Hi Joel, have you solved issue about no notification on you cam? I am in Canada and get from as well, same issue about the cam. but my first Wyze cam works well.

I have asked a few times on other forums, but haven’t gotten a good answer. Why am I getting “No Video at the selected time.” I have SD cards in both cameras and the “View Playback” feature has worked in the past, but every so often I get these notifications when I want to view playback. I have to restart the cameras to reboot the continuous recording. This is getting frustrating, as there may be a time that I really need to see previous footage from the previous 48 hours. Please help someone!

1 Like

Hello @aaronarchambo. I am the sd card nerd around these parts. what type of sd cards are you currently using and having these issues with. ?

and I’ll ask the usual question of what cameras are you having trouble with along with the firmware numbers and app version. I’m sure we can figure this out fairly easily.

To be clear, is it configured as " Record events only" or “Continuous recording”?

Thank you for reaching out. I formatted my SD cards last week and restarted each camera. So far, they’ve been purring like a kitten since then. Let’s hope this continues! Thanks again.

1 Like

I’m glad you got it working. might i still inquire as to the maker of your cards? generally speaking high endurance cards work best for video recording such as our cameras do. regular cards will get errors and show behavior similar to yours and need deep formats time after time. it can get kind of time consuming after the 2nd or third deep format :disappointed:

The Demo.bin fix worked for my cam. Thank you!

1 Like

I have this same problem. I’ve had to restart the camera twice and recording continues.

I am running the Pan Cam To say the least to get not indication that recording has stopped working but to want to reference video only to find absolutely none is really frustrating.

@Bam Since you’ve been engaged here I have a Kingston 32GB card installed. Is there a way to get access to system logs to see if there would be any indication of why the recording would suddenly stop?


Sadly I do not own a pan camera so I’m not exactly an authority on that device alone. But for the most part when it comes to recording if you check your settings just to see that the correct settings are made, record on event, motion detection and all that good stuff is in, and they are (I know there have been reports of Pam cams kind of having a brain of their own and settings changing from time to time so be aware of that) do you still have cloud recordings? in the event that you have the event recordings but no SD recordings you know the issue lies with the SD card. Keep in mind that the best cards for recording video are high endurance cards. I don’t know precisely what that Kingston SD card is but it doesn’t sound like it’s a high endurance card. Your best bet would be to take it out and do a complete format on a computer and try it again and try to track how long it is until you notice an issue. But always make sure the settings are still correct and if you still have events recording but not SD records I would say more than likely it is your SD card.

Let me know your findings and I think together we can get to the bottom of this

Hi Bam, I’m having the same problem as OP. I’m using the 32gb Samsung microSDHC EVO Select Memory Card in multiple cameras (Wyze cam v2), and I’m getting the “No Video at the Selected Time” message anywhere further in the past than the last couple days. This is happening on multiple Wyze cams, all of which are set to “continuously record” onto the SD card. I’ve tried formatting the SD cards and the problem still exists.

If I want to view “recorded” video further back than yesterday, I’m sh*t out of luck. Are we thinking it’s a problem with the Wyze camera software, or the SD cards? I wouldn’t have thought there would be any issues with the Samsung SD card. I’m on the Wyze android app, btw.

My info:

  • Samsung Galaxy S9 on Android version 10
  • Wyze app version: 2.10.80
  • Firmware version:

This feels a little strange for all these SD cards to just be “bad at recording.” I will note I opened a ticket about this which was basically shrugged off. At a minimum I’d expect engineering to request logs to see if there’s a common problem. This is just disk I/O and clearly events aren’t being written so at a high level I’d expect that:

  • there’s a logic flaw somewhere, that is causing the write API to not be called from the Wyze stack
  • there’s a failure on the write at a lower level, in which case I would hope that failed writes that are outside the Wyze software stack are at least getting exceptions caught and logged
1 Like

@BAM. What SD card formatting tool and test app do do recommend? I have four different 32gb cards purchased from Wyze and none of them pass the H2TestW write and verify test. I have tried Win10 FAT32 formatting, SDCardFormatter5, both FAT32 and exFAT32. Still cannot get any of these cards to pass. I have been through double digits of support sessions to try to get two Wyze Pan Cam to properly record events. Once the cards fill, they will not initiate an overwrite. They just stop recording.

well well well, hello everyone.

let me try to go in order here, @nate311 Ive looked into those cards a bit and although they come from a reputable company they do not appear to be high endurance. so not to say the error is for sure in the car itself but I would tend to err on that card being the issue because of that. recording video, especially constantly is a very intensive process for sd cards, especially continuous recording. the fact that you do have SOME recordings is the other reason I would tend to think its the card as well and that it has developed an error on a particular sector. when you say you’ve tried formatting the cards, did you do the long format or was it the quick format most computers are set to by default?

@RBunch4468 your issue is a much more complex issue. for formatting ive only once needed a different program other than the stock option on a computer. when you say you can’t get any of the cards to pass, do you mean they dont pass a card test program or they dont work in a camera and/ or computer? do you by chance have any other cards that you can use to test that the cameras themselves are still operational as far as SD recording goes?

these are the cards that a lot of use use and have had a lot of luck with on these cameras. just in case you guys are looking to have an extra. it usually doesn’t hurt to have an extra if nothing other than for testing purposes :wink:

high endurance sd card- click here

1 Like

So… My series of support cases started because my Wyze Pan Cam would record events properly until the card filled, then the camera would not start overwriting… it would just stop. The view upon playback would show the dreaded “No Video at the selected time”. Support calls with Wyze narrowed in on the SD Card. Reformat, they said… So, I did using the Win10 standard deep format (not Quick Format) and FAT32. Same thing… camera recorded events only until SD card filled up… would not start overwriting content. I confirmed with support that the camera was supposed to overwrite the disk content as part of its normal execution when the card filled. So… then I was told to
then confirm the card is working with the H2TestW app. I downloaded it, unzipped it and ran it on the SD card. The H2TestW writes and verifies each memory location. I was told by Wyze support that unless this test completes successfully, the camera cannot be depended upon to function properly. Okay… so H2TestW was used on the formatted SD card. It wrote the full card, but verified only about two thirds before messaging a verification error. This was enough documentation for Wyze support to replace the card. I now have three different Wyze 32gb SD cards. None of them will pass this formatted write and verify test. I am reluctant to continue forward with troubleshooting the camera until I get an SD card that I am confident in. What would you recommend?

1 Like

OK, I will purchase one of the high endurance cards and see if that works. I doubt it will, but who knows. Will report back :slightly_smiling_face:

1 Like

I was advised by the latest Service Rep that I talked to about the event recording stopping when the SD card filled to try a much older version of firmware. The rollback of firmware to seems to have fixed the event recording issue where recording would stop after the SD card filled. More recording time will confirm, but three days so far and it is working.
@Sam I would like to know if Wyze has a repair ticket open to explore why more recent firmware versions are triggering this issue.
@Nate311 I would like to know if loading firmware solves your problem. I am now four days into a successful test.


After putting in larger SD cards, 512gb and 128gb respectively, it turns out the cameras are working fine. My 32gb card was simply only able to store about 3-4 full days of video (SD) before it would start overwriting. Based on cameras I’ve owned in the past, I had assumed a 32gb card could hold more than ±72 hours of video, but guess I was wrong. By the way, the larger Samsung cards I am using are not high endurance but seem to be working fine.