Cameras (Cam v3) keep going offline

I have new Cam v3s set up, and I have created a device group for three of them. None of the cameras have an SD card, they are all enrolled in Cam Plus. Quite frequently, say after an hour or two, the group goes offline with connection error code 20, and I have to tap the android screen to wake them up again. All devices show signal strength at three bars. Is this behavior normal? Why should they go offline? Can I fix it so that they stay connected to the system all of the time?

I had the same thing happen with mine.
I deleted them then went thru set-up again and no problems since.
Mine all have SD cards in them, just FYI. I don’t think it matters any.

I’m sure that the cameras are not at fault and that the answer probably lies within the app because the images on my Android tablet show “error connection 20” while the images on my android phone are just fine, although the images on my phone do randomly show “error connection 20.”

I have an android phone (Samsung Note 8) and an iPad (10.1 inch released Nov 2019) and all the V3 outside cameras were doing it on both.
Once I deleted and went thru set-up again, no problems, but that’s just me.
I hope something works for you, I know how frustrating it is.
I have my cameras grouped together in 2 groups, inside & outside.
Was so frustrating to look and see all 3 outside cameras, and they were not “online” but touch them and it open up.

I’m having the same type of problem, with two WYZE CamV3 that I bought thru their early purchase program. The WiFi signal from the camera has a clear view to the AP with minimum obstruction , 30ft distance, and it is unable to maintain the connection and often cannot re-connect for hours.

I’ve been trying chat to support, over 4 hours and waiting, when I get to the position 1 or 0 in the chat line, I’m disconnected and sent to the back of the line, calling phone support say’s no one is available and hangs up. I’m unable to figure out how to send them a e-mail.

Wyze support for it’s products is poor, some products just need to be replace as they are defective, forums do not help in these matters. The Cam V3 just has poor WiFi performance, and I cannot get any WYZE product support assistance. I have V2 Cams and no connectivity problems located a few feet from CamV3 locations.

Even their spell checker does not accept their own spelling of “WYZE” in their own forums.

I’ve had issue with the WiFi outlet plugs they break after cycling them twice, I was out of warranty before using them, so I’m stuck with them. But, with these CamV3, this is unacceptable especially since the V2 cams work so when, the only thing that appealed to me for the CamV3 was the low light sensor and supposed weather proofing.

I feel your frustration.

I think I may have found the solution. First I deleted all instances of the app, then I installed the app on my Fire HD 10 tablet. The problem of the app dying seems to revolve about the screen trying to sleep and the app refreshing itself, perhaps there is an inherent conflict between those two events, so I solved the sleep problem by invoking developer options > keep screen awake while charging. Of course, one has to keep it plugged in all the time, but in the past 24 hours the app has not once disconnected, even when the app refreshes itself. Developer Options is reached by going to Settings > Device Options > tap the serial number 7 times > Open Developer Options. Today I created a camera group with two cameras, it’s still working. I will soon install another instance on my android phone, if it works, great! If the second instance running creates a problem I will comment here.

Fire HD 10, 7th Gen, OS
iPad 4th Gen, iOS 9.3.5
Samsung Tab S5e, Android 10
Samsung S21+5G, android 11

Wyze Android: 2.19.14
Wyze Apple: 2.19.22

I have set up the tablets to be continuous monitors with the Wyze app, I used the cell phone to test how well the app performed while the phone was multi-tasking.

Each tablet was on its charger, each tablet had been set up via software for the screen to be always-on. The phone was running the Wyze app all the time, it was on its charger randomly and was used constantly for other tasks, such as playing music, reading the news, checking messages.

No camera had an SD card, all cameras were enrolled in Cam Plus.

I wish I had good news to report, but alas, the Wyze cameras and app are not a security solution, at best they are a monitoring system that needs constant attention.

I set up each of the tablets to report just one camera at a time, then I created a camera group and ran that on each tablet. In both tests the software failed to stay connected. I am satisfied that the cameras did their job, but the app needs a LOT of work. It quickly failed to keep group images connected (failure code 20,) the individual images took much longer to disconnect with the same code, but disconnect they did, and then I had to go climb the ladder to reset the power and rejoin the camera to the app. If, like me, you are trying for a security system on the cheap, you will be disappointed, perhaps there is no such thing. Thank goodness the cameras were only $20 each because it is too late for me to return them. I will continue to use the cameras and Cam Plus until I find a better solution, and I am not giving up on Wyze, I think some of its other products are great, but the camera system may too big a meal for it to digest, the minds at Wyze should either do the software correctly or not do it all.


I was able to contact WYZE on chat, they recommended I use their third party WiFi troubleshooting app “Route This help” to analyze and determine my network function. They told me after the test, I was getting less that 1MB upload speed, at the point where I was getting the worst connectivity. I did my own speed test at my PC attached to the WiFi router I was getting 28MB download, 29 upload. I then use my phone for a speed test while near the WiFi router, I was getting 14Mb download, 13.7 upload, At the CamV3 outdoor location, I was getting a variable of speeds, sometimes no speed reading at all. I decided to purchased a new router, and got even worst wire speeds and WiFi speeds, I felt very discouraged, I return the newly brought router. While returning it, I remember something I had read earlier that “IOT/2.4ghz” devices have a limit channel band width spectrum and WiFi AP routers should be set, to make it as narrow as possible, the channel band width on the original router was set to automatic(20Mhz/40Mhz range). I manually adjusted router channel width to 20Mhz range, and everything improved, camera device groups, began to work, cameras connected right away. The camera group for the cameras furthest away worked right away. I did another phone speed test, near the CamV3 having issues and noted, 5MB download and 7MB upload. :grin:


I have wyze cam v3
It keeps going disconnected
And ask to power cycle ,

I tried all solutions mentioned here
Very frustrating


@goodboy007 This is a pretty old thread. Have you contacted Customer Support (206) 339-9646 Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT? That’s the best way to get help with this issue.

1 Like

I bought a 2nd V3 camera a couple of weeks ago to add to the one I’ve had for several months, and is working just fine. I installed the new camera, and it would keep going off-line after about 10 minutes. I would recycle, reinstall, power off, …etc. and nothing helped. WYZE finally sent me a replacement - same problem. Their customer support is trying to tell me it is because it is trying to connect to my 5.0 GHz Wi-Fi, but I know it’s not. I have an Orbi mesh system and I can go into my device controls and see which satellite it is connected to and what Wi-Fi signal is it using. It is using the 2.4 GHz Wi-Fi, same as my older V3 camera. I have uninstalled the app, powered it down and up, reinstalled the camera, everything they recommended and there is still the problem. Why would my older V3 camera work just fine, and both new ones have the same problem, unless WYZE tried to fix something that wasn’t broken and screwed up the hardware? Old and new cameras are running the same software, old works flawlessly, new is now a paper weight. Thought maybe the problem was the trial cam plus subscription, so I waited for that to expire before I tried firing it up again - still having the same problem. i even tried using the power cable and charger from my old camera on the new one, problem still exists. Looks like I will be returning the new one for a refund and forget about buying any more of the cameras.
When I start the app I can get a live video of my old camera within seconds, the new one cranks and cranks and may or may not go online, and when/if it does, it goes off shortly later. WYZE appears to be trying to cut corners and is now selling junk.

Thanks for the info. I’m going to give this a try.

I guess the annoying thing for me is that it’ll show offline in the group view, but then when you click on it, you get a feed, but can’t change settings or reboot.

This just started happening to me. Extremely frustrating. Wyze cameras are crap. ISmart is so much better but they stopped making them. Luckily i have 12 ISmart and only use a few Wyze .