Camera Notifications Duplicate on Watch 47

I’m getting duplicate notifications from my cameras on my Watch 47.

The Watch is paired to a phone running a current version of android. The cameras I have available at present are Cam OG, Cam Pan v3, and Video Doorbell v2, but I suspect this applies to others. I don’t know exactly when this issue started, but everything except the Video Doorbell v2 has the latest firmware, so the most recent thing to receive an update was probably the Wyze App itself. (I’m postponing the Video Doorbell v2 firmware update for now because of notification issues described in the release announcement topic and a separate topic describing post-update problems.)

None of the cameras in question are on subscriptions, so I receive only the generic motion and sound notifications. I’ve rebooted each camera, the phone, and the watch, and that hasn’t resolved the duplicate notifications.

Here’s an odd twist: The duplicate notifications are not always exactly the same. For the Cam Pan v3 and the Video Doorbell v2, the first notification in the pair doesn’t have a period at the end, but the second notification does, e.g.,

:speech_balloon: Others
Motion Detected
Front Doorbell at 01:53 PM

and

:speech_balloon: Others
Motion Detected
Front Doorbell at 01:53 PM.

or (another example pair)

:speech_balloon: Others
Motion Detected
Cam Pan Black at 01:58 PM

and

:speech_balloon: Others
Motion Detected
Cam Pan Black at 01:58 PM.

In my limited testing, both notifications from the Cam OG have a period at the end (both on the phone and on the watch). The Wyze app generates only a single notification for each event on the phone, and that has a period at the end:

WyzeCameraNotifications

Why do the different cameras (OG vs. Pan v3, for instance) generate different notifications on the Watch (with or without a period)? Who else has experienced this, and what are the steps toward resolution? If I don’t find an answer here, then I’ll plan to submit this for next month’s fix-it-friday.

I now believe this is an app issue. Because some recent app and firmware rollouts have appeared to introduce new bugs, I waited a week or so to update the newest Android app, and now when I see camera notifications on my Watch they both include the period!

I haven’t installed firmware updates for the cameras or the Watch since I initially reported this issue. The only change I’m aware of is the Wyze app, so that almost certainly has to be the culprit.

Another note: When I received a pair of notifications this evening after stepping out the front door and triggering the doorbell’s motion detection, they came back-to-back as usual but the time stamps were off by 1 minute. I presume this happened exactly as the minute was changing, and it indicates to me that there are two different points in the notification generation process where these are being sent to the Watch.

image

Log ID: 1420619
Wyze Ticket ID: 3881561