Cam3 gets IP but does not complete setup

I have several Cam v3, all set up over a year ago, all updated to
On 6 August 2022, two of them lost connectivity. Attempts to reconnect have all failed.
My Wyze app is Android version v2.33.1(162).
My phone is a Pixel 6 Pro running Android 12, build SQ3A.220705.004.

I force-stopped the mobile app, power cycled the Cam v3, hard reset the Cam v3, and even flashed the Cam v3 with the same version I have NOT tried flashing any earlier firmware, but that may be my next move.

Here is what happens every time:

  1. I release the IP previously leased to the MAC of the Cam v3.
  2. I make sure my phone is connected to a 2.4 GHz WiFi network.
  3. I open the mobile app and begin the usual process of adding a Cam v3
  4. The camera scans the QR code. It’s touchier than I remember, but it works.
  5. The v3 alternates red and blue, and I observe that an IP address has been leased to the MAC.
  6. The v3 starts flashing blue, and at this point responds to pings on the leased IP.
  7. I continue pinging the v3 in a loop: ping -t {ip_address}. Pings are typically 2-3 ms.
  8. After a few minutes, the app times out and displays the Connection Failed screen.
  9. At this point the v3 is still responding to pings.
  10. After a few more minutes the v3 speaker announces that the connection failed.
  11. The v3 stops responding to pings exactly when the speaker says the connection failed.

My second Cam v3 does the exact same thing.

What’s up? An IP address has been assigned and the RTOS is up enough to scan the QR, respond to pings, and drive the speaker.

  • Should I suspect the app?
  • Should I suspect the v3?
  • Should I flash the v3 to an earlier firmware? Remember, it had been working on latest.

I have not sniffed the traffic during the connection handshake, so that’s probably my next step. I don’t know what that is supposed to look like. I could delete my only working v3, hope that I can get it to re-connect (not feeling good about the odds!) and sniff the handshake to see what the happy path looks like and compare that to a capture for failed connection.

Anyone having the same problem?
Anyone have a pointer to what to look for in a packet capture?

I feel stupid for putting several hours into a $40 toy. If I were smarter, I’d just buy more v3’s and, if they connect, throw out the old ones!

If you read this far, thanks!

Weird behavior, but I’m guessing it has something to do with your network because multiple are having issues. Is there a reason you have to manually release the ips, and not let the router do that automatically? Try setting them up on a different network if your able to. Also try using a different phone.


My three v3 Cams were all bought at the same time. Two have this problem. One does not. All three are (were) on the same \24 VLAN. I manually release the IP because the router won’t drop them itself until the lease expires, and the TTL is 24 hours. My other 8 Wyze cams and the working v3 are all on the same \24 VLAN. So moving to a different network isn’t an optimal use of diagnostic effort. Trying an old phone running an older version of Android would be pretty quick, though. Thanks.

1 Like

Do you have SD cards in them?

Might sound dumb but I have had V2 and V3’s exhibit odd connectivity issues that went away when the SD card was removed or formatted.

Since you are rolling back firmware this may not apply, SD card rollback…

Just some input on my weird connectivity issues when SD cards were corrupted,

1 Like

@K-Dog - Does your WiFi network happen to limit the number of clients that are allowed to connect/authenticate to vLAN 24?

Maybe power off one of your existing cams that resides on the WiFi network/SSID associated with vLAN 24, then try to connect one of your new cams.

The VLAN is a /24, meaning it supports 2^(32-24) - 1 = 255 clients. It has previously supported everything I have on it and much more.


Thanks @bryonhu. Right. I forgot to mention that I removed the SD card after flashing the firmware. It’s an important point. I believe Wyze recommends removing the SD card when troubleshooting.

Another thing I tried was temporarily disabling blocking on the pi-hole that serves DNS for the VLAN.

Aside: as others have said, it’s highly informative to look at what these Cams are doing that they don’t need to be doing from a functional perspective. I’m not suggesting anything nefarious. But if Wyze ever pushes firmware that requires extraneous comms as a condition of core functionality, that will be the end for me.

Following up on a suggestion from @IEatBeans - I tried a different (older) phone Android phone. Unfortunately, I had already removed the Wyze app so I wasn’t able to test an older version of the app. I re-installed from Google Play. Exact same behavior. The old phone is one major release of Android behind, so at least we learned that’s not it.

Does anyone know if Wyze makes older versions of the app available for testing?


Ah, thank you for the clarification. The CIDR notation went right past me. In any case, I suspect that the problem is with the SSID name or the passphrase tied to the SSID. I’ve seen this type of behavior where the cam gets an IP from DHCP server, but never connects to the network and thus never completes the setup routine.

Consider this test:
If possible, create a simple SSID with no spaces and a simple WPA2 passphrase that does not have a space character at the end of it. Then try running through the setup routine using that SSID.

1 Like

K-Dog - You might try taking one (or both) of the cameras that are not connecting to a friend’s house and try temporarily setting it up there. If it works there but not at your house, that will point you in one direction. If it still does the same thing, that will also tell you a lot. Probably worth a try…


I have the same problem. I tried setting the camera up in three different locations and it fails at all of them. I can get to connected to internet but then the final portion of the install still fails. Interestingly I’m also using a pixel phone which is the only similar link I’ve been able to find between us here.