Cam v3 Looping after update of firmware

Ok I have looked in the forum and tried a couple of the solutions that have been shown in the replys to other cam v3 issues. So here is my problem

I have just updated my Cam v3 to the latest firmware are that it stop working.
! - reset the unit no luck
2 - reset my router no luck
3 - manual downgrade of firmware (So I formatted my SD card 32gb fully not quick and placed the demo_wcv3.bin file onto the empty SD card. Held down the button 3-6 seconds purple light all is good in the world. After around 30 seconds the light goes red and the unit resets itself and sits with a flashing red light ready to be setup). Strange i thought as the instructions says it takes around 3-4 minutes to complete. Follow the instructions to setup and everything seems to be OK. Then after complete setup using the app the unit restarts and we are back to red light flashing.

I do not at present have a smaller SD card (going to go get one to check) but can any see anything I have missed?

Sounds like you’re doing it everything right. The 32 Gb sSD card should be fine. The format is FAT32.
Seems the cam is not finding the file to boot-load.
You might try re-naming the file to just “demo.bin”, see if that works. :man_shrugging:

Nope that did not work. With the demo.bin file it would not go into upgrade/downgrade firmware mode (purple light). The camera is working OK as i just had a look at the SD card and it has recorded video of my desk where I have it at the moment. But Still looping and with the red light flashing in the “ready to connect mode”

Update - Just went and got a smaller SD card 16Gb, made sure that it was Fat32 formatted put the last version of the firmware before the new update onto the card and still have the same issue, goes for around 30 seconds with purple light then goes back to red flashing light

Time to call Wyze Support. +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT

I do have the same problem. I updated my cam v3 to with the app and I couldn’t connect to the camera anymore. I tried resetting the camera (holding setup until the IR lights flashes). I was still able to setup the camera with the QR code, but after the setup was complete, the app (Android) wouldn’t connect to the camera. I also flashed the and later on the firmware manually with a micosd card but the same issue persisted.
I then flashed the original firmware, which brought back the camera to life. I was able to set it up and access it like before. I upgraded it to firmware through the app, which worked, and to, which brought back the initial problem (camera can’t be accessed). When looking on the microsd card, I see a rebootlog folder with reboot_[mac address] files created every minutes.

Thanks for all the support fro FrancoFun and Dr.know. I have found a work around for the camera for now. I used the RSTP version of the firmware and that has seemed to solve the problem. I used a smaller card to flash the firmware (Note hear though, the time only took around 30 seconds to flash) Went through the setup on the app and this time got “setup completed” and fingers crossed all working for now (I may not upgrade the firmware for a while LOL)


I’m having the exact same problem with my cam v3. Mine gets through setup and gets added to the app but as soon as you go in to view the live feed it won’t connect. Tries the 3 times and fails and its during this trial that the camera clicks and reverts back to flashing red.

If it can be of any help, I figured out the latest firmware I can install on my camera for it to work was
All the more recent firmwares cause the issue. The RTSP firmware also brings back the camera to life.

The RTSP firmware is no longer available

RTSP was considered a beta feature and we are currently assessing the path forward as the firmware versions have aged quite a bit. We have removed the firmware files for these versions for now and we’ll update the pages when plans are finalized. Please note that firmware files take a while to work on and test so you may not see an update in the near future. We apologize for the inconvenience.

I am experiencing the same issue and have attempted all described here (reset the unit and flash firmware) Nothing works. I go right back to the flashing red light and “Ready to Connect” over and over.

Any other suggestions on how to fix this or should I start considering this camera a lost cause ?

I had to consider mine as a lost cause. Worked with support and couldn’t come up with anything. Hopefully youre within warranty unlike me who was just outside of the year so it became a paper weight. :confused:

That sucks. I just submitted a ticket. I think I too am out of warranty at this point (I was an early adopter). Lot of good that’s doing me now.

I never do update’s any more on any of my cameras as more times than not they crash. As long as they work for me, I don’t mess with them. If you update and you’re out of warranty period you may be screwed even if it’s proven to be a bad update.