Cam v3 Cant get firmware to flash

For the life of me I cant get the camera to boot into firmware flash where im supposed to get a solid purple light. I know your suppose to shut the camera off (I have a switch on my flood light in my house so I just turn the switch off) then hold the setup button while powering it back on (again i just flip my switch on) and hold it for 3-6 seconds until the red and blue light is solid purple.

This just never happens at all, it goes straight to ready to connect if I hold it long enough or factory resets it which also doesnt downgrade my firmware which is the reason for this to begin with. Ever since updating a few days ago to the latest firmware the sd card doesnt record audio anymore.

I know this to be true because saved videos from the sd do not record audio, playback doesnt produce any audio from the sd card, even saving a video from playback and then taking it to a different enviroment (my pc, VLC Player, Media Player) also does not produce any sound. Just a static sound at the beginning of the video and then nothing like its on mute.

Ive tried toggling sound on and off, during before and after my videos on both the playback and in the advanced settings. Ive tried from iOS and Android both neither work. The new firmware has essentially broken my SD cards audio recording which is unacceptable its half the reason I have the cameras to begin with.

So I went and downloaded a prior firmware, formatted a 32gb wyze brand sd card and a brand new sandisk 32gb sd card i bought today using both windows and the sd card format utility everyone on reddit suggests both quick and full formats, extracted the bin file to the root of the sd card and renamed it with .bin at the end like the instructions say to do. Then I turn the power off, install the sd card, hold the button while turning the power back on, and hold it for 3-6 seconds but I NEVER get the solid purple light.

Like I said it just goes to setup mode or factory restores the settings in the camera (again this doesnt revert back the firmware for some odd reason but does reset every one of my settings quit annoyingly). So I know im pressing the button as those functions work from it and I can hear and feel it “click down”. Im at a loss… the thing just wont enter the firmware flash mode the instructions speak of no matter what I do with either SD card.

Maybe im missing something… I just take the .bin file out of the download and put that in the root of the sd card and rename it with .bin at the end so it reads demo_wcv3.bin right ? I don’t need the zipped download in there or the MacOSX folders do i ? I tried it those ways to though and still didn’t seem to work…

The file should already have the .bin extension. What is the actual file name you used? They are specific for each camera type. Also, since it is Windows, it could be naming the file demo_wcv3.bin.bin, which won’t work. Make sure you’ve enabled the filer to show file extensions.


Does this look correct ? Thats with extensions on I haven’t added .bin to it

Here is another thread with helpful tips. Good luck.

Thanks but I read that post and there isn’t a solution in there, the OP never solves it. Some guy named Mcallister had luck doing a full format with SD Format. I have that software and have tried a full format on 2 different cards, one brand new sandisk and a wyze brand sd card I already had in one of my cams that I know was working.

Those solutions if that’s what your referencing haven’t helped any for me. I posted a picture to the previous reply to show my sd cards contents and how I have the bin file located and named. I don’t remember if I tried it without renaming the file with .bin at the end as the previous guy stated may have actually been resulting in .bin.bin because I didn’t have the filter to show extensions set.

Like I said I can’t remember if I renamed it every time but if I did maybe that’s all it was just waiting on him or someone to get back to me to say that it looks right. Thank you though for taking the time to try to help me I do appreciate any tips I haven’t already read or thought of.

1 Like

It does look correct. Which version of the firmware did you download? I know for some of the older versions you need to do a factory reset first. Did you use FAT32 for the format on the cards?

1 Like

Your the man, that was the problem I was renaming it .bin and didn’t need to. Just couldn’t remember if I had tried without renaming it and obviously I did not. The instructions however need an update then, because the only reason I even figured I had to was due to right in the instructions it tells you to rename and add .bin at the end which is false.

Maybe in previous versions of windows ? Im on Windows 11 Home Insider Preview so basically a beta test version of windows 11 (was the only way to play Assassins creed Valhalla lol). Anyway thanks man I will mark that the solution I figured it was something simple and stupid.

1 Like

Also sorry just noticed I didn’t answer you all the way. I used Fat32 yes and I did have to do a “factory reset” because I tried the firmware for v3 cam from December (the previous to this problematic one) and it was still an issue. The next available download was all the way back in May of 22’ but it solved the issue my SD Card recordings have audio again.

Glad you got it fixed.

Thank You for this thread. I was in the same boat. I’ve flashed three other Wyze Cameras. 1-v2 and 2-v3’s. I grabbed a new v3 camera thinking it would be no big deal. I tried to flash to the RTSP at least 20 times and was thinking I was too late to return the camera. After reading this thread this finally worked:

  1. Format Fat32 full on 32GB micro SD Card from my windows laptop
  2. Copy demo_wcv3.bin to root of card
  3. Add Wyzev3 Cam to my network
  4. unplugged Camera
  5. installed Micro SD Card
  6. Removed setup plug from camera
  7. Plugged USB Cable into switched USB plug
  8. Powered Camera up with Setup button pressed with TORX bit
  9. Camera flashed purple and went to blinking red
  10. Re-added Camera to Wyze App
  11. Firmware now RTSP Version
  12. Enabled RTSP switch
  13. Added Camera to OBS Studio v29.1.3 (This works OK as NVR)

I think it was the TORX screwdriver, I could hear/feel the button but without the cover, I could press pretty hard on the button.

1 Like