Cam not detecting SD card

Anyone know why my camera won’t detect my sd card anymore? It’s updated, I’ve deleted it multiple times and re installed, it worked for a couple hours and then it’s back to not detecting.
Also I keep losing connection. Wifi range isn’t a problem. What can o do to fix this

model? of camera
sd size?
did you format your card?
sd card brand? lots of fake large cards from online store.

ios or android? app. version|?
firmware version?

One of my 34 cameras has a failed uSD Card reader. Like almost anything else, it can happen…

Hey, is your camera mounted outside? If water gets into the micro sd card sometimes it can fry. The v1 and v2 are not rated for outdoor use. Have you tried that sd card in other cams or other cards in that cam?

Wyze v2
It doesn’t let me format it
Sandisk 32 GB
iOS latest updated one
It was working fine until yesterday it stopped working all of a sudden.
And no, I keep this camera indoors at all times

Have you tried unplugging and plugging the cam back in? What error are you getting when you try to use it.

1 Like

I had no sd card recordinging yesterday neither with my V2 but it is working today.

My suggestion us

Submit a log.
remove sd card and see if you can read files with PC tablets etc. U need OTG for tablet.
Save the files you need and format it with FAT32.

See if V2 detects the sd card.

As KyGuy2002 said, “have you tried that sd card in other cams or other cards in that cam?” If you have another cam or another sd card, this test will tell you immediately where the problem is.


Can you provide the the Firmware of the Camera you are using.

I would also take the SD Card out and format it on a computer. Try Fat32 first and see if that corrects it. I have also seen issues when Certain SDCard hit a max write count. Although this is not the norm, I have still seen it. It will present itself similar to what you are seeing. If you have another SD Card, I would try that and see if it makes a difference.

1 Like