Bulb randomly turning on

This is how I have this set up.

Rule 1. Wyze Contact Sensor is connected to “Room 1” door, and when “Room 1” door is open it triggers Wyze Bulb in “Lamp 1” that is located in “Room 1” and another Wyze Bulb in “Lamp 2” that is located in “Room 2” (in essence when my kid open the door multiple lights will go on so my kid can see at night when going to the bathroom. This is rule is done by “Device Trigger”

1a. I need to control time when Rule 1 is going to work, otherwise my light will be going ON and OFF in multiple rooms 200 time per day as doors are constantly being open and closed or just left open so light would stay on. So only way for me to do that is to add Wyze Plug to “Lamp 1” and “Lamp 2”.

Rule 2. Wyze Plugs are connected to “Lamp 1” and “Lamp 2” and through “Schedule” rule they are set to work between 8pm and 6am.

I dont have any issues with rules, they actually work really well, only problem that I have is that Wyze Bulb in “Lamp 1” will turn on at random at night (last two times it was around 3:20 and 3:50).

Do mu rules make sense and what my problem is?

Ah. Now I understand why you have them both.

When you click on the relevant contact sensors, do they show any events happening around that time? Or no?

Nothing at all. Also, that same sensor controls two Wyze Bulbs, one in “Lamp 1” and another one in “Lamp 2”. Only Wyze Bulb in “Lamp 1” is acting out.

Not only I have deleted bulbs, i did renamed them, i did also delete plugs and rules and did everything from scratch.

Reason why I have switch (I am assuming you are referring to plug) is to be able to control time when lights can be on…I did replay to “nerdland” few posts down (or up when you read this) explaning my rules and why i have them the way i do. Unless someone can help me with setting up rules differently.

Ah, I see. Have you tried swapping the bulbs? If the lamp has a short or something, maybe it’s cutting the power and turning itself back on, which would cause the bulb to turn on.

Here’s what I’d try, in order:

  • Swap the BULBS and see what happens

    • If it happens in the OTHER lamp after you swap the bulbs, it would seem to be a problem with the bulb itself. At least we’ve narrowed down the culprit. Maybe you can contact Wyze support and they’ll send a replacement.
    • If it happens in the SAME lamp after you swap the bulbs, we need to test more…
  • Try swapping the PLUGS next and see what happens
    (If you’re at this step, we’ve already eliminated the bulb as a culprit, so the bulbs can be in whichever lamp you want. Keep each lamp in the same room it was in before.)

    • If it happens in the OTHER lamp after you swap the plugs, it would seem to be a problem with the plug. Again, maybe contact Wyze support at this point
    • If it happens in the SAME lamp after you swap the plugs, we need to test more…
  • Try swapping the LAMPS next. Put lamp from room 1 into room 2 and vice-versa.
    (If you’re at this step, we’ve already eliminated the bulb AND the plug as a culprit, so the bulbs and plugs can be connected to whichever lamp you want.)

    • If the problem continues to happen with the SAME lamp that caused problems before, then it seems to be a short in the lamp itself.
    • If it happens in the OTHER lamp (but in the same room that caused problems before) then it seems like a short in the wall outlet.

Make sense? If you do that, you can at least narrow down which part of the setup is causing the problem.


Yes, I meant the Wyze plug which BTW is really a smart switch.

I don’t have a Wyze bulb so I don’t know what schedule options are available for bulbs, but …

I still believe the plugs are redundant. There should be a way to set up a rule that says a bulb can only be ON at certain times. After all, the Wyze bulb is just a plug/switch with an LED light.

Oh totally. Hopefully they’ll continue to make their rules system more robust so that this won’t be necessary.

As of right now those rule options are not available, so until then this is only way to do a simple task :smiley: is by two sets of rules and two products.

I am doing this tonight, so lets see what happens.

This is similar to a set up in beta testing right now. Where a rule is only available during certain times to which you can set limits. For instance I have a rule that says when a certain sensor in my house is activated between 6 a.m. and 7 a.m. a certain light will turn on. If that sensor activated another time that light does not come on

1 Like

With this rule I would eliminate need for plug, can you set up single rule that is between 8PM and 6AM or you would need two rules like its the case today?

So far all my rules to go past midnight have worked correctly. So you would only need one

I’m curious to hear what happens. Be sure to send an update. :slight_smile:

1 Like

I did this, and light has been coming on,

Same here, lights is randomly turning on.

This one as well, did not help.

Besides bulbs in two lamps, my third one that is at the outside patio door also has been acting out and turned on few times for no reason…

Besides Wyze bulbs i also have Hue bulbs and i have never had a single issue with them turning on for no reason?

Could it be bad set of bulbs? Am I the only one with this issue?

dmmatic, there is clearly a known problem with the Wyze bulbs randomly coming on as evidenced by all the forum reported problems. In these cases it is not a power blip issue.

Not sure if Wyze acknowledges this yet, but again way too many people are reporting the same problem. Check out other forum posts if interested as there are many reported instances of this bulb problem.

I am a Wyze fan and hope they fix this one soon

Hi JGvegas, i was not aware of it till this morning when another post did pop on (I thought i did search for it before posting but i guess i didn’t), and you are right there is few I am seeing and one with over 100 posts. Same here, i really like Wyze but at this point its an issue as I cant use bulbs nor sensors…

I can’t use Wyze plugs, either.

Plugs’ schedules don’t work on Saturdays!

Plus, on my Wyze app, there is no way to see each individual plug’s schedule; I see all of my plugs’ schedules all lumped together. I have no way to tell which schedule item belongs to which plug. You have to drill in to find out.

1 Like

I’m not clear about the results of your test. Only ONE of the lights was giving you the issue, right? Was it the same bulb the entire time, regardless of which fixture it was in, which Wyze Plug it was connected to, and which room the bulb was in?

If so, it sounds like you’ve ruled out the wall sockets, lamps, or Wyze Plugs causing the problem. So yeah, I’d probably contact Wyze support about getting a replacement bulb.