Bug: Floodlight PIR is disabled when switch control Rule is enabled

I have my floodlight hardwired on, and a wyze switch that doesn’t have any load attached. I set up two rules to control the flood light status without turning off power to the camera.

Rule 1) When Switch Turns on, turn on floodlight
Rule 2) When Switch Turns off, turn off floodlight

This works well for the most part. The camera stays on, and I can control the floodlight with my switch.

But there is a bug: When “Rule 2” is enabled the floodlight does not turn on when PIR motion is detected.

Note: The floodlight will still turn on if motion is detected by the camera.

Has anyone figured out a way around this?

When these rules fire, does it change the slider from AUTO to ON or OFF? If it’s not in AUTO, the motion detection by camera or PIR shouldn’t work.

The flood light remains on “auto” under the “floodlight control” section after either rule runs.

Again, after the turn off rule runs, the light will still turn on if motion is detected by the camera, but will not turn on if motion is detected by the PIR sensor.

@R.Good is the master ruler (no pun intended) and can give a better explanation as to your rule set up

Hey @R.Good how you doing

Any insight here ? Thanks

Doing Good @Rulwiz,

Thanks for the tag.

I thought I was, then @Omgitstony kicked me down with some knowledge earlier… maybe this is karma allowing me an opportunity to get my mojo back :rofl:.

Going to review and think on this for a moment, please hold.


I just did a test and set my Floodlight up to turn on if I double tap my switch, and turn off when I triple tap my switch

I made sure this worked, and turned the floodlight off and on a couple times using the double and triple press. All worked

I turned off Motion detection to turn on the floodlight just to test the PIR. And only have PIR turning on the flood light.

When I walked past the floodlight the Floodlight came on.

I then turned off PIR and set to detect motion only to trigger the floodlight

The floodlight triggered with motion

Turned both back on, and turned the floodlight on and off with the switch controls.

And…. Walking around the Cam/Floodlight the floodlight did not trigger

BUT…. (And I remember this from another test I did awhile back) it takes everything 10 minutes to reset/cool down.

I have no idea why… but look at the time stamps. At 9:11 the floodlight triggered where the in between 10 minutes did not, and my last trigger was at 9:01. Appears as if this is only the case if motion and PIR are set to trigger the floodlight, a new variable discovery, as I did not make the connection last time.

@Zackrr give the floodlight ten minutes after turning off from the switch and see if the floodlight triggers. Not sure this is a rule issue.

1 Like

Nononooo, “provided with knowledge”. No kicking was done, :slight_smile:

1 Like

That’s how the youngins’ say it… or at least used to at one time. It’s hard to stay up with the lingo, no cap.


I did some trouble shooting…

TLDR: It appears that the PIR will not work after a switch toggle, until you receive your next motion notification (or maybe until your camera cool down as ended).

Testing notes:

  • I left “motion detected by camera” and “motion detected by PIR sensor” checked for all of my testing
  • I do not pay for cam plus

Testing steps:

  • I waited until dark then walked outside without toggling the switch. The PIR sensor worked as expected (tested several times)
  • I toggled the switch then walked outside. The PIR sensor didn’t work. The camera sensor did work-- but there was a long delay [note I received a motion notification]
  • I walked in, then back out and the PIR was working as expected again (tested several times)
  • I toggled the switch and the PIR and camera would not trigger the light
  • checked the PIR and camera sensors after 3, 4,5,6,8, and 10 minutes, each time the PIR and camera wouldn’t work.
  • Around minute 11 I received a camera motion notification, and the light turned on. After this the PIR sensor worked as expected.
  • I toggled the switch and the PIR and Camera no longer triggered the light.

I have run into this same issue too, and wonder if anyone has solved it. I have a double press of the switch to turn the floodlight on for 1 minute. I have a triple press set to turn off floodlight. If I use either of these, the PIR sensor will no longer trigger the light. The floodlight control setting on the camera still shows auto, but it won’t work. After a restart, the PIR sensor works again. Any insight? Thanks in advance.

1 Like