Brave Browser & Wyze Shopping

Hello Wyze-ers,

I have a strange problem.
I primarily use the Brave browser on my laptop (Windows 11 Pro).
I realized that I cannot add items to my cart when I use this particular browser. Neither can I view any items in my cart using this browser.
I can use Google Chrome to add an item to the cart and view it. However, when I use the Brave browser, there will be NO item in the cart!
And this started just recently, so something must have changed with the Wyze shopping provider, no?
Is anyone experiencing the same and knows of a solution? I hope nothing in my browser is blocking the shopping.

I have Brave so I tested this for you and had the same issue. I checked the console, found out it blocking stuff, I found the problem. It wouldn’t let me add anything until I told it to stop blocking scripts. Then it worked. Disable blocking scripts as follows in the screenshot:

Now it should work for you for this site to add items to your cart.

You can toggle it back on after you complete your purchase, but scripts are used to place an order on the website, so if you block them (which Brave does by default), it won’t work.

1 Like

Strangely, the “block scripts” option is NOT enabled on mine.

Yes, I don’t know why it shows as disabled in the settings area, I know it does not make sense, but changing it there in the settings area does not fix it. I saw that too on mine, mine also showed disabled there, even though Brave has it active anyway.

Apparently, you have to navigate to the product you want to add to your cart, then click the lion head icon, then deselect blocking scripts there, exactly like I showed in the screenshot:

Then it will work. It seems like a bug in the Brave Browser to me because in settings it says it’s not blocking scripts (mine did too), but then on the Wyze website it showed it was indeed actually blocking them anyway. You also can’t just disable the “shields” toggle or it will still block everything, you have to actually click on the advanced controls and disable blocking scripts while you are on the page of the product you want to add to your cart and you must do it through the lionhead icon next to the domain field. Any other way wasn’t working for me. AND after I added an item to the cart and went to a new page (like my cart), brave had blocking scripts toggled back on again, so it seems every time I navigated to a new page it was forcing blocked scripts everywhere even when we have it disabled in settings.

This is most definitely a Brave bug, not a Wyze one…but I was able to work around the bug and make it possible to add things to my cart.

ALTERNATIVELY you can log in to the Wyze app and click on the Shopping Tab to purchase that way instead :+1:

I hope that clarifies and helps.

1 Like

Thank you for looking into this.
What worked for me was to just turn the shields DOWN for With that, I can now add items to the cart and transact.


Good! I’m glad that worked for you. :slight_smile: Strangely when I turned the shields down for Wyze dot com it still didn’t fix it for me, That’s when I tried just doing the script blocking toggle and it worked. I thought it was strange since the script toggle should be part of the shield toggle, logically… but for whatever reason it didn’t for me. Glad it worked for you though! That’s what matters. At least we found a way for it to work for you! :slight_smile:

Best wishes.