Battery Cam Pro (useless!)

I have a new battery cam pro. I have it just outside my window, about 40 feet or less from my house where I have my Wi-Fi. I can almost never connect. Once in a great while I won’t get the error code 20 and I will get a live image. It is recording motion, but all I get is a static image, and ALWAYS get an “Failed to upload” message. Wyze support is pathetic. The “chat” person just recommended I return it. I’ve been on hold for 55 minutes now on the phone, and don’t ever expect anyone to answer.

My Outdoor cam 2’s work fine, and they’re further away than the Battery cam pro.

Any suggestions would be appreciated, otherwise I’m dumping all my Wyze cameras!

I’m really getting sick and tired of Wyze. How has a company with such potential fallen so far?


Counter-Point. I have 3 of them and 7 other cameras that all work great.

What model of WIFI router do you have?

1 Like

Do you have a ticket number from calling Wyze? if you do, can you post it here?

I am sorry you are having and issue, I am a community volunteer and also have a Battery Cam Pro. I do have a couple of questions:

  • What Firmware version of your BCP
  • What app Version are you running
  • do you have Cam Plus? Without Cam Plus, you will only receive a still image of the event.

Here are a few things you can try:

  • Clear Cache from within the App
  • Since you have Android: Shut the app down, Long Press on the App Icon and select App Info, do a Force Stop, go to Storage and Cache and clear Cache (NOT Storage).
  • Remove the battery from the BCP for a few seconds and then put it back in. This will establish the connection to your network again.
  • Restart your phone or Tablet

Log back in and see if you can connect.

My Firmware for the BCP is:
My Plugin for the BCP is:

1 Like

The router is a Sonicwall TZ400 and the wireless access point is a TP Link XE75 mesh system.


  • What Firmware version of your BCP
    Can’t tell - I can’t connect to the camera!
  • What app Version are you running
  • do you have Cam Plus? Without Cam Plus, you will only receive a still image of the event.

BTW, I’ve done all of that (force app stop, clear cache, remove battery from the camera). Didn’t help.

Thanks, can you provide the ticket number when you spoke with Support?

I did a “chat” with support - but they weren’t any help, and I don’t have a ticket number. I can NEVER get thru to support on the phone (after an hour on hold I was disconnected).


Got ya, thanks again. I will see if I can get eyes on this.

@Bertsirkin - I had to look up your equipment to see what they are. The first thing I notice is that a Sonicwall tz400 is billed as a firewall. I know you can make it a router but my first look would be inside that device. I do small business I.T. help for folks and almost always, the first place to look is the network device if you are having widespread network issues. Simply because it is the traffic cop. And since that device is meant to stop EVERYTHING it doesn’t understand, which is a good thing for a business, it could be stopping Wyze stuff for some reason?

Your Mesh WiFi is pretty good according to the net… so it should handle the workload and is probably configured to be Home Network friendly out of the box.

But, in instances like this, everyone is a suspect and you have to check down everything. I use the Wyze Pro Mesh WiFi and have 3 outdoor cameras about 35 feet away. Going through 1 wall. I have no issues. All my other cameras, TV, sensors, 2 dozen rules, computer, etc. have no issues with the streams. I have 500 Mb down and 20 Mb up. (network speed is bits not bytes). Don’t get me wrong, the app hangs on my phone and drops sometimes. I just force kill the app and reopen and I see the cameras right away… but, overall. I can almost always open them and see what they see.

I don’t know if that helps. A good deep dive to all network settings is a great place to start IMO. Just to be sure. Turn some knobs and see what happens!


I don’t think it’s the firewall, as it works sometimes. If the firewall was blocking it, it wouldn’t work at all.

Appreciate the help, but I may just return it - the biggest problem is that Wyze doesn’t provide any support anymore. Seems like they’ve spread themselves too thin and can’t support everything they have - let alone the security issues they don’t seem to want to address. I have 11 of their cameras, but may just dump all the cameras and stick to cameras that support RTSP so they’ll work with Blueiris.

I have the same problem, the QR code almost never works outside. I constantly have to power cycle. I hate my out door camera. The support is terrible with this company. We are switching to our cable provider. That camera never goes down. I dislike Wayze

I would recommend that you try moving the camera inside, close to your router and see how it works. I had a problem with the Wyze OG camera when I first got it. Worked sometimes and then didn’t work right. Did all kinds of different things. I Thought my modem and router were fine. I use a Spectrum provided modem and router. Found out there was a newer version of both so on a whim, swapped mine out for the newer models and low and behold all of my camera problems went away’

How are you powering the camera? If you extended a long USB cable it may be dropping voltage on the way. Did you try putting 110v close to the camera with the charger and a short usb cable?

I had a V3 that did the same. Customer service agreed it was flakey and extended a gift card with which I bought a new one. That has worked perfectly with the same extended use cable. Maybe some units were too sensitive to the voltage drop.

Good luck…

It’s a battery powered camera.

FWIW, I returned the camera to Wyze for a refund and will be getting rid of all of my Wyze cameras. I’ve found better alternatives.


I can’t, it’s wired into the house. It’s the flood light. The camera is shot.


It’s wired into the house