Battery Cam Pro SD card not working

Continuing the discussion from Playback issue with my V3:

This exact thing is happening to me but with my two Battery Cam Pros. I cannot access SD card anymore after an update. I have submitted multiple logs since April 16 and there’s no fix according to Wyze. Please let me know if anyone knows if there will be a fix soon?

1 Like

Same here. Just dropped in 3 new Battery Cam Pros for a relative today. Set them up in his living room including a 256 GB SD Card (Sandisk C10 … forget the other details). Got the ding-ding during setup indicating the card was there.

Had to wait a day to install/mount - needed longer screws, and no cards shown after mounting.

I really hope they fix it soon. This is so frustrating that we purchased multiples and they don’t function properly nor is a fix in the short future.

Hear that.

Going to try a couple different SD cards, but here is what I used. Same card - different size - in v4 and Battery Cam Pro. They just don’t register in the BCP after initial setup.

Have tried formatting to FAT32 and reformatting as EXFAT. NO diff. One of the card did kinda show in one camera after formatting as FAT32 - but then disappeared as soon as I left the camera and then went back into it.

used in 6x v4 Cams
SanDisk 512GB Ultra microSDXC UHS-I Memory Card with Adapter

  • SDSQUAC-512G-GN6MA

used in 3x BCP Cams - not recognized after initial setup
SanDisk 256GB Ultra microSDXC UHS-I Memory Card with Adapter

  • SDSQUAC-256G-GN6MA
2 Likes

Tried with another SD card I had lying around - an older 32 GB Samsung SD card, and its recognized in the BCP without issue. So may drop some more money on other cards in the meantime.

Was looking to downgrade the firmware but don’t see there are links to older versions for the Battery Cam Pro.

None of the solar panels I have connected are charging either. Tested 1 cam and 1 panel before install and it worked fine. Now nothing.

New cam 4 updated camera inserted SD card NO dig ding nothing, just a flashing red light on camera. Took SD card out, camera goes back to the blue light and functions normally. Put the card in computer nothing, would not even recognize as a drive. Tried 3 different SD readers, nothing. I am thinking either the camera killed it or they are a bad batch.