Base station not connecting - flashing blue light

Thank you for your suggestion! I will try that when I get home.
Your help is very much appreciated!

I posted about this issue a couple weeks ago. Earlier in this thread someone suggested restoring firmware from June or July. It worked well for me. Have you tried that?

1 Like

How do ou go back to a specific firmware?

Directions here, make sure you follow them correctly: Use a good clean SD card

Great detailed steps. As you have seen others have benefited from this. Great job.

1 Like

Thank you so much Muda888! Tried everything and only manual July firmware installation and reset helped.


I have a lot of time trying to get the base station to connect to wifi. Updated to newest firmware and also tried some of the older fimrwares. But the base station always just starts with yellow light for a while and then changes to blinking blue. The base station doesn’t seem to read the sd card. I’ve tried one that was laying around and also a brand new card.
The same happens when I try to connect on the router at work.
I’ve contacted Wyze support. They sent another base station, same problem.

What wifi equipment do you use? I had the flashing blue in my base after I went to wifi mode, but it connected after I went into my Ubiquity access point settings and enabled “legacy 11b” support in the ssid I was trying to connect to. I’ve seen a few times other users on here having the same success. My exact setting will probably look different than your router settings pages but I think there’d be a similar labeled toggle somewhere in the Wi-Fi settings.

Ok The firmware update notes seem to indicate this problem has been solved, However, I cannot connect to Wi-Fi, and my situation is unique and different from most situations described here because I have those mesh network Plume pod thingys (and always wondered why the pods had an Ethernet port and cable, but now I know). So after setup, when I unplug the Ethernet cable connecting the pod to the base station, the blue light flickers; when I plug it back it and only then, the blue light becomes solid again and there is transmission. So I am inclined just to keep the Ethernet cable connected to the bas unless you guys think for some reason I shouldn’t.

It is so complicated. The system was set up by the TV cable company, and unfortunately, I am not that savvy. As I said, it is a mesh system and I am afraid to mess with it without calling the cable co’s tech support. I just wondered if it was OK to leave the Ethernet connection plugged in. I think I will call the cable system, however.

Yes it is OK to leave the ethernet connection plugged in. Mine has been plugged in for over 1 year and my 4 cams all have a good signal. I have never tried to use the base on wireless, no need.

1 Like

Thanks so much. I think this may be the only way it will work for now at least.

I had the same basic issue.
Following the links and comments (Thank You), I connected via hardwire, manually loaded to the latest firmware (had, now and allowed the unit to reboot/refresh. When the APP showed all was connected, updated and properly confirgured, I disconnected the hardwire. After a few minutes of flashing blue light, it reestablished the wifi connection and ALL IS WELL.
(note: You don’t need to erase anything off the SD if there is enough space for the firmware update directory. Be sure to remove the update after the reload from the SD when done.

its 07/2022, i just got my wyze outdoor and it took 2 hours of headache trying to figure out why the base just keep on blinking blue. i swapped out the ethernet cable that came with it with the one i have lying around and that fixed my issue. now it connects each time i unplug/plugging it.

1 Like

From Asus router DHCP client list, I can see my base station and its IP address. My base station is still blinking blue light. I guess I don’t have the same problem.

Switch away from wpa3? Is it connected via Ethernet cable or wifi?

connected through ethernet. I have changed to cat 7 cables as someone suggested. same flashing blue light.

I was able to get my device to connect after changing the wireless router settings. I noticed that when I changed to the new WPA2 and WPA3 option, I had this problem come up with the blinking lights. Nothing worked to get it connected. I then changed the authentication back to TKIP and WPA2, and now the connection is fine. Give it a try if you haven’t done this option yet.

I am going to return my camera tomorrow. It’s a piece of junk. You would think that a technology company today could make connection an easier process. When you buy something made by Apple, it just works. Not so here. Extremely frustrating. Very poorly engineered. Not recommended.

Perfect response from someone responding to an unrelated 2 year old thread. Today’s Apple customer!!!