Automatically start vacuuming when I leave home (via Wyze app or IFTTT)

I would like my Wyze Vacuum to run any time I leave the house (and trigger a geofence). This could be added as a feature in the Wyze app, and/or by adding Wyze Vaccuum support to the IFTTT integration (so we can make a recipe using IFTTT’s Location triggers).

[Mod Note]: Post was moved to this category as your request is satisfied by existing functionality.

You should already be able to trigger the vacuum via a Location Trigger. If you don’t see this feature under Create Rule, please state your Wyze app version and Vacuum firmware version:


1 Like

I love the name of your Vacuum. :slight_smile:

1 Like

Ah, nice! I was looking under the vacuum schedules, and didn’t see the new “Pilot” feature on the Home Screen menu. Thanks!

1 Like

Don’t forget the permission settings for geofencing. I think I had to set location for Wyze app to Always and Precise Location. And turn Background App Refresh on for the Wyze app.

@Seapup , I have the app settings running in the background set to on, Where do I turn on precise location and background app refresh?

My comment above was for an iPhone user. Which phone/tablet and operating system version are you using?

this was for a similar problem with geofencing in the android app. I am trying to trigger the lights on by location. Alexa handled this before I found the location triggers in the wyze app, but apparently just there for looks.

The location of location-based permissions vary depending on phone/tablet and operating system version. Need to know to answer your question.

moto g8 power running v11. Location permissions are allowed all the time in android along with background restriction- the app can use battery in the background.

Your problem is either phone settings, app settings and/or created Rule.

Phone settings… I’m not familiar with G8 and Moto’s My UX, but here are some general Android 11 settings to check:
Android Settings > Location > Improve accuracy > Toggle both WiFi and Bluetooth scanning on
Android Settings > Location > App permissions > Wyze > Allow all the time
Android Settings > Apps > Special access > Wi-Fi control > Wyze > Allow app to control Wi-Fi > toggle on
Sounds like you already checked battery settings to disallow putting the Wyze app to sleep. Seting is at: Android Settings > Apps > Special access > Optimize battery usage > All > Wyze > toggle off
If you have an auto-memory cleaner, make sure you exclude the Wyze app to keep it running in the background.

Wyze app settings:
Wyze app Home > Account > App Settings > Running in the background > toggle on

Please post a screenshot of your Rule/Location Trigger.
Also, check your Rule history to see if your rule triggered: Wyze app Home > Account > Rules > History > look for your rule name and tap the down icon to the right to expand for details.