App V2.26.21 & Camv3 setup

I updated my app to see if it would update my Camv3 that I bought in May of 2021 and it did only if I unplugged the power.
Next I tried to connect second Camv3 that the Support team told me to trash because they said it was defective and it connected but for about 15 minutes.
I am wondering why it disconnected and I could not get it online again? Was the mac address not recognized by their server because they refunded me the money for it?
If so Why am i being punished for their inability to determine that it was their app and other bugs causing the problem.
Do they realize how much time of mine was wasted trying to get something as simple as this connected and not it’s not able to connect anymore?
I am not confident of there products and apps anymore.
I am open to a response from the manufacture by phone if they are really interested in my findings.

Interesting have you tried to sign out then back in on your app?also have you re booted your wifi and run a test on it